[RELEASE] OzWeather - Australian Weather Addon using BOM data

  Thread Rating:
  • 3 Votes - 4.33 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
bossanova808 Online
Donor
Posts: 2,244
Joined: Sep 2009
Reputation: 34
Location: Melbourne, Australia
Post: #406
Yeah I think all of iview has changed, I'll have to look into it.

Is it crashing or just going over that bit? I haven't see it crash as such yet...

My XBMC stuff:
find quote
fuggin Offline
Member
Posts: 64
Joined: May 2008
Reputation: 0
Post: #407
nope not crashing, just that the option is missing from the slideout menu. working fine otherwise.

XBMC Gotham 13.2 git20140719
Minimal Ubuntu trusty 14.04.1 x86_64
ASRock ION 330-BD Intel Dual Core Atom 1.6GHz
4GB RAM | HDMI Display | Analogue Audio | Flirc IR
find quote
bossanova808 Online
Donor
Posts: 2,244
Joined: Sep 2009
Reputation: 34
Location: Melbourne, Australia
Post: #408
Pretty much fixed, will request the xbmc Gods pull the changes...

My XBMC stuff:
find quote
bossanova808 Online
Donor
Posts: 2,244
Joined: Sep 2009
Reputation: 34
Location: Melbourne, Australia
Post: #409
Fixed and pushed as 0.7.0, should arrive with you in the next few days

My XBMC stuff:
find quote
fuggin Offline
Member
Posts: 64
Joined: May 2008
Reputation: 0
Post: #410
autoupdated to 0.7.0 today. Weather in 90 seconds still missing from slideout menu. video setting at default 1000k. otherwise working fine, not crashing.

Code:
17:41:06 T:140677954397952  NOTICE: ### Oz Weather-0.7.0 ### Oz Weather (Author: Bossanova808) Starting ...
17:41:06 T:140677954397952  NOTICE: ### Oz Weather-0.7.0 ### Called as: ['/home/xbmc/.xbmc/addons/weather.ozweather/default.py', '2']
17:41:15 T:140677954397952   ERROR: Traceback (most recent call last):
17:41:15 T:140677954397952   ERROR:   File "/home/xbmc/.xbmc/addons/weather.ozweather/default.py", line 601, in propertiesPDOM
17:41:15 T:140677954397952   ERROR:     url = "http://mpegmedia.abc.net.au/news/news24/weather/video/"+ video[0][0] + "/WINs_Weather1_" + video[0][1] + "_" + qual + ".mp4"
17:41:15 T:140677954397952   ERROR: IndexError: list index out of range
17:41:15 T:140677954397952  NOTICE: ### Oz Weather-0.7.0 ### Oz Weather (Author: Bossanova808) Exiting ....

XBMC Gotham 13.2 git20140719
Minimal Ubuntu trusty 14.04.1 x86_64
ASRock ION 330-BD Intel Dual Core Atom 1.6GHz
4GB RAM | HDMI Display | Analogue Audio | Flirc IR
find quote
bossanova808 Online
Donor
Posts: 2,244
Joined: Sep 2009
Reputation: 34
Location: Melbourne, Australia
Post: #411
Ok looks like they are playing silly buggers and moving things around a bit, maybe depending on time of day or server needs. I've made it more adaptable but will try it for a few days to make sure the urls are being consistent before I push out another update, don't want to irritate the xbmc devs who are very very buys right now...

Sit tight, I'll get it there!

My XBMC stuff:
(This post was last modified: 2014-03-08 13:03 by bossanova808.)
find quote
bossanova808 Online
Donor
Posts: 2,244
Joined: Sep 2009
Reputation: 34
Location: Melbourne, Australia
Post: #412
Ok it's been working a week now so I've pushed it. Give the xbmc folk a bit and it should arrive as 0.7.1 before long.

My XBMC stuff:
find quote
shayolden Offline
Junior Member
Posts: 2
Joined: Mar 2014
Reputation: 0
Post: #413
I can't get it to work. I've just done a fresh install but still it won't retrieve any data.

Log: http://xbmclogs.com/show.php?id=150285

Any ideas?
find quote
bossanova808 Online
Donor
Posts: 2,244
Joined: Sep 2009
Reputation: 34
Location: Melbourne, Australia
Post: #414
My guess from that is you haven't configured OzWeather with a postcode/suburb in the addoon settings.

If you have, can you tell me what you used?

My XBMC stuff:
find quote
fuggin Offline
Member
Posts: 64
Joined: May 2008
Reputation: 0
Post: #415
(2014-03-15 00:03)bossanova808 Wrote:  Ok it's been working a week now so I've pushed it. Give the xbmc folk a bit and it should arrive as 0.7.1 before long.
all working fine here. seems you've nailed it. thanks.

XBMC Gotham 13.2 git20140719
Minimal Ubuntu trusty 14.04.1 x86_64
ASRock ION 330-BD Intel Dual Core Atom 1.6GHz
4GB RAM | HDMI Display | Analogue Audio | Flirc IR
find quote
bossanova808 Online
Donor
Posts: 2,244
Joined: Sep 2009
Reputation: 34
Location: Melbourne, Australia
Post: #416
Great!

My XBMC stuff:
find quote
uksa007 Offline
Junior Member
Posts: 4
Joined: Mar 2014
Reputation: 0
Post: #417
Hi,

I have modified the Pan2 skin for Aeon MQ 5.

Where can i send it, so you can put it on the wiki?

Regards.
find quote
bossanova808 Online
Donor
Posts: 2,244
Joined: Sep 2009
Reputation: 34
Location: Melbourne, Australia
Post: #418
Well, it's a wiki. Might as well just pop it straight up yourself, if that works for you?

My XBMC stuff:
find quote
anibeasts Offline
Member
Posts: 95
Joined: Nov 2012
Reputation: 0
Post: #419
I can't get this addon to work.
I have 0deg for all my forecasts.

XBMC v13.1 Gotham, Aeon Nox 5.1.1
Windows 7 Home Premium 64bit SP1, CPU: AMD A8-3850 Quad Core Fusion,
MB: ASUS F1A75 V PRO, RAM: 4GB, Video: on board(HDMI), Sound: on board (HDMI),
TV Tuner: Hauppauge HVR-2200
find quote
bossanova808 Online
Donor
Posts: 2,244
Joined: Sep 2009
Reputation: 34
Location: Melbourne, Australia
Post: #420
Give me something to work on, like a proper debug log. Have you configured that addon? It doesn't have auto-location like the built in one.

My XBMC stuff:
find quote
Post Reply