XBMC 11.0 Eden: Beta available now

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Closed
Mach13 Offline
Junior Member
Posts: 32
Joined: Dec 2010
Reputation: 0
Location: Western NY - USA
Post: #61
Thanks DEV Team. Eden Beta working flawlessly here (Win 7 install). Many hours of use over the last two days!
find
VonMagnum Offline
Senior Member
Posts: 112
Joined: Aug 2009
Reputation: 1
Post: #62
It seems to work OK for the most part on my Generation One AppleTV units, but there is a tendency for the cursor to go haywire during some movies when bringing up the on-screen menu (acts like someone is holding down the left or right key a lot). The new weather options are nice. I like how you can read chapter names during movies now, but a drop-down chapter list to select from wouldn't be a bad idea.

The most disappointing missing feature is still no meta tag reading support for video files (M4V or MKV) despite the fact the audio tag reader can read them if the files are renamed to audio files (meaning little effort would be required to adapt it to handle video tags). This makes it impossible for me to ditch the Apple interface since many movies I have are foreign and what not and the DB lookups don't recognize them. Besides, I spent a lot of time making my tags the way I want them (for various cover art, descriptions ,etc.) and it just ditches them in favor of some generic scraper look-up. Imagine if meta tag reading wasn't support for audio formats. Well, video has grown up, guys. Scraping along with AVI is so last decade. M4V and MKV containers both support modern tagging. XBMC should too, IMO.

It'd be nice if multiple XBMC boxes could automatically sync any updates to the database with each other as well so I don't have to manually do it across almost a half dozen boxes. The AppleTV interface is old and not updated for V1 boxes anymore, but it can still sync them all via iTunes with zero issues on that end.

Save your "Program it yourself" messages for someone else. I'm just telling it how it is for my setup. I use XBMC purely for the occasional AVI or MKV file I need to view in a hurry and little else at this point. I was hoping to go CrystalHD and Linux+XBMC at one point for full 1080p support, but the interface issues make that impossible. Hopefully, I'll find another all-in-one solution at some point. But with newer audio formats that come with Blu-Ray and now 3D Blu-Ray as well, sadly this (ATV Gen1 or Gen2 + XBMC) isn't going to be it any time soon regardless.

Thanks for the update anyway. At least weather works again.
find
A3Baak Offline
Junior Member
Posts: 13
Joined: Oct 2010
Reputation: 0
Post: #63
I have a centralized database running for al my XBMC installations, when i tried it with Eden it was incredibly slow. Was something changed in the way Eden handles mysql databases?

Or do i have to make a new database for Eden?
find
gobbledigook Offline
Senior Member
Posts: 237
Joined: Aug 2009
Reputation: 0
Post: #64
hey! a big thanx! for all your hard work getting this ready Smile it worked for a bit for me but now i get the splash and then i'm sent back to my login screen Sad

i compiled on linux mint 12 using the steps i've posted here, and here is a debug log...

it ran a couple of times, i installed the youtube addon and the xeebo skin, then quit. when i went back in i switched back to confluence and turned on debugging, then next time i start, as described above.

EDIT: nothing a reboot didn't fix!
(This post was last modified: 2011-12-28 14:39 by gobbledigook.)
find
RichH Offline
Junior Member
Posts: 27
Joined: Nov 2011
Reputation: 0
Post: #65
figofago Wrote:Thanks but still don't get it. If I understand it right, files copied to movies directory should be vissible even if not processed by the scraper (this would be great)? If so, it doesn't work for me. Still need to access files mode to see them. What is the expected behaviour?

The way I understand this is:

Files = looking at the file system you added as a video source so you see all the media files you have in that area.

Library = looking at the database which has recognised media files in you file system you added as a video source. Any media files it has not identified and added to the database will not show.
find
Ned Scott Offline
Team-Kodi Wiki Guy
Posts: 21,883
Joined: Jan 2011
Reputation: 289
Location: Arizona, USA
Post: #66
A3Baak Wrote:I have a centralized database running for al my XBMC installations, when i tried it with Eden it was incredibly slow. Was something changed in the way Eden handles mysql databases?

Or do i have to make a new database for Eden?

VonMagnum Wrote:It'd be nice if multiple XBMC boxes could automatically sync any updates to the database with each other as well so I don't have to manually do it across almost a half dozen boxes. The AppleTV interface is old and not updated for V1 boxes anymore, but it can still sync them all via iTunes with zero issues on that end.


http://wiki.xbmc.org/index.php?title=HOW..._libraries
find
Ned Scott Offline
Team-Kodi Wiki Guy
Posts: 21,883
Joined: Jan 2011
Reputation: 289
Location: Arizona, USA
Post: #67
VonMagnum Wrote:The most disappointing missing feature is still no meta tag reading support for video files (M4V or MKV) despite the fact the audio tag reader can read them if the files are renamed to audio files (meaning little effort would be required to adapt it to handle video tags). This makes it impossible for me to ditch the Apple interface since many movies I have are foreign and what not and the DB lookups don't recognize them. Besides, I spent a lot of time making my tags the way I want them (for various cover art, descriptions ,etc.) and it just ditches them in favor of some generic scraper look-up. Imagine if meta tag reading wasn't support for audio formats. Well, video has grown up, guys. Scraping along with AVI is so last decade. M4V and MKV containers both support modern tagging. XBMC should too, IMO.

Someday. It wasn't planned for Eden, but I do believe there is work being done on this front.

Quote:I was hoping to go CrystalHD and Linux+XBMC at one point for full 1080p support, but the interface issues make that impossible.

http://www.stmlabs.com/projects/crystalhd-for-appletv/

Very easy to install, and what I use on my ATV1+BCHD

Quote:Hopefully, I'll find another all-in-one solution at some point. But with newer audio formats that come with Blu-Ray and now 3D Blu-Ray as well, sadly this (ATV Gen1 or Gen2 + XBMC) isn't going to be it any time soon regardless.

AudioEngine will be in nightly builds shortly after Eden is done, if you can't wait for XBMC v12.
find
A3Baak Offline
Junior Member
Posts: 13
Joined: Oct 2010
Reputation: 0
Post: #68
Ned Scott Wrote:http://wiki.xbmc.org/index.php?title=HOW..._libraries

Thx, should have looked it up myselfWink
find
tcman47 Offline
Fan
Posts: 426
Joined: Jan 2009
Reputation: 1
Location: Naperville, IL
Post: #69
Eden is very fast compared to Dharma, thanks.

I am however not fond of the home splash screen, where is mostly black and just says xbmc eden beta (or whatever) in faint white lettering, can someone direct me to a link on this site about how I can make my own xbmc splash screen?

Thanks Nod

Loft - Intel I5-3570K, Asus P8Z77-LX, Corsair 16GB DDR3, AMD HD 7700, AOC 27" LCD
Bedroom - Intel I3-530, Intel DH55HC, Corsair 4GB DDR3, Nvidia G610, Samsung 37" HDTV
Living Room - Intel E8400, Gigabyte GA-E7AUM-DS2H, 4GB DDR2, Nvidia G610, Samsung 52" HDTV
find
dtviewer Offline
Fan
Posts: 664
Joined: Jul 2008
Reputation: 1
Post: #70
tcman47 Wrote:Eden is very fast compared to Dharma, thanks.

I am however not fond of the home splash screen, where is mostly black and just says xbmc eden beta (or whatever) in faint white lettering, can someone direct me to a link on this site about how I can make my own xbmc splash screen?

Thanks Nod

Try here:
http://forum.xbmc.org/showthread.php?tid...ash+screen

Edit: The link I posted is how to switch out the splashscreen. Were you actually looking into how to make your own?
If so I would think any photo editing software such as Photoshop or Gimp would work.
Heres a thread with a couple pretty nice ones users here made:
http://forum.xbmc.org/showthread.php?tid...ash+screen
(This post was last modified: 2011-12-28 18:34 by dtviewer.)
find
tocinillo Offline
Fan
Posts: 317
Joined: Dec 2010
Reputation: 2
Post: #71
I have an error with Eden Beta 1:

I can't launch Powerdvd to play Blu-ray disc with "protocols=bd", but I can launch Powerdvd to play BD&BD3D perfectly....so...whats the problem?

My advancedsettings:
Quote:<playercorefactory>
<players>
<player name="PowerDVD" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Mounter.bat</filename>
<args>"{1}"</args>
<forceontop>true</forceontop>
<hidexbmc>true</hidexbmc>
<hidecursor>true</hidecursor>
<hideconsole>true</hideconsole>
<warpcursor>none</warpcursor>
</player>
<player name="PowerDVD2" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Mounter2.bat</filename>
<args>"{1}"</args>
<forceontop>true</forceontop>
<hidexbmc>true</hidexbmc>
<hidecursor>true</hidecursor>
<hideconsole>true</hideconsole>
<warpcursor>none</warpcursor>
</player>
</players>
<rules action="prepend">
<!-- Blu-rays -->
<rule name="Blu-Ray" protocols="bd" player="PowerDVD2"/>
<rule filetypes="iso" filename=".*FULLBD3D*." player="PowerDVD"/>
</rules>
</playercorefactory>

And now Mounter2.bat:

Quote:"C:\Program Files\CyberLink\PowerDVD10\PowerDVD Cinema\PowerDVDCinema10.exe" /fullscreen I:

I have exatly the same BAT to Mounter.bat for launch powerdvd to see BD and BD3D iso files and I dont have the problem....

Thanks and regards.
(This post was last modified: 2011-12-28 20:30 by tocinillo.)
find
TomislavV Offline
Junior Member
Posts: 18
Joined: Dec 2011
Reputation: 0
Post: #72
Hello,

I'm experiencing quite higher CPU usage than with pre eden nightlies. Usually for h264 with dxva CPU usage was about 5%, now it's 35 %. Also, with sd usage is about 30 %, but I guess that's because I use lancos3. CPU is Athlon dual core.

Is that normal or?

Regards
find
DDDamian Offline
Team-XBMC Developer
Posts: 3,028
Joined: Sep 2011
Reputation: 254
Location: Canada
Post: #73
+1 on the new release and all the hard work that's gone into it. Flawless on Win7. Looking forward to what magic comes next!

Thanks devs - pat your backs Big Grin

System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon AVR-3808CI - Denon DVD-5900 Universal Player - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray - X-Box 360 - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
find
System77 Offline
Junior Member
Posts: 8
Joined: Dec 2011
Reputation: 0
Post: #74
da-anda Wrote:Yes, check the skins in the addon repository, there is a confluence vertical IIRC that gives you the "old" look?

Thanks.. Ill give it a go.. Smile
find
Hitcher Online
Skilled Skinner
Posts: 11,051
Joined: Aug 2007
Reputation: 103
Location: Eastleigh, UK
Post: #75
Why post bugs in the announcement forum?

Post them in the right place and include a full debug log.
(This post was last modified: 2011-12-29 09:35 by Hitcher.)
find
Thread Closed