Missing Movie Scanner

  Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
bodozer Offline
Junior Member
Posts: 31
Joined: Feb 2014
Reputation: 0
Post: #316
Hi Takoi

First of all, I really like Missing Movie Scanner and many thanks for all the work you've done.
But I've got some problem with the 4.xx version of Missing Movie Scanner.
It reports files that KODI have found.

My setup is:
KODI 15.2 running under Linux Mint 17.2 with a mounted NTFS formatted HDD.
It's running a database so I can watch the movies from my Raspberry PI 2 with OpenElec 6.0.
A few days ago I was able to reverse to older version, so I tested 4.0.3 4.0.2, 4.0.1, 4.0.0, 3.9.9 and finally 3.3.2.
The 3.3.2 version worked like a charm. But the others reported movies that are not missing:

*********************************************************
Missing Movies scan results 2015-11-19 20:18:39.008687
*********************************************************
smb://HTPC-MASTER/Video/= Långfilmer =/Släpp fångarne loss, det är vår! [1975 SV]/Släpp fångarne loss, det är vår (1).avi
smb://HTPC-MASTER/Video/= Långfilmer =/Släpp fångarne loss, det är vår! [1975 SV]/Släpp fångarne loss, det är vår (2).avi
smb://HTPC-MASTER/Video/= Långfilmer =/Patrik 1,5 [2008 SV]/Patrik 1,5 (1).avi
smb://HTPC-MASTER/Video/= Långfilmer =/Patrik 1,5 [2008 SV]/Patrik 1,5 (2).avi
smb://HTPC-MASTER/Video/= Långfilmer =/Vit jägare, svart hjärta (White Hunter Black Heart) [1990 US]/Vit jägare, svart hjärta (1).avi
smb://HTPC-MASTER/Video/= Långfilmer =/Vit jägare, svart hjärta (White Hunter Black Heart) [1990 US]/Vit jägare, svart hjärta (2).avi
smb://HTPC-MASTER/Video/= Barnfilmer =/Atlantis, en försvunnen värld [2001 US]/Atlantis - En försvunnen värld (2).avi
smb://HTPC-MASTER/Video/= Barnfilmer =/Du är inte klok, Madicken [1979 SV]/Du är inte klok, Madicken (1).avi
smb://HTPC-MASTER/Video/= Barnfilmer =/Du är inte klok, Madicken [1979 SV]/Du är inte klok, Madicken (2).avi

(NB! Due to my settings KODI sees part (1) and (2) as one movie.)

I renamed Patrik 1,5 (1).avi to Patrik 1,5.avi and than it disappeared from the missing list.
Can it be the combo of the letter ',' and the (1)/(2) that trigger the scanner?
Strange that only part 2 of 'Atlantis - En försvunnen värld' are reported not part 1...

I'm setting up a KODI prepared computer for a friend – but now I can't install the 3.3.2 version any more.
Can I retrieve it from my KODI computer in some way?
Or can you provide me a zip file with that 3.3.2 version?
By the way – from the RPI2 can I manually edit sources so I can run the scanner from that one as well?

Thanks in advanced,

Best regards
Bodozer
find quote
manray Offline
Junior Member
Posts: 33
Joined: Feb 2013
Reputation: 0
Post: #317
(2015-11-17 16:18)manray Wrote:  Hi,

I'm using kodi v15.2 and Missing Movies version="4.0.3" on windows 7.
When i launch this plugin I get a screen error and the following error on Kodi log:

13:56:31 T:3220 NOTICE: -->Python Interpreter Initialized<--
13:56:31 T:3220 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <class 'routing.RoutingError'>
Error Contents: No route to path "//extrafanart/"
Traceback (most recent call last):
File "C:\Users\user\AppData\Roaming\Kodi\addons\plugin.video.mms\default.py", line 233, in <module>
plugin.run()
File "C:\Users\user\AppData\Roaming\Kodi\addons\script.module.routing\lib\routing.py", line 109, in run
self._dispatch(path)
File "C:\Users\user\AppData\Roaming\Kodi\addons\script.module.routing\lib\routing.py", line 122, in _dispatch
raise RoutingError('No route to path "%s"' % path)
RoutingError: No route to path "//extrafanart/"
-->End of Python script error report<--
13:56:31 T:1924 ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.mms//extrafanart/
Can anyone help me?
Thanks for the great work!

Hi Takoi

Can you help me?

Thanks in advanced,
Best regards
find quote
takoi Offline
Team-Kodi Member
Posts: 1,105
Joined: Oct 2009
Reputation: 23
Location: Norway
Post: #318
(2015-11-19 22:08)bodozer Wrote:  I renamed Patrik 1,5 (1).avi to Patrik 1,5.avi and than it disappeared from the missing list.
Can it be the combo of the letter ',' and the (1)/(2) that trigger the scanner?
Strange that only part 2 of 'Atlantis - En försvunnen värld' are reported not part 1...
Should be fixed in 4.0.4

(2015-11-23 19:49)manray Wrote:  
(2015-11-17 16:18)manray Wrote:  Hi,

I'm using kodi v15.2 and Missing Movies version="4.0.3" on windows 7.
When i launch this plugin I get a screen error and the following error on Kodi log:

13:56:31 T:3220 NOTICE: -->Python Interpreter Initialized<--
13:56:31 T:3220 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <class 'routing.RoutingError'>
Error Contents: No route to path "//extrafanart/"
Traceback (most recent call last):
File "C:\Users\user\AppData\Roaming\Kodi\addons\plugin.video.mms\default.py", line 233, in <module>
plugin.run()
File "C:\Users\user\AppData\Roaming\Kodi\addons\script.module.routing\lib\routing.py", line 109, in run
self._dispatch(path)
File "C:\Users\user\AppData\Roaming\Kodi\addons\script.module.routing\lib\routing.py", line 122, in _dispatch
raise RoutingError('No route to path "%s"' % path)
RoutingError: No route to path "//extrafanart/"
-->End of Python script error report<--
13:56:31 T:1924 ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.mms//extrafanart/
Can anyone help me?
Thanks for the great work!

Hi Takoi

Can you help me?

Thanks in advanced,
Best regards
I need the complete debug log.
find quote
tojomo Offline
Junior Member
Posts: 1
Joined: Nov 2015
Reputation: 0
Post: #319
When i try to click on any of the add on's menu items I am told "missing movies error" and to "check the log for more information." I have attached the log.
http://pastebin.com/qA5VVd3n
find quote
bodozer Offline
Junior Member
Posts: 31
Joined: Feb 2014
Reputation: 0
Smile  RE: Missing Movie Scanner
Post: #320
Thanks alot.

Now it works like a charm.

/Bodozer
find quote
SigHunter Offline
Junior Member
Posts: 2
Joined: Dec 2015
Reputation: 0
Post: #321
I just can't get Missing Movies to show anything.
I have 150 elements in my directory and just 145 movies got scraped,
so Missing Movies should display at least 5 items

[Image: screenshot003.png]
[Image: screenshot004.png]

uploaded the Debug Log here:
http://www.xbmclogs.com/pkxlzy2dh

even tried to add videoextensions to my advancedsettings.xml but no change

<advancedsettings>
<network>
<buffermode>1</buffermode>
<cachemembuffersize>157286400</cachemembuffersize>
<readbufferfactor>5</readbufferfactor>
</network>
<pvr>
<minvideocachelevel>30</minvideocachelevel>
<minaudiocachelevel>30</minaudiocachelevel>
</pvr>
<videoextensions>
<add>.ex1|.ex2|.m4v|.3gp|.nsv|.ts|.ty|.strm|.rm|.rmvb|.m3u|.ifo|.mov|.qt|.divx|.xv​​id|.bivx|.vob|.nrg|.img|.iso|.pva|.wmv|.asf|.asx|.ogm|.m2v|.avi|.bin|.dat|.dvr-ms|.mpg|.mpeg|.mp4|.mkv|.avc|.vp3|.svq3|.nuv|.viv|.dv|.fli|.flv|.rar|.001|.wpl|.​zip</add>
</videoextensions>
</advancedsettings>

videos are all mkv
find quote
takoi Offline
Team-Kodi Member
Posts: 1,105
Joined: Oct 2009
Reputation: 23
Location: Norway
Post: #322
(2015-12-06 14:08)SigHunter Wrote:  I just can't get Missing Movies to show anything.
I have 150 elements in my directory and just 145 movies got scraped,
so Missing Movies should display at least 5 items


uploaded the Debug Log here:
http://www.xbmclogs.com/pkxlzy2dh

even tried to add videoextensions to my advancedsettings.xml but no change

<advancedsettings>
<network>
<buffermode>1</buffermode>
<cachemembuffersize>157286400</cachemembuffersize>
<readbufferfactor>5</readbufferfactor>
</network>
<pvr>
<minvideocachelevel>30</minvideocachelevel>
<minaudiocachelevel>30</minaudiocachelevel>
</pvr>
<videoextensions>
<add>.ex1|.ex2|.m4v|.3gp|.nsv|.ts|.ty|.strm|.rm|.rmvb|.m3u|.ifo|.mov|.qt|.divx|.xv​​id|.bivx|.vob|.nrg|.img|.iso|.pva|.wmv|.asf|.asx|.ogm|.m2v|.avi|.bin|.dat|.dvr-ms|.mpg|.mpeg|.mp4|.mkv|.avc|.vp3|.svq3|.nuv|.viv|.dv|.fli|.flv|.rar|.001|.wpl|.​zip</add>
</videoextensions>
</advancedsettings>

videos are all mkv
According to the log, you don't have any video sources set up. There are lots of warnings about "/var/media/Filme/.." not existing. If you click on 'source' that should also list all the sources the addon can see.
find quote
SigHunter Offline
Junior Member
Posts: 2
Joined: Dec 2015
Reputation: 0
Post: #323
thanks for the tip, I now got it working.

before that, I added sources with the "Files" overview, browsed to the directory, pressed C and set content to Movies or TV Shows.

This worked like a charm for scraping and library, but it seems this doesn't work with Missing Movies.

I now readded all my sources via the Filemanager (from Settings) via "add source" and selected the corresponding folder from root-folder (/media/Filme/Filme/ instead of /var/something). This is the default way if you have SMB-Shares or anything like that, but was not necessary when using local USB drives

thanks for the quick help!
find quote
Concestly Offline
Senior Member
Posts: 108
Joined: Sep 2015
Reputation: 1
Post: #324
I've tried downloading it from SuperRepo, still does same thing. I can't seem to find it as a single download anywhere. I also have no experience with github, not sure what to do or how to work with anything from there.
find quote
jeromed Offline
Junior Member
Posts: 2
Joined: Oct 2013
Reputation: 0
Post: #325
Hi and thank you for this great addon

When running it on a SFTP source (4.0.4 on kodi Isengard) it reports some files are missing from movie library even if they don't, see log below :
Code:
source 'sftp://login:Pa$$@192.168.0.1/mnt/patrice/Films2' identified as movie source
'sftp://login:Pa$$@192.168.0.1/mnt/patrice/Films2/Big_buck_bunny/Big_buck_bunnybig_buck_bunny_1080p_surround.avi' identified as missing

note that there are two "Big_buck_bunny" in the path : one in the directory and one (incorrect) in the filename : Big_buck_bunnybig_buck_bunny_1080p_surround.avi
The right disk file path is /mnt/patrice/Films2/Big_buck_bunny/big_buck_bunny_1080p_surround.avi

it seems that line 33 of fsutils.py, xbmcvfs.listdir(path) returns a file "Big_buck_bunnybig_buck_bunny_1080p_surround.avi" which is not a correct filename

That problem occurs when a file is located in a subdirectory of a SFTP source

could you please fix this ?

let me know if you need further information

regards,
find quote
Shawzborne Offline
Junior Member
Posts: 13
Joined: Jan 2015
Reputation: 0
Post: #326
Is there a way to stop the Missing Movie Scanner to stop scanner for this file type from bluray rips?

Also are the id.bdmv files required to play or identify the bluray movies or can I just delete them?

[Image: xQdUj5K.jpg]
find quote
takoi Offline
Team-Kodi Member
Posts: 1,105
Joined: Oct 2009
Reputation: 23
Location: Norway
Post: #327
(2016-01-09 16:28)Shawzborne Wrote:  Is there a way to stop the Missing Movie Scanner to stop scanner for this file type from bluray rips?

Also are the id.bdmv files required to play or identify the bluray movies or can I just delete them?

[]http://i.imgur.com/xQdUj5K.jpg[/]
Blurays are a real mess;) Not sure what they're for. Should be fixed in v4.0.5 (by just ignore them)
find quote
Shawzborne Offline
Junior Member
Posts: 13
Joined: Jan 2015
Reputation: 0
Post: #328
(2016-01-17 23:21)takoi Wrote:  
(2016-01-09 16:28)Shawzborne Wrote:  Is there a way to stop the Missing Movie Scanner to stop scanner for this file type from bluray rips?

Also are the id.bdmv files required to play or identify the bluray movies or can I just delete them?

[]http://i.imgur.com/xQdUj5K.jpg[/]
Blurays are a real messWink Not sure what they're for. Should be fixed in v4.0.5 (by just ignore them)


The v4.0.5 update didnt change any of that but in the settings you can add

l.bdmv

to the list of blacklisted file extensions and they are now gone and list is empty
find quote
Andulien Offline
Junior Member
Posts: 16
Joined: Dec 2013
Reputation: 0
Post: #329
Hey all,

since quite some time ago I wanted to run again the MMS but it failed with the following error log. This error repeats itself no matter what I click in the MMS Addon.
Any idea on why the Addon does not work for me? I am running Kodi 15.2 on a Windows 7 Machine, connected via the Network to a Synology NAS for the Files. The Network Drives are locally mapped with a respective Drive letter.

Code:
14:32:16 T:6260  NOTICE: Previous line repeats 5 times.
14:32:16 T:6260  NOTICE: Thread LanguageInvoker start, auto delete: false
14:32:16 T:6260  NOTICE: -->Python Interpreter Initialized<--
14:32:16 T:6260   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.UnicodeDecodeError'>
                                            Error Contents: 'utf8' codec can't decode byte 0x84 in position 14: invalid start byte
                                            Traceback (most recent call last):
                                              File "C:\Users\MCramer\AppData\Roaming\Kodi\addons\plugin.video.mms\default.py", line 234, in <module>
                                                plugin.run()
                                              File "C:\Users\MCramer\AppData\Roaming\Kodi\addons\script.module.routing\lib\routing.p​y", line 109, in run
                                                self._dispatch(path)
                                              File "C:\Users\MCramer\AppData\Roaming\Kodi\addons\script.module.routing\lib\routing.p​y", line 120, in _dispatch
                                                view_func(**kwargs)
                                              File "C:\Users\MCramer\AppData\Roaming\Kodi\addons\plugin.video.mms\default.py", line 172, in missing_movies
                                                sources = [_.path for _ in library.get_movie_sources()]
                                              File "C:\Users\MCramer\AppData\Roaming\Kodi\addons\plugin.video.mms\library.py", line 123, in get_movie_sources
                                                return _identify_source_content()[0]
                                              File "C:\Users\MCramer\AppData\Roaming\Kodi\addons\plugin.video.mms\library.py", line 102, in _identify_source_content
                                                movie_content = get_movies()
                                              File "C:\Users\MCramer\AppData\Roaming\Kodi\addons\plugin.video.mms\library.py", line 59, in get_movies
                                                items = jsonrpc(query)['result'].get('movies', [])
                                              File "C:\Users\MCramer\AppData\Roaming\Kodi\addons\plugin.video.mms\library.py", line 29, in jsonrpc
                                                return json.loads(xbmc.executeJSONRPC(json.dumps(query, encoding='utf-8')))
                                              File "C:\Program Files (x86)\Kodi\system\python\Lib\json\__init__.py", line 338, in loads
                                                return _default_decoder.decode(s)
                                              File "C:\Program Files (x86)\Kodi\system\python\Lib\json\decoder.py", line 366, in decode
                                                obj, end = self.raw_decode(s, idx=_w(s, 0).end())
                                              File "C:\Program Files (x86)\Kodi\system\python\Lib\json\decoder.py", line 382, in raw_decode
                                                obj, end = self.scan_once(s, idx)
                                            UnicodeDecodeError: 'utf8' codec can't decode byte 0x84 in position 14: invalid start byte
                                            -->End of Python script error report<--
14:32:16 T:2812   ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.mms/missing_movies
14:32:16 T:2812   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.mms/missing_movies) failed
14:32:16 T:7688  NOTICE: Thread BackgroundLoader start, auto delete: false
find quote
Post Reply