(DUSHMANIAC) Latest release crash at startup, new package needed.

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
loggio Offline
Fan
Posts: 593
Joined: May 2010
Reputation: 6
Post: #1
Hi there,

Updated today and XBMC is crashing at startup, with my log telling me failed audio mixer. Apparently this issues has been fixed in latest nightlies.
I'm not very good with Linux, So i have no idea how to 'roll back' my install to the previous working version i had. My HTPC is now 'out of action'

Could we get an update for a working version, please ?

also, for future reference... How does one roll back to a previous install?

Cheers,
Loggio.
find quote
Bonzi Offline
Member
Posts: 50
Joined: Feb 2011
Reputation: 0
Post: #2
Can you post the log? Might give an idea of what is going on. My guess is that it has something to do with your configuration. Did you install anything else other than the new xbmc-pvr?
find quote
Jimmer Offline
Donor
Posts: 339
Joined: Jan 2010
Reputation: 3
Location: Sunny Devon, UK
Post: #3
Have you tried:

http://forum.xbmc.org/showpost.php?p=973...stcount=16

This guy changed two values in that file and it cured it for him.... perhaps you have the same problem?

Jim
find quote
opdenkamp Offline
Team-XBMC PVR Developer
Posts: 2,232
Joined: Feb 2009
Reputation: 29
Location: Heerlen, The Netherlands
Post: #4
@loggio:
the build is based on Eden B1 and has the latest changes from the Eden branch in it. if it crashes out and that crash has been fixed in the nightlies, you'll have to wait until that fix is backported to the Eden branch.

try what the guy from Jimmer's link above here did. if it doesn't work, please pastebin the full debug log.

opdenkamp / dushmaniac

xbmc-pvr [Eden-PVR builds] [now included in mainline XBMC, so no more source link here :)]
personal website: [link]

Found a problem with PVR? Report it on Trac, under "PVR - core components". Please attach the full debug log.

If you like my work, please consider donating to me and/or Team XBMC.
find quote
loggio Offline
Fan
Posts: 593
Joined: May 2010
Reputation: 6
Post: #5
I tried the link fix... Didnt work, It's xbmc, not my setup. Also deleted .db . It's a known issue and has been fixed. I never install system updates on Ubuntu they always just break my system beyond repair, the only thing I ever update is xbmc. Windows is working great however... Might just go back to windows as its a much more manageable platform.

Thanks guys :-)
find quote
Prof Yaffle Offline
Donor
Posts: 1,210
Joined: Mar 2011
Reputation: 28
Location: UK - in the middlish (mostly).
Post: #6
Well, I was just about to say that - from my experience - it's this patch that needs to be merged into the PVR code.

However, checking github - it looks like Dushmaniac did just that about 2 hours ago. So this can be checked out now and recompiled, or you can wait for the next binary build.
find quote
kml2 Offline
Junior Member
Posts: 33
Joined: May 2011
Reputation: 0
Post: #7
Prof Yaffle Wrote:So this can be checked out now and recompiled, or you can wait for the next binary build.

Trying to grab this patched code, I managed to get confused ...

WHICH branch of git://github.com/opdenkamp/xbmc.git has the fixed code in it? 'master' or 'Eden-pvr'?

I pulled & built from both today, and am still seeing the crashes as reported here.
find quote
opdenkamp Offline
Team-XBMC PVR Developer
Posts: 2,232
Joined: Feb 2009
Reputation: 29
Location: Heerlen, The Netherlands
Post: #8
master should contain the fix. it's been synced with mainline about 2 days ago

opdenkamp / dushmaniac

xbmc-pvr [Eden-PVR builds] [now included in mainline XBMC, so no more source link here :)]
personal website: [link]

Found a problem with PVR? Report it on Trac, under "PVR - core components". Please attach the full debug log.

If you like my work, please consider donating to me and/or Team XBMC.
find quote