XBMC Library Updater Addon

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
elmcguinness Offline
Junior Member
Posts: 39
Joined: Jun 2013
Reputation: 0
Post: #316
Thanks for the reply and no worries, as I said I was able to fix it by resetting the settings.xml file so it is likely something to do with the date that was stored in there. I will post more information if it happens again.
find quote
bartplessers Offline
Junior Member
Posts: 24
Joined: Oct 2011
Reputation: 0
Post: #317
Hi,
I am running
- openelec 5.0.6
- Raspberry 2
- add-on XBMC Library Auto Update 0.9.4
- "update music library" is enabled in the settings of the add-on and shedule is hourly

I noticed that my music library is not updated anymore: newly added music does not appear in the library.
Manually updating the library resolves the problem.

Has anyone else experienced this same problem?
Solution?

Kind regards,
Bart
find quote
Labmax Offline
Junior Member
Posts: 2
Joined: Feb 2014
Reputation: 0
Post: #318
Same issue here.
First it does update library. Then it cleansup
But no action for music library.
If I disable video update it does update music.

any ideas?Tongue
find quote
robweber Offline
Posting Freak
Posts: 989
Joined: Sep 2009
Reputation: 30
Post: #319
Pics or it didn't happen Smile

Seriously though, I'd need a log file of this happening. Something that covers at least one interval where both library functions should have been executed. What should be happening is if one DB update is in progress, the next one will continue to check until it is allowed to run. If this isn't happening the log file will show.
find quote
Labmax Offline
Junior Member
Posts: 2
Joined: Feb 2014
Reputation: 0
Post: #320
Hi robweber...

Both audio and music are setup with cron timer 0 5 0 0 0 (I changed it but that does not change the issue)
Manually startup also has this issue.

This is what I could find out from kodi.log:

05:00:00 T:2918200352 NOTICE: service.libraryautoupdate-0.9.4 : Starting network check
05:00:00 T:2918200352 NOTICE: service.libraryautoupdate-0.9.4 : Update Video Library
05:00:00 T:2918200352 NOTICE: service.libraryautoupdate-0.9.4 : Starting network check
05:00:00 T:2637636640 NOTICE: Thread VideoInfoScanner start, auto delete: false
05:00:00 T:2918200352 NOTICE: service.libraryautoupdate-0.9.4 : Waiting for other scan to finish
05:00:00 T:2637636640 NOTICE: VideoInfoScanner: Starting scan ..
05:00:01 T:2637636640 WARNING: No information found for item

//// then i see a lot of warnings that files could not be added. But that is normal behaviour! ///

05:00:32 T:2637636640 NOTICE: VideoInfoScanner: Finished scan. Scanning for video info took 00:32
05:00:32 T:2918200352 NOTICE: service.libraryautoupdate-0.9.4 : Cleaning Database
05:00:33 T:3024207872 NOTICE: CleanDatabase: Starting videodatabase cleanup ..
05:00:33 T:3024207872 WARNING: CreateLoader - unsupported protocol(plugin) in plugin://plugin.video.youtube/?action=play_video&videoid=PMA-taGtfXs
05:00:33 T:3024207872 WARNING: CreateLoader - unsupported protocol(plugin) in plugin://plugin.video.youtube/?path=/root/video&action=play_video&videoid=3Lwnr4cem08
05:00:33 T:3024207872 WARNING: CreateLoader - unsupported protocol(plugin) in plugin://plugin.video.youtube/?path=/root/video&action=play_video&videoid=FJNd007TqLg
05:00:33 T:3024207872 WARNING: CreateLoader - unsupported protocol(plugin) in plugin://plugin.video.youtube/?path=/root/video&action=play_video&videoid=O7jGXVWS4_c
05:00:33 T:3024207872 WARNING: CreateLoader - unsupported protocol(plugin) in plugin://plugin.video.youtube/?path=/root/video&action=play_video&videoid=lIWy8taP1rE
05:00:33 T:3024207872 WARNING: CreateLoader - unsupported protocol(plugin) in plugin://plugin.video.youtube/play/?video_id=-7iR1QKVY3E
05:00:33 T:3024207872 WARNING: CreateLoader - unsupported protocol(plugin) in plugin://plugin.video.youtube/play/?video_id=YbS6t_BivNs
05:00:33 T:3024207872 WARNING: CreateLoader - unsupported protocol(plugin) in plugin://plugin.video.youtube/play/?video_id=ceP_zvyM3A4
05:00:33 T:3024207872 WARNING: CreateLoader - unsupported protocol(plugin) in plugin://net.rieter.xot/?action=playvideo&pickle=KGltZWRpYWl0ZW0KTWVkaWFJdGVtCnAxCihkcDIKUydyYXRpbmcnCnAzCk5zUydNZWRpY​$
05:00:33 T:3024207872 WARNING: CreateLoader - unsupported protocol(plugin) in plugin://net.rieter.xot/?action=playvideo&pickle=KGltZWRpYWl0ZW0KTWVkaWFJdGVtCnAxCihkcDIKUydyYXRpbmcnCnAzCk5zUydNZWRpY​$
05:00:34 T:2918200352 NOTICE: service.libraryautoupdate-0.9.4 : update timers
05:00:34 T:2918200352 NOTICE: service.libraryautoupdate-0.9.4 : Creating timer for Video Library
05:00:34 T:2918200352 NOTICE: service.libraryautoupdate-0.9.4 : Creating timer for Music Library
05:00:34 T:2918200352 NOTICE: service.libraryautoupdate-0.9.4 : update timers
05:00:34 T:2918200352 NOTICE: service.libraryautoupdate-0.9.4 : Creating timer for Video Library
05:00:34 T:2918200352 NOTICE: service.libraryautoupdate-0.9.4 : Creating timer for Music Library
05:00:36 T:3024207872 NOTICE: CleanDatabase: Cleaning videodatabase done. Operation took 00:03
05:02:10 T:3024207872 NOTICE: Samba is idle. Closing the remaining connections
11:23:28 T:2589979680 something else is done!!

I don''t know what the "05:00:33 T:3024207872 WARNING: CreateLoader - unsupported protocol(plugin)" means.
But before I ever had this issue and the same addons where installed...

It seems like music scan never starts in this case!

Do you need more info?

Regards Ralph
find quote
Post Reply