ATV2 - Eden 11.0 b1 - terrible frame rate w/ ass/ssa subtitles

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Ned Scott Offline
Team-Kodi Wiki Guy
Posts: 21,967
Joined: Jan 2011
Reputation: 293
Location: Arizona, USA
Post: #16
Damn, I see it too, but just on ATV2. iPhone 4 plays my .ass anime fine (that sounds wrong, but is accurate in every context *bowchikawowwow*)
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,630
Joined: Feb 2011
Reputation: 116
Location: germany
Post: #17
great sample dude ... works here too ... i mean fps go low here too Big Grin

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
GuyJustHere Offline
Junior Member
Posts: 20
Joined: Jan 2012
Reputation: 0
Post: #18
As far as getting the GUI to run faster. Has anyone looked into removing some of the useless ATV2 boot daemons in order to speed system up? I did this on my iphone and got a nice boost...
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,508
Joined: Feb 2008
Reputation: 64
Post: #19
GuyJustHere Wrote:As far as getting the GUI to run faster. Has anyone looked into removing some of the useless ATV2 boot daemons in order to speed system up? I did this on my iphone and got a nice boost...

A simple peek at top will show that there is nothing else consuming significant amounts of CPU that makes this worth the effort. That said, it is recommended to remove expose (vnc server).


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
donmodro Offline
Junior Member
Posts: 1
Joined: Jan 2012
Reputation: 0
Post: #20
I've noticed the same issue as well. I'm running 4.4.4, with 11.0 beta 2. I was working with a 264 encoded video at 720p resolution. The embedded subtitles would cause the video to stutter anytime they were being displayed, but pointing xbmc touse a seperate srt formatted subtitle file would not cause the video to stutter. I was watching the same exact video file both times.

I will have to double check the file format of the embedded subs.
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,630
Joined: Feb 2011
Reputation: 116
Location: germany
Post: #21
i get the low fps with that sample on 4.4.4 - no issue on 4.3 with the same testfile ... ios5 sucks *singing*

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
linusyang Offline
Member
Posts: 76
Joined: Jan 2012
Reputation: 4
Post: #22
I have to say that beta 3 still has the same issue on iOS 4.4.4. Any .mkv files with embedded .ssa subtitles cannot be played smoothly. Will this issue be solved?
find quote
g-off Offline
Fan
Posts: 631
Joined: Aug 2011
Reputation: 3
Post: #23
linusyang Wrote:I have to say that beta 3 still has the same issue on iOS 4.4.4. Any .mkv files with embedded .ssa subtitles cannot be played smoothly. Will this issue be solved?

Now that you have asked so politely - I guess it will bumped to the top of the list of things to fix. Or not. You might need to ask for your money back.
find quote
linusyang Offline
Member
Posts: 76
Joined: Jan 2012
Reputation: 4
Post: #24
g-off Wrote:Now that you have asked so politely - I guess it will bumped to the top of the list of things to fix. Or not. You might need to ask for your money back.
Oh sorry, I just want to report that the problem still exists. I am not meant to be rude. Smile I am always grateful for the team's great job.
Anyone can fix this, that will be good. If not, I will see what further I can do to help fix this.

Again, thanks a lot for the team's job!
find quote
meerlol Offline
Junior Member
Posts: 2
Joined: Mar 2012
Reputation: 0
Post: #25
Just a bump. I have exactly the same issue on a lot of content I downloaded lately. Turning off the subtitles solves all my buffering issues.
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,630
Joined: Feb 2011
Reputation: 116
Location: germany
Post: #26
This will be a known issue for eden as we don't see a chance to fix this yet...

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
meerlol Offline
Junior Member
Posts: 2
Joined: Mar 2012
Reputation: 0
Post: #27
Thanx for the update, I presume the simple workaround would be for me to strip the embedded subtitles from the MKV?
find quote
Ushae Offline
Junior Member
Posts: 15
Joined: Feb 2012
Reputation: 0
Post: #28
Hi, I'm also experiencing the same issue with my subtitled media. Downgrading to 4.3 seems to make the most sense right now, but I'll hang fire for a fix, nothing is impossible Wink
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,630
Joined: Feb 2011
Reputation: 116
Location: germany
Post: #29
(2012-05-05 12:02)Ushae Wrote:  but I'll hang fire for a fix, nothing is impossible Wink

show me...

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
Ushae Offline
Junior Member
Posts: 15
Joined: Feb 2012
Reputation: 0
Post: #30
(2012-05-06 00:56)Memphiz Wrote:  
(2012-05-05 12:02)Ushae Wrote:  but I'll hang fire for a fix, nothing is impossible Wink

show me...

I guess that means it's not happening at all. Too bad Sad

But still, immense work you guys manage to do here and a fantastic thing for the community.
find quote