XBMC Eden Webserver failed to start

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
CakeEater Offline
Junior Member
Posts: 3
Joined: Jan 2012
Reputation: 0
Post: #1
I just installed Eden beta 1 and when I try to activate control via http it says "webserver failed to start"... I've tried restarting the computer, reloading stuff and gah! I use http to control with xbmc commander, it can't connect otherwise :-(
With the previous version everything was kick-ass and worked super duper. Does anyone else have this problem? Solution suggestion?
find quote
buges Offline
Fan
Posts: 335
Joined: Apr 2007
Reputation: 0
Location: UK
Post: #2
check your settings in xbmc, if all is ok then i'd post a debug log.

if it used to be ok, have you changed anything firewall etc...
find quote
block134 Offline
Donor
Posts: 152
Joined: Sep 2011
Reputation: 1
Post: #3
Check your port that is set in XBMC. I was having the same problem, I changed the port from 80 to 8082 and then enabled the web server with no problem. It might the firewall blocking the port.
find quote
CakeEater Offline
Junior Member
Posts: 3
Joined: Jan 2012
Reputation: 0
Thumbs Up  worked
Post: #4
block134 Wrote:Check your port that is set in XBMC. I was having the same problem, I changed the port from 80 to 8082 and then enabled the web server with no problem. It might the firewall blocking the port.

This worked... why?
Thanks for the tip.
find quote
jhsrennie Offline
Team-XBMC Developer
Posts: 7,248
Joined: Nov 2008
Reputation: 119
Location: Chester, UK
Post: #5
CakeEater Wrote:This worked... why?

You have something installed on your PC that is already using port 80. Typically this would be a web server. Do you have IIS or Personal web server (or whatever it's called these days) installed?

JR
find quote
CakeEater Offline
Junior Member
Posts: 3
Joined: Jan 2012
Reputation: 0
Post: #6
Ah, understood, conflicting port allocations or smth like that.
Couldn't XBMC be fixed so it checks if port 80 is busy and changes to something free? Perhaps a new feature?
Oh well, thanks for the help everyone involved. Smile
find quote
jhsrennie Offline
Team-XBMC Developer
Posts: 7,248
Joined: Nov 2008
Reputation: 119
Location: Chester, UK
Post: #7
CakeEater Wrote:Couldn't XBMC be fixed so it checks if port 80 is busy and changes to something free? Perhaps a new feature?

If XBMC started grabbing random ports on my PC I would not be amused! Also you wouldn't know what port to put in on your remote control software.

JR
find quote
CelticWhisper Offline
Junior Member
Posts: 14
Joined: May 2010
Reputation: 0
Post: #8
I apologize for resurrecting an old thread, but can someone offer instructions on how, exactly, to change the port used by the webserver? To be honest, I don't even recall installing it or activating it, so if anything it's been a long time since I did anything in the way of configuring it.

Thank you.
find quote
Plaguester Offline
Senior Member
Posts: 262
Joined: May 2010
Reputation: 7
Post: #9
Settings > Network > Services. About halfway down the port is listed. I think it's 8080 by default.

HTPC 1 - Zotac ZBOX ID80U | 4GB RAM | 64GB SSD | Openelec | Confluence
HTPC 2 - Zotac ZBOX ID41U | 4GB RAM | 60GB SSD | Openelec | Confluence
Server - unRAID Server | 3 x 2TB WD Green HDD, 1TB WD Black HDD (Cache) | Sabnzbd | CouchPotato | Sickbeard
find quote
KarlHegbloom Offline
Junior Member
Posts: 1
Joined: May 2012
Reputation: 0
Post: #10
I have the same problem. When I run xbmc the first time, it works, but if I exit and then restart it, the webserver fails to start. If I then exit xbmc, and then run "killall -9 xbmc.bin", and restart, it works again for that run. So what's happening is the web server is not exiting when the GUI is exited. A process is still running, holding ownership of the web server port.

Ubuntu 12.04, xbmc 2:11.0~git20120423.cd20772-1

I will file a report on Launchpad also, unless one has already been filed.
find quote