Stuttering then wathing live tv, using 4therecord pvr plugin

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
rantzauer Offline
Junior Member
Posts: 14
Joined: Jul 2010
Reputation: 0
Post: #1
Hello

I am the very happy user of a xbmc setup, with a pulse-eight.net build of xbmc, and the newest 4therecord pvr plugin. It a amasing job which has been done on both sides. It looks so nice.

But I do have a little problem. Then watching livetv, I have a little stuttering in the picture. The sound is fine it is only the picture. I have heard that this should be a problem in XBMC at the moment for the Livetv funktion. Is this correct.

Is there some settings I should take a closer look at, which could improve this?

If it is a known 'bug', is there any sight of this getting solved in any near future?

And a second thing. My wife uses TELETEXT (the text pages from 1 to 999), but it is really not easy to read, because of the text font, and that there are big spaces between the letters. I have tried to switch to 4:3 format, because I thought this was the problem but it does not help. Is there a wayto change the look of these TELETEXT pages?

Thanks for a GREAT product.

Best regards

Rantzauer
find quote
KRA77 Offline
Senior Member
Posts: 291
Joined: Jul 2010
Reputation: 0
Post: #2
I can confirm the issue, live-tv audio is fine, but video is not smooth. Playback of recordings is fine. Now get this :

I start live-tv, video is not smooth

I start recording the same channel, video still not smooth.

So I stop playback (still recording), and restart the channel, still not smooth.

Then I mount the recording folder via smb mount in videos.
While still recording, playback via videos and not live-tv is perfect.


this is xbmcbuntu beta3 with beta2 pvr

cpu % is low
find quote
gculley Offline
Junior Member
Posts: 19
Joined: Mar 2012
Reputation: 0
Post: #3
I just downloaded the latest development build and I'm still seeing the same problem. I'm hoping to go "live" with xbmc with my family sometime over the next month (I'm going to "cut the cord" with cable tv) and was hoping to have a semi-functional pvr. MediaPortal streams my live TV signals just fine, but the xbmc PVR is still stuttering.

Dushmaniac, I know that you mentioned before that the stuttering was from the audio/video resyncing but you didn't indicate if there was any work being done to fix this. I can see that you've been busy working on the PVR (which is looking good), but unfortunately the PVR is still not usable to do much other testing as the video is pretty much unwatchable.

If there's anything I can provide to help, please let me know.
find quote
KRA77 Offline
Senior Member
Posts: 291
Joined: Jul 2010
Reputation: 0
Post: #4
Same here, using 5 day old build of xbmc-pvr, using build 132 of 4TR plugin. Playback of SD Live-TV cause stutter in video, (cpu usage is low at this point).
Live-TV HD thou plays much better. Recording of the same content and playback via "recordings" or a mounted share result in perfect playback.

this is ofcourse a clientcomputer running xbmcbuntu

Playback on windows computer that runs 4TR and Margo prebuilt xbmc-pvr is fine.
find quote
oojimaflip Offline
Junior Member
Posts: 3
Joined: Sep 2011
Reputation: 0
Post: #5
I am having a similar problem playing back live tv using tsp's cmyth plugin.
find quote
FernetMenta Offline
Team-Kodi Developer
Posts: 3,656
Joined: Jul 2010
Reputation: 70
Location: Munich
Post: #6
Please post debug log and a note at what time you notice the stutter.
find quote
gculley Offline
Junior Member
Posts: 19
Joined: Mar 2012
Reputation: 0
Post: #7
Here's the link to my logfile: http://pastebin.ca/2131232

My local station is broadcasting in HD. The stuttering occurs immediately and playback doesn't go much more than a couple of seconds between stutters.
find quote
pkscout Offline
Posting Freak
Posts: 1,143
Joined: Jan 2011
Reputation: 23
Location: Honolulu, HI
Post: #8
I'm only seeing video stuttering if I try and watch a channel while FTR is recording that same channel. Otherwise the playback has been very stable for me.
find quote
gculley Offline
Junior Member
Posts: 19
Joined: Mar 2012
Reputation: 0
Post: #9
Perhaps I needed to uninstall the Dharma version of xbmc before upgrading to the lastest beta version that has the pvr?
find quote
KRA77 Offline
Senior Member
Posts: 291
Joined: Jul 2010
Reputation: 0
Post: #10
http://pastebin.com/cpyn8u42

I only cut out part of the log related to playback of live-tv, if need bigger part of log, please tell.

looking at gculleys log he's using a windows computer and mediaportal tv-server

I however use xbmcbuntu client connected to a windows computer running 4tr (argus) tv-server.

During the test I started live-tv for about 30 second, then stop. The stuttering is pretty much all the time, looks like it dropping frames regularly, nothing in the log about it as far as I can read, but some errors when start reading the TS file.
(This post was last modified: 2012-03-23 19:56 by KRA77.)
find quote
FernetMenta Offline
Team-Kodi Developer
Posts: 3,656
Joined: Jul 2010
Reputation: 70
Location: Munich
Post: #11
Looking at gculley's log I am wondering what station does broadcast 1920x1080 as mpeg2. There are CRC errors in the audio packets which might cause the stutter.

KRA77: indeed, the log looks clean. Can you confirm that it drops regularly? Does the dropping counter (codec screen, 'o' key) indicate drops?

Nevertheless, this is a case for the addon author. Will point him to this thread if he not already knows.
find quote
opdenkamp Offline
Team-XBMC PVR Developer
Posts: 2,232
Joined: Feb 2009
Reputation: 29
Location: Heerlen, The Netherlands
Post: #12
>> Looking at gculley's log I am wondering what station does broadcast 1920x1080 as mpeg2
discovery HD does here, as the only channel I know

opdenkamp / dushmaniac

xbmc-pvr [Eden-PVR builds] [now included in mainline XBMC, so no more source link here :)]
personal website: [link]

Found a problem with PVR? Report it on Trac, under "PVR - core components". Please attach the full debug log.

If you like my work, please consider donating to me and/or Team XBMC.
find quote
pkscout Offline
Posting Freak
Posts: 1,143
Joined: Jan 2011
Reputation: 23
Location: Honolulu, HI
Post: #13
(2012-03-23 20:58)FernetMenta Wrote:  Looking at gculley's log I am wondering what station does broadcast 1920x1080 as mpeg2. There are CRC errors in the audio packets which might cause the stutter.

I know our local CBS, NBC, and PBS stations do. I get the first one only as QAM and the other two both ATSC and QAM.
find quote
margro Offline
Fan
Posts: 654
Joined: Oct 2009
Reputation: 21
Location: The Netherlands
Post: #14
@gculley: I see you are using the MediaPortal (ffmpeg) addon. I have also problems with HD playback using RTSP streams in XBMC. The MPEGTS over RTSP implementation of XBMC's ffmpeg library is problematic. It takes a long time to tune a channel and playback shows many artifacts. I'm not able to solve this without digging into the ffmpeg code, which is especially under Windows a real challenge. Therefore I started with a new MediaPortal addon that skips the RTSP step.

You might want to try this addon (MediaPortal (tsreader) found in my Windows XBMC-pvr builds and in my github repository.

@KRA77: seems that we might need to wait a bit between tuning and playback (to increase the buffer size) because delayed playback via a recording does work...
Another reason would be that the route for Live TV playback (without demuxing at the addon side) is too slow. I'm seeing also a drop in fps (<24) on some HD channels with my MediaPortal (tsreader) addon. Older builds from before Dec. 2011 have less problems. I'm not sure yet which changes cause the stuttering and framedrops...

Developer of the MediaPortal PVR addon and the Argus-TV PVR-addon. Unofficial XBMC Windows builds with PVR.
http://www.scintilla.utwente.nl/~marcelg/xbmc
find quote
KRA77 Offline
Senior Member
Posts: 291
Joined: Jul 2010
Reputation: 0
Post: #15
Thank you for your reply, I also had a theory that playback was too close to end of TS buffer. But I was unsure because audio was fine.

I will also check for dropped frames in playback, and report back.
find quote
Post Reply