[RELEASE]XSqueeze - Squeezebox player, music chooser and visualiser for XBMC

  Thread Rating:
  • 3 Vote(s) - 4.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
cw-kid Offline
Posting Freak
Posts: 1,260
Joined: Jun 2012
Reputation: 8
Post: #1516
(2015-04-15 01:37)bossanova808 Wrote:  @cw-kid

Note those binaries you linked to in the other thread are not actually the main squeezelite downloads (which are found at the bottom of this page - https://code.google.com/p/squeezelite/), but special builds with statically linked libraries (that I asked Ralph Irving to prepare and he very kindly did - consider donating to him!). These static binaries are included with the latest xsqueeze, so you could have just copied them from there also. The problem is that these will not be updated as it would require Ralph to maintain a bunch of build environments he does not use. So we may be a bit stuck going forward...but for now all is working ok (both your way or with the integrated xsqueeze approach).

Oh I see, that's not so good then!

So the downloads found here on the Google Code page are still the official latest builds? Dated Jan 2014.

And these ones here are the special one off builds that include the statically linked libraries.

As of OpenElec 5.0.x my existing SqueezeLite setup stopped working. I guess the OpenElec developers removed the libraries required for MP3 playback with SqueezeLite. Not sure why this actually happened?

The only way to have SqueezeLite running under Linux OpenElec now (that I know of) is to use these new SqueezeLite builds with the statically linked libraries in them. I updated my old install guide here to reflect these changes.

Not sure what the solution will be moving forward in the future then..

Cheers

The Media Center Blog
The Digital Lifestyle
Authorised Euro Z-wave dealer contact for bespoke prices!
find quote
bossanova808 Offline
Donor
Posts: 2,567
Joined: Sep 2009
Reputation: 41
Location: Melbourne, Australia
Post: #1517
The libraries as not needed for kodi anymore as I believe ffmpeg handles this now for kodi. So OE took tgr m out, logically. If it gets desperate and I am still motivated enough I will set up vms to compile static binaries but given I personally don't use xsqueeze as such anymore, not 100% sure I will find that motivation...

Sorry, no help w/out a *full debug log*
find quote
cw-kid Offline
Posting Freak
Posts: 1,260
Joined: Jun 2012
Reputation: 8
Post: #1518
Not related to XSqueeze but maybe of interest, with these new SqueezeLite builds we are discussing, Google TTS (Text to Speech) no longer appears to work!

For example in the Logitech Media Server webpage under the Radio section, there is an option to Tune in URL:

http://translate.google.co.uk/translate_...ello+world

The above URL no longer works, it appears to play in LMS on the SqueezeLite, but you can't hear the TTS.

However I can still tune in Radio URLs OK such as:

http://www.listenlive.eu/bbcradio1.m3u

I integrated my Home Automation Controller (Micasaverde Vera) with Kodi and Squeezelite, for voice announcements in the house when certain things happen, like when the doorbell is pressed.

I've just downgraded SqueezeLite on my Windows file server, which drives the speakers in my Kitchen, from version "squeezelite-1.8.0-566-win32" back to version "squeezelite-1.5-365-win32" and the Google TTS is now working again.

Just seems odd I can still tune in Radio URLs OK but not Google TTS URLs any more.

The Media Center Blog
The Digital Lifestyle
Authorised Euro Z-wave dealer contact for bespoke prices!
(This post was last modified: 2015-05-01 14:46 by cw-kid.)
find quote
nickr Offline
Donor
Posts: 12,223
Joined: May 2009
Reputation: 220
Location: Christchurch NZ
Post: #1519
(2015-05-01 14:42)cw-kid Wrote:  Not related to XSqueeze but maybe of interest, with these new SqueezeLite builds we are discussing, Google TTS (Text to Speech) no longer appears to work!

For example in the Logitech Media Server webpage under the Radio section, there is an option to Tune in URL:

http://translate.google.co.uk/translate_...ello+world

The above URL no longer works, it appears to play in LMS on the SqueezeLite, but you can't hear the TTS.

However I can still tune in Radio URLs OK such as:

http://www.listenlive.eu/bbcradio1.m3u

I integrated my Home Automation Controller (Micasaverde Vera) with Kodi and Squeezelite, for voice announcements in the house when certain things happen, like when the doorbell is pressed.

I've just downgraded SqueezeLite on my Windows file server, which drives the speakers in my Kitchen, from version "squeezelite-1.8.0-566-win32" back to version "squeezelite-1.5-365-win32" and the Google TTS is now working again.

Just seems odd I can still tune in Radio URLs OK but not Google TTS URLs any more.

That my friend is fucking clever! I thought I was clever popping up on-screen notifications to the kids to come for dinner or tidy their rooms, but I like this even better!

If I have helped you or increased your knowledge, click the 'thank user' button to give thanks :) (People with less than 20 posts won't see the "Thank you" button.)
find quote
cw-kid Offline
Posting Freak
Posts: 1,260
Joined: Jun 2012
Reputation: 8
Post: #1520
I've got SqueezeLite running on my WHS 2011 server and this connects to an amp for the kitchen speakers. Using the Squeezebox plugin for Vera, I can then in my scenes send Google TTS announcements to that Squeezelite instance.

However running Squeezelite on Openelec Linux I could never get the Google TTS to work, I just hear nothing, yet music works fine.

I then discovered the DLNA plug-in for Vera, this supports Google TTS and works with my OpenElec PCs, it even resumes the media you were watching after its spoken the announcement! See my blog here for more about the DLNA plugin.

It's quite handy, I have scenes to run announcements like "Beer assistant" and "Kids turn off TV and go to sleep" Also a lot of my Vera lighting scheduled scenes are announced so I know what's going on, like "Schedule turning off lawn lights" and stuff like that.

The Media Center Blog
The Digital Lifestyle
Authorised Euro Z-wave dealer contact for bespoke prices!
(This post was last modified: 2015-05-01 22:06 by cw-kid.)
find quote
Snyder Offline
Junior Member
Posts: 10
Joined: Jan 2015
Reputation: 0
Post: #1521
I have installed XSqueeze a couple of times and I never had any problems. Since I bought a raspberry pi 2 and I installed OSMC, XSqueeze can´t connect to the player.

Please see my log file:

http://pastebin.com/XCViJXSR

I followed the installation instructions for Raspbmc, which doesn´t seem to work for OSMC:


Code:
sudo modprobe snd_bcm283
(This post was last modified: 2015-05-25 21:41 by Snyder.)
find quote
bossanova808 Offline
Donor
Posts: 2,567
Joined: Sep 2009
Reputation: 41
Location: Melbourne, Australia
Post: #1522
@Snyder - best thing to do is ssh in and run squeeslite from the addon dir on the command line and see what happens. Kill xbmc first initially, then try with xbmc running in BG etc.

The command line to try is found in the log basically:
21:13:57 T:1717851168 NOTICE: ### XSqueeze - 1.2.1 ### Attempting to start player: ['/home/osmc/.kodi/addons/script.xsqueeze/resources/bin/arm/squeezelite', '-m', '11:23:88:44:55:hf', '-o', 'dmix:CARD=ALSA,DEV=0', '-160', '-s', '192.168.178.20']

..if you get it working outside xbmc, it's usually easy from there. I know nothing about osmc though....

Sorry, no help w/out a *full debug log*
find quote
Snyder Offline
Junior Member
Posts: 10
Joined: Jan 2015
Reputation: 0
Post: #1523
ok... thanks. I will try it later...
find quote
nick w Offline
Senior Member
Posts: 271
Joined: Jan 2013
Reputation: 0
Post: #1524
(2015-05-25 21:39)Snyder Wrote:  I have installed XSqueeze a couple of times and I never had any problems. Since I bought a raspberry pi 2 and I installed OSMC, XSqueeze can´t connect to the player.

Please see my log file:

http://pastebin.com/XCViJXSR

I followed the installation instructions for Raspbmc, which doesn´t seem to work for OSMC:


Code:
sudo modprobe snd_bcm283
I had issues with openelec on a pi2. Haven't had too much time to investigate it recently. I had it working on a desktop running openelec after spending some time working out the errors with the dev
find quote
Post Reply