Freeze with tvheadend

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
bibi Offline
Senior Member
Posts: 205
Joined: Sep 2009
Reputation: 0
Post: #1
Hi,

I get little freezes in video with TVHeadend. In the log, i get :
Code:
11:53:23 T:2861562736 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
11:53:23 T:2861562736   ERROR: GetDelay - snd_pcm_delay, alsa error: -32 - Broken pipe

In Tvheadend i get :

Code:
Feb 18 12:06:02 TS: Philips TDA10046H DVB-T/LILLE TNT: 522,000 kHz/CANAL+: MPEG2VIDEO @ #160: Continuity counter error

Feb 18 12:06:02 TS: Philips TDA10046H DVB-T/LILLE TNT: 522,000 kHz/CANAL+: MPEG2AUDIO @ #80: Continuity counter error

Feb 18 12:06:02 TS: Philips TDA10046H DVB-T/LILLE TNT: 522,000 kHz/CANAL+: MPEG2AUDIO @ #81: Continuity counter error

Feb 18 12:06:02 TS: Philips TDA10046H DVB-T/LILLE TNT: 522,000 kHz/CANAL+: AC3 @ #83: Continuity counter error

Feb 18 12:06:02 TS: Philips TDA10046H DVB-T/LILLE TNT: 522,000 kHz/CANAL+: AC3 @ #82: Continuity counter error

Feb 18 12:06:02 TS: Philips TDA10046H DVB-T/LILLE TNT: 522,000 kHz/CANAL+: MPEG2VIDEO @ #160: Continuity counter error

Feb 18 12:06:02 TS: Philips TDA10046H DVB-T/LILLE TNT: 522,000 kHz/CANAL+: MPEG2AUDIO @ #80: Continuity counter error

Feb 18 12:06:02 TS: Philips TDA10046H DVB-T/LILLE TNT: 522,000 kHz/CANAL+: MPEG2AUDIO @ #81: Continuity counter error

Feb 18 12:06:02 TS: Philips TDA10046H DVB-T/LILLE TNT: 522,000 kHz/CANAL+: AC3 @ #83: Continuity counter error

Feb 18 12:06:02 TS: Philips TDA10046H DVB-T/LILLE TNT: 522,000 kHz/CANAL+: AC3 @ #82: Continuity counter error

Feb 18 12:06:02 TS: Philips TDA10046H DVB-T/LILLE TNT: 522,000 kHz/CANAL+: TELETEXT @ #32: Continuity counter error

For you, is it a problem with the tv signal ?
(This post was last modified: 2012-02-18 13:29 by bibi.)
find quote
reven Offline
Junior Member
Posts: 41
Joined: Oct 2009
Reputation: 0
Post: #2
i also am getting little freezes/stuttering with tvheadend

heres some info from my xbmc.log

Quote:19:02:12 T:2788600688 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
19:03:07 T:2788600688 WARNING: Previous line repeats 346 times.
19:03:07 T:2788600688 ERROR: GetDelay - snd_pcm_delay, alsa error: -32 - Broken pipe
19:03:07 T:2788600688 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
19:03:22 T:2788600688 WARNING: Previous line repeats 12 times.
19:03:22 T:2788600688 ERROR: GetDelay - snd_pcm_delay, alsa error: -32 - Broken pipe
19:03:22 T:2811734896 ERROR: Get - failed to get stream
19:03:41 T:3048085216 NOTICE: Samba is idle. Closing the remaining connections
19:04:19 T:2788600688 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
19:04:42 T:2788600688 WARNING: Previous line repeats 96 times.
19:04:42 T:2788600688 ERROR: GetDelay - snd_pcm_delay, alsa error: -32 - Broken pipe
19:04:42 T:2788600688 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
19:04:42 T:2811734896 ERROR: Get - failed to get stream
19:04:42 T:2788600688 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
this is happening on multiple clients (windows, openelec, ubuntu, osx) and also the xbmc running on the tvheadend server.

my tv server is a core i5 2500K with 16 GB RAM, so it shouldnt be a performance issue.

any info a dev needs to debug this let me know and i'll try and supply it.
find quote