XBMCbuntu display/resolution issues (laptop w/ vga out)

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Lukano Offline
Junior Member
Posts: 27
Joined: Dec 2004
Reputation: 0
Post: #1
I have a laptop with an Intel 945GM GPU and VGA out on it. I was running windows with xbmc outputting on the secondary display, but as I've enjoyed my testing with XBMCbuntu on my two other htpc's, I figured I'd give the laptop a go too.

Unfortunately, it seems to have some resolution/display issues with multiple displays (and perhaps due to the intel GPU/driver?).

The HDTV is 720p, and I've tried 1360x768 as the specified resolution without much luck. On a fresh install it defaults to 1024x768, but when I change it to 1360x768 I end up getting ~3/4 of the display showing ~3/4's of XBMC, and the right hand ~1/4 of the display showing the openbox wallpaper. If that makes any sense... Tongue

The openbox shell itself seems to be running @ 1024x768 on the laptop display, and mirroring / stretching that to fit the HDTV. This made me wonder if it was driver/config related, something specific to intel gpu's / settings (as it was not present on my acer revo / ion machine with nvidia drivers)... but as the openbox shell doesn't have any display / resolution configuration tools preinstalled, i'm at a loss as to what to try in order to play with resolutions manually, or disable the primary/laptop display in favor of only using the VGA/HDTV one.

There's also no /etc/X11/xorg.conf on that machine, whereas the acer revo generated a xorg.conf on install. I'm not really fancying having to roll my own xorg.conf for the laptop unless absolutely necessary.

Any thoughts/advice?

edit - I have confirmed that openbox is running @ 1024x768 by connecting to it remotely via VNC. When I ran xrandr -s 1360x768 it did successfully change the resolution of the VNC session, so I'm going to try adding that to ~/.config/openbox/autostart.sh to see if I can get it setting that resolution on boot. It's a bit of a shot in the dark, but it's all I've got to go on for now.

edit 2 - no luck there, same result when running @ 1360x768. Part of the XBMC menu is cut off, and replaced by the openbox / xbmcbuntu wallpaper.
(This post was last modified: 2012-02-21 03:45 by Lukano.)
find quote
Lukano Offline
Junior Member
Posts: 27
Joined: Dec 2004
Reputation: 0
Post: #2
Ok, I got it resolved manually for the time being.

Created ~/.xprofile and added the following to it;

xrandr --output VGA1 --mode 1360x768 --rate 60

sets the appropriate resolution on boot for that display now.
find quote
wrick01 Offline
Junior Member
Posts: 7
Joined: Feb 2012
Reputation: 0
Post: #3
signed up just for this post. Installed XBMCubuntu yesterday on my not so old Lenovo G530.

I'm getting the screen off by a few inches, and can't correct it. Will try the OP's way, my *nix aint my forte. It's just sooooo smooth compared to running XBMC on windows... I really don't want to go back !

If I can get this resolution thing going, I'm in heaven.

suscribed.
find quote
wrick01 Offline
Junior Member
Posts: 7
Joined: Feb 2012
Reputation: 0
Post: #4
Lukano Wrote:Ok, I got it resolved manually for the time being.

Created ~/.xprofile and added the following to it;

xrandr --output VGA1 --mode 1360x768 --rate 60

sets the appropriate resolution on boot for that display now.

that doesn't work for me...

I'm still missing an inch off the left side of the screen. I don't see the background, just a black bar. Like it was off to the right ( right is cut off ). tried all settings in xbmc, btw.
find quote
Lukano Offline
Junior Member
Posts: 27
Joined: Dec 2004
Reputation: 0
Post: #5
you can also run xrandr -q from a command line to see what interfaces you have, and what resolutions they support, then tailor your .xprofile line to match.

Yours may not be VGA1, or may not support 1360x768 specifically (may be 1280x720, or 1366x768 perhaps?).

I also had the black bar show instead of the XBMCbuntu wallpaper after switching resolutions back and forth a few times, so it does sound like you're experiencing the same issue as me.

(pro-tip if you're not already familiar with it, ctrl-alt-f1(through f6) will drop you to a shell and save you having to exit XBMC and log back into openbox. ctrl-alt-f7 to get back to the X session with XBMC again).
find quote
vikjon0 Offline
---
Posts: 2,500
Joined: Apr 2009
Reputation: 8
Location: Sweden
Post: #6
This is interesting because I have this issue in vmware.
However, when I have the issue on my HTPC I just use nvidia-settings to adjust overscan. You may want to take a look in what ever native config tool you have available.
find quote
alex84 Offline
Senior Member
Posts: 180
Joined: Jan 2010
Reputation: 2
Location: Sweden
Post: #7
I also reported this problem and others here
http://forum.xbmc.org/showthread.php?tid=123436

The installation for XBMCbuntu is not friendly for non HD resolution devices in my point of view.

Edit: Found a bugg report from igitur about the issue here
http://trac.xbmc.org/ticket/12622

Hope this will get fixed.

---------------------------------------------------
Intel NUC Haswell D34010WYK | ATV2 | Logitech Harmony One | Onkyo TX-NR808 Receiver | QNAP 809 | APC Back-UPS RS 550
(This post was last modified: 2012-02-21 10:20 by alex84.)
find quote
Lukano Offline
Junior Member
Posts: 27
Joined: Dec 2004
Reputation: 0
Post: #8
Not meaning to nitpick, but I saw your thread and while it was tangentially related - figured it was worth a seperate thread for troubleshooting my issue (which I then happened to resolved on my own, and then posted my workaround for).

Your thread and that ticket are specifically regarding resolution/dpi issues in the installer, not scan/sizing/resolution issues once installed. Very well related to the same root issue though, I just figured that as there was no specific verbiage for post-install issues, less linux savvy folks may not make the connection - thus making this thread.

Also, 1280x720 and 1360x768 (1366x768) are HD resolutions too - for 720p Smile

(ok sorry, so maybe I was nitpicking a little, but it's all in good fun)


vikjon0 Wrote:This is interesting because I have this issue in vmware.
However, when I have the issue on my HTPC I just use nvidia-settings to adjust overscan. You may want to take a look in what ever native config tool you have available.

Yeah that's originally where I was heading when posting the thread to start, looking for suggestions on what tool to use for intel gpu's to acheive the same results as nvidia-settings would for an nvidia setup. I just stumbled across the .xprofile / xrandr way of going about it manually via some google diving instead.
(This post was last modified: 2012-02-21 17:46 by Lukano.)
find quote
lcapriotti Offline
a.k.a Luigi, Team-XBMC XBMCbuntu Dev
Posts: 820
Joined: Jan 2008
Reputation: 12
Location: Italy
Post: #9
The next releases will include an xrandr frontend, ie an easy way of setting screen resolution.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
wrick01 Offline
Junior Member
Posts: 7
Joined: Feb 2012
Reputation: 0
Post: #10
lcapriotti Wrote:The next releases will include an xrandr frontend, ie an easy way of setting screen resolution.

Great news. I'll hang tight for the next release then !
find quote
wrick01 Offline
Junior Member
Posts: 7
Joined: Feb 2012
Reputation: 0
Post: #11
(2012-02-21 21:15)lcapriotti Wrote:  The next releases will include an xrandr frontend, ie an easy way of setting screen resolution.

Fresh install of eden, and even with the tool you guys included, I'm still getting the screen off by about 1.5 inches to the right.

For some reason I do not get this when I boot it into windows. I'm thinking I'm missing a resolution in the list.

I'll compare and report back.

edit : yup, I have the 1280x768 60hz resolution available for windows, and not under xbmcubuntu.

I'll google around to see if I can add that to the list. Should solve the problem I guess...

edit 2 : haha, really, clueless as to how to add it Smile I'm lost lol
(This post was last modified: 2012-03-29 04:29 by wrick01.)
find quote
wrick01 Offline
Junior Member
Posts: 7
Joined: Feb 2012
Reputation: 0
Post: #12
still no idea...
find quote
funtasticguy Offline
Junior Member
Posts: 39
Joined: Jul 2008
Reputation: 0
Post: #13
Greetings! I have the same situation as the original poster with the same Intel 945GM GPU and VGA out on it. When I set the Monitor preferences in XBMCbuntu to display VGA at 1360x768 it works within XBMCbuntu when it reloads (using Eden). If I run xbmc from within XBMCbuntu it displays the VGA out at 1360x768 and it looks nice. However, if I have it reboot under xbmclive, the VGA output is always at 800x600 and it mirrors my laptop's display which is also at 800x600. I don't want it to mirror my laptop's display. Instead, I want the VGA output with no mirroring at 1360x768.

Can someone provide a solution for me? Thanks
(This post was last modified: 2012-04-03 15:40 by funtasticguy.)
find quote
tekno Offline
Senior Member
Posts: 200
Joined: Feb 2012
Reputation: 1
Post: #14
I think this topic needs some clarification. Here are mentioned installer issues as well as running XBMCbuntu after installed. I think the original poster referred to the latter. The installer issue is not the same.

I have tried this on 2 desktop systems with Intel 945 Chips, and although one Mobo has a LVDS display out that is not used, and the other does not both show a "laptop display" in the Xbmcbuntu LXDE GUI. Even once disabled and tyhe session is started as XBMC the screen seems to be cut off on the right side of the screen. I can load XBMC from the LXDE GUI but there is something missing to get the display resolution correctly set . It appears that the right side of the display is cut off at 1024x768 when the display resolution is 1366x768 so I do not see the rightt side of the XBMC display. This is a separate issue that the bug report referenced earlier iin this thread, I believe.

IMHO this should be set entirely from within XBMC or the option should not be available at all .

too bad because this is the only solution for 5.1 sound that I have found on these boards. If we can resolve display issues that would be just ducky.
(This post was last modified: 2012-04-06 20:22 by tekno.)
find quote
pi3ch Offline
Junior Member
Posts: 11
Joined: Mar 2012
Reputation: 0
Post: #15
I had similar situation on my laptop and LCD TV (HDMI output change to VGA if needed).
I added this line to ~/.xprofile
Code:
xrandr --output HDMI1 --mode 1280x720 --rate 60.0 --output LVDS1 --off

that fixed the XBMC session. The other workaround was to set openbox as a default session (exit xbmc and login to xbmcbuntu) and setup Monitor settings (Settings > Monitor settings) and auto start xbmc ~/.config/autostart/xbmc_autostart.desktop:

Code:
[Desktop Entry]
Type=Application
Name=XBMC autostart
Comment=Start XBMC
Exec=xbmc
OnlyShowIn=LXDE
(This post was last modified: 2012-05-12 03:56 by pi3ch.)
find quote
Post Reply