[RELEASE] Artist Slideshow 1.3.0 addon (with skin and addon integration)

  Thread Rating:
  • 3 Votes - 4.33 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
GuidoW Offline
Junior Member
Posts: 8
Joined: Feb 2015
Reputation: 0
Post: #1321
(2015-02-21 15:51)GuidoW Wrote:  What the heck am I doing wrong?

I guess I just found the culprit

<substitute>
<from>special://profile/addon_data/</from>
<to>smb://srv/xbmc/addon_data/</to>
</substitute>

can it be, that AS can't handle the images to be downloaded to a windows share?
I can see many cryptic folders but nothing in them...
(This post was last modified: 2015-02-21 16:46 by GuidoW.)
find quote
scott967 Offline
Posting Freak
Posts: 973
Joined: Jul 2012
Reputation: 24
Post: #1322
(2015-02-21 15:51)GuidoW Wrote:  Hey pkscout
I'm desperately trying to get AS to display something, but I fail on each of my
installs. What the heck am I doing wrong?
Here's an example log of my office PC running Windows 10, but I fail on Windows 8.1
as on 2012R2 and dito on an android device.

http://1drv.ms/1DIvTRP

1 log normal, 1 log run as admin
I would really appreciate some input on what's going wrong.


Thanks!
Guido

Not sure but looking at that log it appears you have a path sub for your addon_data set to an smb share, but artist slideshow is attempting to use the default location (not using the subbed path).

scott s.
.
find quote
GuidoW Offline
Junior Member
Posts: 8
Joined: Feb 2015
Reputation: 0
Post: #1323
That's very likely the reason.
Maybe pkscout can find out if it's his end that ignores the substitution?
find quote
pkscout Offline
Posting Freak
Posts: 1,189
Joined: Jan 2011
Reputation: 24
Location: Honolulu, HI
Post: #1324
(2015-02-21 15:51)GuidoW Wrote:  Hey pkscout
I'm desperately trying to get AS to display something, but I fail on each of my
installs. What the heck am I doing wrong?
Here's an example log of my office PC running Windows 10, but I fail on Windows 8.1
as on 2012R2 and dito on an android device.

http://1drv.ms/1DIvTRP

1 log normal, 1 log run as admin
I would really appreciate some input on what's going wrong.


Thanks!
Guido

I don't know why it's happening, but on your machine every time AS tries to write one of the cache files for an artist it looks like it writes it but then can't find it 1 second later. I double checked, and everything is working on my dev machine (OS X) and production machine (Windows 7). I'd say you may have some kind of permissions problem on the addons_data folder in your Kodi settings directory.
find quote
ChickenLicken Offline
Junior Member
Posts: 22
Joined: Dec 2010
Reputation: 0
Location: Melbourne - Australia
Post: #1325
Hi Pkscout,

Love the add-on, but unfortunately since Frodo, I have had Artist Slideshow work for only a few tracks before it encounters an error and crashes.

I upgraded to Helix on the weekend, with AS 1.8.2...but unfortunately no joy....the script consistently crashes after a few songs.

Attached is a log file....I hope you can suggest a course of action!

I'm sure it is something trivial...

btw, I am running Kodi 14.1 on Gentoo

Regards

http://pastebin.com/75xzXF62
(This post was last modified: 2015-02-23 11:58 by ChickenLicken.)
find quote
pkscout Offline
Posting Freak
Posts: 1,189
Joined: Jan 2011
Reputation: 24
Location: Honolulu, HI
Post: #1326
(2015-02-23 11:36)ChickenLicken Wrote:  Hi Pkscout,

Love the add-on, but unfortunately since Frodo, I have had Artist Slideshow work for only a few tracks before it encounters an error and crashes.

I upgraded to Helix on the weekend, with AS 1.8.2...but unfortunately no joy....the script consistently crashes after a few songs.

Attached is a log file....I hope you can suggest a course of action!

I'm sure it is something trivial...

btw, I am running Kodi 14.1 on Gentoo

Regards

http://pastebin.com/75xzXF62

I have no idea what is causing that, and most of the error seems to be in the Requests module. The really odd thing is that the line number the error log has for where the issue is in AS doesn't match with the actual code. I'd suggest manually deleting AS and the Requests module and then reinstalling from the Kodi repo. To manually delete you need to quit Kodi and then go to the data folder for your install and then go to addons. Find script.artistslideshow and script.module.requests and delete them. Then restart Kodi and reinstall. Hopefully that'll do it.
find quote
ChickenLicken Offline
Junior Member
Posts: 22
Joined: Dec 2010
Reputation: 0
Location: Melbourne - Australia
Post: #1327
(2015-02-24 07:52)pkscout Wrote:  
(2015-02-23 11:36)ChickenLicken Wrote:  Hi Pkscout,

Love the add-on, but unfortunately since Frodo, I have had Artist Slideshow work for only a few tracks before it encounters an error and crashes.

I upgraded to Helix on the weekend, with AS 1.8.2...but unfortunately no joy....the script consistently crashes after a few songs.

Attached is a log file....I hope you can suggest a course of action!

I'm sure it is something trivial...

btw, I am running Kodi 14.1 on Gentoo

Regards

http://pastebin.com/75xzXF62

I have no idea what is causing that, and most of the error seems to be in the Requests module. The really odd thing is that the line number the error log has for where the issue is in AS doesn't match with the actual code. I'd suggest manually deleting AS and the Requests module and then reinstalling from the Kodi repo. To manually delete you need to quit Kodi and then go to the data folder for your install and then go to addons. Find script.artistslideshow and script.module.requests and delete them. Then restart Kodi and reinstall. Hopefully that'll do it.

- I stopped Kodi, manually deleted the 2 directories above as directed.
- Relaunched Kodi, ran the Add-on update and it reinstalled both the AS and Requests module from the Kodi respositories

Unfortunately, it still crashes...in the past it used to be able to show a few images before crashing, but now it is blank until the script fails.

I've added a link to the new logs....perhaps they might shed some light

http://pastebin.com/QvaVc85c

I also tried moving my .kodi folder to a backup location .kodi.bak, then restarting kodi, ie so that it loads the default settings and downloads all the plugins again to create a fresh profile.

Unfortunately it doesn't make any difference. It's probably some incompatibility with the distro I am using

Thanks
(This post was last modified: 2015-02-24 22:01 by ChickenLicken.)
find quote
manfeed Online
Senior Member
Posts: 114
Joined: Jan 2011
Reputation: 1
Location: Spain
Post: #1328
Hi, first of all I would like to say thanks for AS, really nice, it adds a lot to the experience of listening to the music.

I'm trying to use it in a music visualization screen and mostly it works like a charm... I'm using the options that you put in your wiki...

Window(Visualisation).Property(ArtistSlideshow.%d.SimilarName)
Window(Visualisation).Property(ArtistSlideshow.%d.SimilarThumb)

Window(Visualisation).Property(ArtistSlideshow.%d.AlbumName)
Window(Visualisation).Property(ArtistSlideshow.%d.AlbumThumb)

...to get the names and thumbs. Similar artists works perfectly. Discography is getting a bit awkward though, I mean, with most artist it works well, but not so with others... for example Faith Hill:

Window(Visualisation).Property(ArtistSlideshow.1.AlbumName) = It matters to me
Window(Visualisation).Property(ArtistSlideshow.2.AlbumName) = Cry
Window(Visualisation).Property(ArtistSlideshow.3.AlbumName) = Faith
Window(Visualisation).Property(ArtistSlideshow.4.AlbumName) = The private collection
Window(Visualisation).Property(ArtistSlideshow.5.AlbumName) = Fireflies
Window(Visualisation).Property(ArtistSlideshow.6.AlbumName) = Breath

Window(Visualisation).Property(ArtistSlideshow.1.AlbumThumb) = EMPTY
Window(Visualisation).Property(ArtistSlideshow.2.AlbumThumb) = correct image
Window(Visualisation).Property(ArtistSlideshow.3.AlbumThumb) = EMPTY
Window(Visualisation).Property(ArtistSlideshow.4.AlbumThumb) = correct image
Window(Visualisation).Property(ArtistSlideshow.5.AlbumThumb) = EMPTY
Window(Visualisation).Property(ArtistSlideshow.6.AlbumThumb) = correct image

I have found that AlbumName always returns the names, but the problem is AlbumThumb (only with certains artist, not all of them). Not sure whether you could do something about... thanks anyway...


P.S. Another one I have found: Christina Aguilera:

Window(Visualisation).Property(ArtistSlideshow.3.AlbumName) = Mi Reflejo
Window(Visualisation).Property(ArtistSlideshow.3.AlbumThumb) = EMPTY

P.S.(2) Upps... it's happening more frequently than I thought... other ones are Cassadee Pope, Vonda Shepard, Sugarland...
(This post was last modified: 2015-02-24 13:55 by manfeed.)
find quote
pkscout Offline
Posting Freak
Posts: 1,189
Joined: Jan 2011
Reputation: 24
Location: Honolulu, HI
Post: #1329
(2015-02-24 12:00)manfeed Wrote:  Hi, first of all I would like to say thanks for AS, really nice, it adds a lot to the experience of listening to the music.

I'm trying to use it in a music visualization screen and mostly it works like a charm... I'm using the options that you put in your wiki...

Window(Visualisation).Property(ArtistSlideshow.%d.SimilarName)
Window(Visualisation).Property(ArtistSlideshow.%d.SimilarThumb)

Window(Visualisation).Property(ArtistSlideshow.%d.AlbumName)
Window(Visualisation).Property(ArtistSlideshow.%d.AlbumThumb)

...to get the names and thumbs. Similar artists works perfectly. Discography is getting a bit awkward though, I mean, with most artist it works well, but not so with others.

SNIP

I have found that AlbumName always returns the names, but the problem is AlbumThumb (only with certains artist, not all of them). Not sure whether you could do something about... thanks anyway...

The album and artist thumbs are downloaded from theaudiodb.com. If they don't have one for an album or artist, you won't see one. I spot checked a few of your examples, and in each case the thing was empty because there is nothing on theaudiodb.com for it. That site does take user submissions, so the best way to fix your problem is to find the artwork you need and upload it. Then everyone benefits. The second best way is to look at the override .nfo files. That would allow you to have local artwork for the things that don't have stuff in theaudiodb.com. But I think the latter would take longer, and you'd be the only one who benefits.
find quote
manfeed Online
Senior Member
Posts: 114
Joined: Jan 2011
Reputation: 1
Location: Spain
Post: #1330
(2015-02-26 09:51)pkscout Wrote:  
(2015-02-24 12:00)manfeed Wrote:  Hi, first of all I would like to say thanks for AS, really nice, it adds a lot to the experience of listening to the music.

I'm trying to use it in a music visualization screen and mostly it works like a charm... I'm using the options that you put in your wiki...

Window(Visualisation).Property(ArtistSlideshow.%d.SimilarName)
Window(Visualisation).Property(ArtistSlideshow.%d.SimilarThumb)

Window(Visualisation).Property(ArtistSlideshow.%d.AlbumName)
Window(Visualisation).Property(ArtistSlideshow.%d.AlbumThumb)

...to get the names and thumbs. Similar artists works perfectly. Discography is getting a bit awkward though, I mean, with most artist it works well, but not so with others.

SNIP

I have found that AlbumName always returns the names, but the problem is AlbumThumb (only with certains artist, not all of them). Not sure whether you could do something about... thanks anyway...

The album and artist thumbs are downloaded from theaudiodb.com. If they don't have one for an album or artist, you won't see one. I spot checked a few of your examples, and in each case the thing was empty because there is nothing on theaudiodb.com for it. That site does take user submissions, so the best way to fix your problem is to find the artwork you need and upload it. Then everyone benefits. The second best way is to look at the override .nfo files. That would allow you to have local artwork for the things that don't have stuff in theaudiodb.com. But I think the latter would take longer, and you'd be the only one who benefits.

Ok. Thank you, now I understand. My issue is that I'm coding a Music Visualization screen; my aim is to provide similar artists and discography information and their corresponding images while the song is playing. With similar artists there's no problem; would there be any way to get discography work in the same way? I mean, that AlbumName.1 and AlbumThumb.1 (and so on) only returned results if both had any content...

Sorry if I'm asking for too much...

Thank you...
(This post was last modified: 2015-02-26 18:04 by manfeed.)
find quote
m66k Offline
Junior Member
Posts: 1
Joined: Feb 2015
Reputation: 0
Post: #1331
Does someone know why Artist Slideshow only works when I use some kind of visualization (like waveform)? Nothing happens when visualization is set to none. I don't really like those visualization graphs running on my artist slideshow though.

I'm using Aeon Nox skin on Openelec 5.0.3 with Raspberry Pi 1 B
find quote
Post Reply