TVHeadend not letting me in

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
gsi095 Offline
Member
Posts: 65
Joined: Feb 2009
Reputation: 0
Post: #1
hi,

I install XBMCbuntu, updated to the PVR build from packages.pulse-eight.net and went to configure TVHeadend and I get a log in screen.

I have tried xbmc/xbmc, the user login details, but keep getting "The server localhost:9981 requires a username & password. The server says: TVHeadend"

I did the reconfigure utility via terminal and changed the user and password but keep getting this same reply.

Am I doing something wrong??

Dave
find quote
LastCoder Offline
Fan
Posts: 459
Joined: Dec 2011
Reputation: 0
Post: #2
Sorry, have no idea .. try to ask in the tvheadend forum (https://www.lonelycoder.com/redmine/proj...end/boards)

Greetz

LastCoder

Ubuntu 12.04 LTS Server, Xfce, KODI Helix, Skin Confluence, tvheadend tv backend
ASUS P8H61-M LE/USB3, Celeron G530, Geforce 210, 4 GB DDR3 RAM
16 GB CnMemory 300x CF, 1 TB Samsung 2,5" HDD
iHOS104 BluRay Drive, TT DVBS2-1600
Silverstone GD05B Case, Sony PS3 BD Remote control, Logitech Cordless Mediaboard Pro for PS3
find quote
j1nx Offline
Fan
Posts: 651
Joined: Aug 2011
Reputation: 23
Location: Netherlands
Post: #3
1st figure out under which user the tvheadend is running;
Quote:#ps ax | grep tvheadend
You will get out such as;
Quote:2140 ? Ssl 3:55 /usr/bin/tvheadend -f -u hts -g video
32238 pts/1 R+ 0:00 grep --color=auto tvheadend
There you will see, it runs as user "hts" (-u hts)

Go into the hts config folder for that user;
Quote:cd /home/hts/.hts/tvheadend/
Here are all setting stored. But also the config of the super user. You need to be root, so under ubuntu for instance;
Quote:sudo cat superuser
You will get an output like;
Quote:{
"username": "gsi095",
"password": "forgotthedamnthing"
}

Use those to get into the webadmin and do your things.
find quote
opdenkamp Offline
Team-XBMC PVR Developer
Posts: 2,242
Joined: Feb 2009
Reputation: 29
Location: Heerlen, The Netherlands
Post: #4
or just run:
sudo dpkg-reconfigure tvheadend

you'll be asked to enter a new password.

opdenkamp / dushmaniac

xbmc-pvr [Eden-PVR builds] [now included in mainline XBMC, so no more source link here :)]
personal website: [link]

Found a problem with PVR? Report it on Trac, under "PVR - core components". Please attach the full debug log.

If you like my work, please consider donating to me and/or Team XBMC.
find quote
babca Offline
Junior Member
Posts: 28
Joined: Apr 2011
Reputation: 0
Post: #5
I had a similar issue, and found this:
Quote:create a file calles "1" with following content in the ~/.hts/tvheadend/accesscontrol/ directory
Code:
{
        "enabled": 1,
        "username": "*",
        "password": "*",
        "comment": "Default access entry",
        "prefix": "0.0.0.0/0",
        "streaming": 1,
        "dvr": 1,
        "webui": 1,
        "admin": 1,
        "id": "1"
}

source:
http://openelec.tv/forum/36-solved-bug-r...ting-users
http://www.lonelycoder.com/redmine/issues/166

For some reason the ~/.hts/tvheadend/accesscontrol/ directory had gone, so I had to create it again incl. the '1' file and it's OK now.

My silent AMD Zacate HTPC on MSI E350IA-E45, 16W@46°C when idle, 27sec cold boot
find quote
nobleach Offline
Junior Member
Posts: 38
Joined: Nov 2008
Reputation: 0
Post: #6
(2012-03-17 12:59)dushmaniac Wrote:  or just run:
sudo dpkg-reconfigure tvheadend

you'll be asked to enter a new password.

It doesn't matter how many times I try this, it doesn't let me in. I can see the username and password in the file, so I know I'm typing it correctly.

Does it not allow my to connect from a remote host? I can't connect from localhost, it doesn't have a web browser.
find quote
Prof Yaffle Offline
Donor
Posts: 1,377
Joined: Mar 2011
Reputation: 30
Location: UK - in the middlish (mostly).
Post: #7
Have you played with the IP address config at all? Could it be that you're connecting from a PC that doesn't have admin rights because of its IP address?

I can't remember off the top of my head, but I wonder if tvheadend defaults to localhost unless you change it... so are you connecting from the machine hosting tvheadend, or a different one?

Have a look at ~/.hts/tvheadend/accesscontrol and see what's in there...
find quote
nobleach Offline
Junior Member
Posts: 38
Joined: Nov 2008
Reputation: 0
Post: #8
Yep, originally had it set to 0.0.0.0/0. I changed it to 192.168.1.0/24 just to see if it would change the outcome. I also SSHed in and used lynx to localhost:9981. It fails just the same.

Unless there's somewhere else to change it.
find quote
thatsenough Offline
Junior Member
Posts: 1
Joined: Mar 2012
Reputation: 0
Post: #9
Try start tvheadend with -C. This will create a user account with no username/password if no user exists already. Then you can get access and create a new user.

That did it for me.
find quote
lachs Offline
Junior Member
Posts: 2
Joined: May 2012
Reputation: 0
Post: #10
(2012-09-15 00:20)nobleach Wrote:  Yep, originally had it set to 0.0.0.0/0. I changed it to 192.168.1.0/24 just to see if it would change the outcome. I also SSHed in and used lynx to localhost:9981. It fails just the same.

Unless there's somewhere else to change it.

I had the same problem but when i ran:

cat /home/username/.hts/tvheadend/accesscontrol/1

it displayed:

root@LachsMC:/home/lachs/.hts/tvheadend/accesscontrol# cat 1
{
"enabled": 1,
"username": "xbmc",
"password": "xbmc",
"comment": "Default access entry",
"streaming": 1,
"dvr": 1,
"dvrallcfg": 1,
"webui": 1,
"admin": 1,
"id": "1"
}

showing me that despite setting up my own password with the initial tvheadend config it is using xbmc/xbmc as the user/pass still...
Hope this helps...
find quote
shess757 Offline
Donor
Posts: 132
Joined: Mar 2013
Reputation: 0
Post: #11
(2013-01-07 02:52)lachs Wrote:  
(2012-09-15 00:20)nobleach Wrote:  Yep, originally had it set to 0.0.0.0/0. I changed it to 192.168.1.0/24 just to see if it would change the outcome. I also SSHed in and used lynx to localhost:9981. It fails just the same.

Unless there's somewhere else to change it.

I had the same problem but when i ran:

cat /home/username/.hts/tvheadend/accesscontrol/1

it displayed:

root@LachsMC:/home/lachs/.hts/tvheadend/accesscontrol# cat 1
{
"enabled": 1,
"username": "xbmc",
"password": "xbmc",
"comment": "Default access entry",
"streaming": 1,
"dvr": 1,
"dvrallcfg": 1,
"webui": 1,
"admin": 1,
"id": "1"
}

showing me that despite setting up my own password with the initial tvheadend config it is using xbmc/xbmc as the user/pass still...
Hope this helps...

Had same problem tried xbmc/xbmc and it worked, just wanted to update this post.

Raspberry Pi
OpenELEC 5.0 Helix
find quote
martyn379 Offline
Junior Member
Posts: 2
Joined: Jan 2015
Reputation: 0
Post: #12
Dear all,

I am a new user to Kodi but played around with XBMC for a while - never really getting it to work properly for me.

In addition to the issues above - I followed the instructions to find that the hts user wasn't in fact running tvheadend on my system. I don't know if this is a quirk of the Ubuntu setup I am using but it was using the user name set up during *buntu installation.

By using
Code:
ps ax | grep tvheadend


as suggested I accidently discovered that.

When looking through that users home directory there was the 'hts hidden file with all the settings in the subdirectories as already described. If you find your setups are not behaving it might be worthwhile checking your own home folder if you have one.

Best wishes

Martyn.
find quote
negge Offline
Team-Kodi Member
Posts: 2,763
Joined: Dec 2010
Reputation: 28
Location: Finland
Post: #13
@martyn379 uninstall tvheadend completely and install it from the apt repository. I recommend using the "unstable" version, it's not really unstable but packs a ton of new features and fixes.
find quote
martyn379 Offline
Junior Member
Posts: 2
Joined: Jan 2015
Reputation: 0
Post: #14
negge - thanks I shall try that...
find quote