Disable screensaver during music playback

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
fungify Offline
Senior Member
Posts: 146
Joined: Jul 2010
Reputation: 2
Post: #1
(Original thread here: http://forum.xbmc.org/showthread.php?tid=125524)

I use the Slideshow screensaver to display my pictures when XBMC aren't used - and this works perfectly as intended. When XBMC aren't accessed for the desired duration, my pictures start displaying. And when I play music, XBMC displays the music fanart in the background with Now Playing information. This is also what I really like.

Now - the problem is, that after the music have played for some time, the screensaver kicks in, and the fanart is no longer displayed. Instead I get the Slideshow screensaver with a smaller Now Playing information.

Is there any way to disable this behavior?

FFY
find quote
TrentSe7en Offline
Junior Member
Posts: 9
Joined: Dec 2012
Reputation: 0
Post: #2
Bumpity

Did you ever find a solution to thisConfused
find quote
BigNoid Offline
Team-Kodi Member
Posts: 3,188
Joined: Jul 2010
Reputation: 105
Location: Below sea level
Post: #3
you can toggle that setting in the appearance-->screensaver section.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
overseer Offline
Junior Member
Posts: 13
Joined: Feb 2013
Reputation: 0
Post: #4
(2013-11-05 11:51)BigNoid Wrote:  you can toggle that setting in the appearance-->screensaver section.

Really? I can't seem to find that option.

I'm looking to find a solution for the exactly issue OP is having. Haven't found it yet.
find quote
BigNoid Offline
Team-Kodi Member
Posts: 3,188
Joined: Jul 2010
Reputation: 105
Location: Below sea level
Post: #5
(2013-11-24 00:35)overseer Wrote:  
(2013-11-05 11:51)BigNoid Wrote:  you can toggle that setting in the appearance-->screensaver section.

Really? I can't seem to find that option.

I'm looking to find a solution for the exactly issue OP is having. Haven't found it yet.

Really?
Settings/System -->Appearance--> "Use visualization if playing audio"

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
antisuck Offline
Member
Posts: 71
Joined: Mar 2011
Reputation: 1
Post: #6
(2013-11-24 06:01)BigNoid Wrote:  
(2013-11-24 00:35)overseer Wrote:  
(2013-11-05 11:51)BigNoid Wrote:  you can toggle that setting in the appearance-->screensaver section.

Really? I can't seem to find that option.

I'm looking to find a solution for the exactly issue OP is having. Haven't found it yet.

Really?
Settings/System -->Appearance--> "Use visualization if playing audio"
I was thinking about the same issue recently and played with this setting - my conclusion was that the extrafanart slideshow built into Nox isn't actually a visualization, so this setting has no effect on it. In order for the extrafanart slideshow to be displayed properly one would normally set the visualization to "none", and the logic of the setting in question acts like it's testing for a non-zero visualization before overriding the screensaver.
find quote
overseer Offline
Junior Member
Posts: 13
Joined: Feb 2013
Reputation: 0
Post: #7
(2013-11-24 11:19)antisuck Wrote:  
(2013-11-24 06:01)BigNoid Wrote:  
(2013-11-24 00:35)overseer Wrote:  Really? I can't seem to find that option.

I'm looking to find a solution for the exactly issue OP is having. Haven't found it yet.

Really?
Settings/System -->Appearance--> "Use visualization if playing audio"
I was thinking about the same issue recently and played with this setting - my conclusion was that the extrafanart slideshow built into Nox isn't actually a visualization, so this setting has no effect on it. In order for the extrafanart slideshow to be displayed properly one would normally set the visualization to "none", and the logic of the setting in question acts like it's testing for a non-zero visualization before overriding the screensaver.

That sounds about right.
find quote
ben.page Offline
Member
Posts: 54
Joined: Feb 2013
Reputation: 0
Post: #8
So... What's the solution then?

XBMC 13.0 Gotham - Windows 7 x64
find quote
huzz456 Offline
Senior Member
Posts: 129
Joined: Dec 2012
Reputation: 0
Post: #9
Id like to know this too, turning on 'Use visualization if playing audio" doesn't work......
find quote
949BFN Offline
Junior Member
Posts: 6
Joined: Jun 2014
Reputation: 0
Location: Bloemfontein, South Africa
Post: #10
Anyone with a solution for this issue, please?
find quote