[RELEASE] XBMC Subtitles - Addon Script

  Thread Rating:
  • 6 Votes - 4.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Closed
amet Offline
Retired Team-Kodi Member
Posts: 4,087
Joined: Jul 2009
Reputation: 41
Location: Novi Sad / Dubai
Post: #166
(2012-04-28 19:39)necronomicon Wrote:  
(2012-04-28 18:29)amet Wrote:  read the first page of this thread

I've just edited my post, adding the required full debug log: http://forum.xbmc.org/showthread.php?tid=126495&pid=1089270#pid1089270

since I cant see, does "smb://xbmc:SMB_PASSWD_REMOVED@HOSTNAME_REMOVED/disk_3/Video/Series/New Girl/01/" have any non ascii characters ?

try with this fix -> https://github.com/amet/script.xbmc.subt...a8262aba66
(This post was last modified: 2012-04-28 20:07 by amet.)
find
necronomicon Offline
Junior Member
Posts: 12
Joined: Apr 2012
Reputation: 0
Post: #167
(2012-04-28 19:55)amet Wrote:  
(2012-04-28 19:39)necronomicon Wrote:  
(2012-04-28 18:29)amet Wrote:  read the first page of this thread

I've just edited my post, adding the required full debug log: http://forum.xbmc.org/showthread.php?tid=126495&pid=1089270#pid1089270

since I cant see, does "smb://xbmc:SMB_PASSWD_REMOVED@HOSTNAME_REMOVED/disk_3/Video/Series/New Girl/01/" have any non ascii characters ?

Both the password and the hostname have ASCII characters.
find
amet Offline
Retired Team-Kodi Member
Posts: 4,087
Joined: Jul 2009
Reputation: 41
Location: Novi Sad / Dubai
Post: #168
(2012-04-28 19:57)necronomicon Wrote:  
(2012-04-28 19:55)amet Wrote:  
(2012-04-28 19:39)necronomicon Wrote:  I've just edited my post, adding the required full debug log: http://forum.xbmc.org/showthread.php?tid=126495&pid=1089270#pid1089270

since I cant see, does "smb://xbmc:SMB_PASSWD_REMOVED@HOSTNAME_REMOVED/disk_3/Video/Series/New Girl/01/" have any non ascii characters ?

Both the password and the hostname have ASCII characters.

only ascii? try this -> https://github.com/amet/script.xbmc.subt...a8262aba66
find
necronomicon Offline
Junior Member
Posts: 12
Joined: Apr 2012
Reputation: 0
Post: #169
(2012-04-28 20:07)amet Wrote:  
(2012-04-28 19:57)necronomicon Wrote:  
(2012-04-28 19:55)amet Wrote:  since I cant see, does "smb://xbmc:SMB_PASSWD_REMOVED@HOSTNAME_REMOVED/disk_3/Video/Series/New Girl/01/" have any non ascii characters ?

Both the password and the hostname have ASCII characters.

only ascii? try this -> https://github.com/amet/script.xbmc.subt...a8262aba66

Yep, 100% ASCII. Let me try this and get back to you.
find
necronomicon Offline
Junior Member
Posts: 12
Joined: Apr 2012
Reputation: 0
Post: #170
(2012-04-28 20:09)necronomicon Wrote:  
(2012-04-28 20:07)amet Wrote:  
(2012-04-28 19:57)necronomicon Wrote:  Both the password and the hostname have ASCII characters.

only ascii? try this -> https://github.com/amet/script.xbmc.subt...a8262aba66

Yep, 100% ASCII. Let me try this and get back to you.

Ok, so this seems to be working in some cases, but not in all of them. Subtitles that are unzipped in the temp folder usually look like "New Girl 1x20 - Normal (Español (España)).srt" and are not successfully processed (so you are definitely narrowing down the encoding issue)
I'm using mainly two providers: OpenSubtitles.org and Subdivx (for Spanish subtitles both of them), and I've noticed that some filenames avoid non-ASCII characters and others don't.

Again, it seems you are going down the right path with the fix above... let me know if you want me to test any other modification.
find
amet Offline
Retired Team-Kodi Member
Posts: 4,087
Joined: Jul 2009
Reputation: 41
Location: Novi Sad / Dubai
Post: #171
(2012-04-28 20:27)necronomicon Wrote:  
(2012-04-28 20:09)necronomicon Wrote:  
(2012-04-28 20:07)amet Wrote:  only ascii? try this -> https://github.com/amet/script.xbmc.subt...a8262aba66

Yep, 100% ASCII. Let me try this and get back to you.

Ok, so this seems to be working in some cases, but not in all of them. Subtitles that are unzipped in the temp folder usually look like "New Girl 1x20 - Normal (Español (España)).srt" and are not successfully processed (so you are definitely narrowing down the encoding issue)
I'm using mainly two providers: OpenSubtitles.org and Subdivx (for Spanish subtitles both of them), and I've noticed that some filenames avoid non-ASCII characters and others don't.

Again, it seems you are going down the right path with the fix above... let me know if you want me to test any other modification.

Would be interesting to see tha failure while using those files. It would help narrow down where it fails and fix it
find
necronomicon Offline
Junior Member
Posts: 12
Joined: Apr 2012
Reputation: 0
Post: #172
(2012-04-28 20:30)amet Wrote:  
(2012-04-28 20:27)necronomicon Wrote:  
(2012-04-28 20:09)necronomicon Wrote:  Yep, 100% ASCII. Let me try this and get back to you.

Ok, so this seems to be working in some cases, but not in all of them. Subtitles that are unzipped in the temp folder usually look like "New Girl 1x20 - Normal (Español (España)).srt" and are not successfully processed (so you are definitely narrowing down the encoding issue)
I'm using mainly two providers: OpenSubtitles.org and Subdivx (for Spanish subtitles both of them), and I've noticed that some filenames avoid non-ASCII characters and others don't.

Again, it seems you are going down the right path with the fix above... let me know if you want me to test any other modification.

Would be interesting to see tha failure while using those files. It would help narrow down where it fails and fix it

Ok, let me try to see what I can do. The problem now is that I was able to download all of the missing subtitles using either "opensubtitles" or "subdivx" (alternating between both providers depending on whether one or the other was failing with the encoding issue...), so now I can't remember which one was giving me this headache Tongue

Let me get back to you as soon as I can catch an example.

[quickedit]
Something I did notice after applying your fix was that all of the sudden some of the subtitles that I had downloaded but failed to process where successfully processed without having to redownload.
[/quickedit]
(This post was last modified: 2012-04-28 20:42 by necronomicon.)
find
Rififi77 Offline
Senior Member
Posts: 144
Joined: Aug 2010
Reputation: 0
Location: Paris, France
Post: #173
(2012-04-28 20:07)amet Wrote:  
(2012-04-28 19:57)necronomicon Wrote:  
(2012-04-28 19:55)amet Wrote:  since I cant see, does "smb://xbmc:SMB_PASSWD_REMOVED@HOSTNAME_REMOVED/disk_3/Video/Series/New Girl/01/" have any non ascii characters ?

Both the password and the hostname have ASCII characters.

only ascii? try this -> https://github.com/amet/script.xbmc.subt...a8262aba66

Thank amet,
this fix resolve my problem with betaseries

@+

[Image: G2M]
OS: yavdr64-0.5.0 XBMC GOTHAM-13.0 - VDR 2.0.3
Box: Advance 3906B
DVBS2: S2-3200
CM: ASUS AT3N7A-I - 4 Go - HD 750 Go Samsung
NAS: D-Link DNS-325 + infinity USB smart
find
amet Offline
Retired Team-Kodi Member
Posts: 4,087
Joined: Jul 2009
Reputation: 41
Location: Novi Sad / Dubai
Post: #174
(2012-04-28 21:08)Rififi77 Wrote:  
(2012-04-28 20:07)amet Wrote:  
(2012-04-28 19:57)necronomicon Wrote:  Both the password and the hostname have ASCII characters.

only ascii? try this -> https://github.com/amet/script.xbmc.subt...a8262aba66

Thank amet,
this fix resolve my problem with betaseries

@+

good to know, thx for letting us know
find
ailingcoot Offline
Senior Member
Posts: 205
Joined: Mar 2012
Reputation: 0
Post: #175
(2012-04-28 18:50)amet Wrote:  
(2012-04-28 18:48)ailingcoot Wrote:  
(2012-04-28 18:22)amet Wrote:  [quote='Rififi77' pid='1089232' dateline='1335628027']
[quote='amet' pid='1089128' dateline='1335618879']

hey amet, for the shooters service connection problem(just freeze at that step.) http://pastebin.com/qaemTBxs
Anyway to fix that?

sure, but you need to read the first post of this thread again.. we need FULL debug log... its not optional
It is the complete log for the subtitle service since XBMC froze at that step and I had to force it to stop by the win system manager. Maybe you are talking about the previous computer hardware/software information? wait a minute , i would paste that now.


UPDATE: It is solved now, might due to the server busy or something. thanks though.
(This post was last modified: 2012-04-29 03:46 by ailingcoot.)
find
Wanilton Offline
Posting Freak
Posts: 1,316
Joined: Jun 2010
Reputation: 28
Location: Florianópolis - Brazil
Post: #176
@Amet, latest translate strings for Portuguese (Brazil), please download here:

http://dl.dropbox.com/u/25170804/Subtitles/strings.xml

Thanks,

Wanilton

http://www.xbmcbrasil.net - Youtube Channel
Admin
Windows 8.1 - Kodi Helix Custom Plus - Aeon MQ 5
My Room Entertaiment´s
About me
find
necronomicon Offline
Junior Member
Posts: 12
Joined: Apr 2012
Reputation: 0
Post: #177
(2012-04-28 21:13)amet Wrote:  
(2012-04-28 21:08)Rififi77 Wrote:  
(2012-04-28 20:07)amet Wrote:  only ascii? try this -> https://github.com/amet/script.xbmc.subt...a8262aba66

Thank amet,
this fix resolve my problem with betaseries

@+

good to know, thx for letting us know

amet,

After running some tests with other TV shows, I can confirm the problem still persists in some scenarios. I was able to get the "zipsubs.zip" (provider: OpenSubtitles) and "subdivx.rar" (provider: SubDivx) for subtitles that are failing to be processed by the script (it's downloaded to the "sub_tmp" folder and extracted correctly, but the script fails to move it to the target folder together with the TV show video file)

The SRTs inside are "The Mentalist 4x21 - Ruby Slippers (Español (España)).srt" for OpenSubtitles and "The Mentalist 4x21 LOL Espa¤ol.srt" for SubDivx, but I think getting you the ZIP and RAR files will be more accurate since I'm not sure the characters will be conveyed to you correctly when posted here. What is the recommended way for sharing these sort of files in the forum?

Thanks.
find
amet Offline
Retired Team-Kodi Member
Posts: 4,087
Joined: Jul 2009
Reputation: 41
Location: Novi Sad / Dubai
Post: #178
(2012-04-29 05:31)necronomicon Wrote:  
(2012-04-28 21:13)amet Wrote:  
(2012-04-28 21:08)Rififi77 Wrote:  Thank amet,
this fix resolve my problem with betaseries

@+

good to know, thx for letting us know

amet,

After running some tests with other TV shows, I can confirm the problem still persists in some scenarios. I was able to get the "zipsubs.zip" (provider: OpenSubtitles) and "subdivx.rar" (provider: SubDivx) for subtitles that are failing to be processed by the script (it's downloaded to the "sub_tmp" folder and extracted correctly, but the script fails to move it to the target folder together with the TV show video file)

The SRTs inside are "The Mentalist 4x21 - Ruby Slippers (Español (España)).srt" for OpenSubtitles and "The Mentalist 4x21 LOL Espa¤ol.srt" for SubDivx, but I think getting you the ZIP and RAR files will be more accurate since I'm not sure the characters will be conveyed to you correctly when posted here. What is the recommended way for sharing these sort of files in the forum?

Thanks.

You have pm with my e-mail address, please send it there and I will look into it

Thx
find
MicaH_Z Offline
Junior Member
Posts: 7
Joined: Jun 2006
Reputation: 0
Post: #179
Hi guys,

i need some help. Since I upgraded to Eden I'm no longer able to download subtitles.

Here's my log: http://pastebin.com/mvypur5A

Here's what's weird:
the log states: failed to get url 'http://api.bierdopje.com/369C2ED4261DE9C3/GetAllSubsFor/9203/5/22/nl' but if I copy/paste that url in my browser I get a nice response with a sweet xml like page containing several subtitles for the episode I want.

Hopfully someone here can give me a clue as to what's going on... Life is so much sweeter with a working subtitle addon.

Kind regards,

MicaH
find
ronie Offline
Team-Kodi Member
Posts: 9,504
Joined: Jan 2009
Reputation: 168
Post: #180
(2012-05-01 23:43)MicaH_Z Wrote:  Hi guys,

i need some help. Since I upgraded to Eden I'm no longer able to download subtitles.

Here's my log: http://pastebin.com/mvypur5A

Here's what's weird:
the log states: failed to get url 'http://api.bierdopje.com/369C2ED4261DE9C3/GetAllSubsFor/9203/5/22/nl' but if I copy/paste that url in my browser I get a nice response with a sweet xml like page containing several subtitles for the episode I want.

Hopfully someone here can give me a clue as to what's going on... Life is so much sweeter with a working subtitle addon.

Kind regards,

MicaH

looks like xbmc can't connect to the internet
check if the proxy setting in xbmc isn't accidentally enabled.

Settings > Network > Internet Access > Use HTTP proxy...

Always read the Kodi online-manual, FAQ and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find
Thread Closed