AppleTV 2 (black) - XBMC Eden on iOS 5 Performance

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
infinitybiff Offline
Junior Member
Posts: 3
Joined: Apr 2012
Reputation: 0
Post: #1
Hey all, just replaced my xbmc box with an atv2. It shipped with the latest iOS on it so I went ahead and did the tethered jailbreak and loaded the xbmc eden version compiled for ios 5. http://forum.xbmc.org/showthread.php?tid=127369

I'm aware that this build isn't listed as stable or supported by the team etc. Trying to determine if I can expect a performance increase if I downgrade my iOS version and install the official 11.0 release. There is some noticeable lag in the UI and when first jumping into the movie or tv libraries. Video playback is just fine.

Is this UI lag due to ios 5 + new build or is this standard fair for xbmc on atv2? Any input would be appreciated. Totally fine with downgrading to lower fw to achieve better performance.Nod
find quote
deanmv Offline
Posting Freak
Posts: 876
Joined: Jun 2011
Reputation: 10
Location: UK
Post: #2
If you don't have the old SHSH blobs from firmwares used before then you can't downgrade iOS. You are stuck on iOS 5.0 for now and the version that was built for 5.0 is built on the stable 11.0 Eden release. The only difference is the stuff added to compensate for the changes in iOS 5.0. For UI speeding up try using dirty regions: http://wiki.xbmc.org/index.php?title=Dirty_regions

Set Up
Raspberry Pi running Raspbmc - XBMC 12.2
40" Samsung ES6800 LED Smart 3D 1080P TV
Onkyo HTS3405 5.1 DD True HD and DTS-HD Surround Sound
ReadyNAS Duo with 4TB (2 x 2TB X-RAID) Western Digital Caviar Green using NFS
(This post was last modified: 2012-04-03 14:25 by deanmv.)
find quote
infinitybiff Offline
Junior Member
Posts: 3
Joined: Apr 2012
Reputation: 0
Post: #3
(2012-04-03 14:24)deanmv Wrote:  If you don't have the old SHSH blobs from firmwares used before then you can't downgrade iOS. You are stuck on iOS 5.0 for now and the version that was built for 5.0 is built on the stable 11.0 Eden release. The only difference is the stuff added to compensate for the changes in iOS 5.0. For UI speeding up try using dirty regions: http://wiki.xbmc.org/index.php?title=Dirty_regions

It looks like I can use this http://forum.firecore.com/topic/7292 to get back to an older firmware. Will the same lag still exist or am I wasting my time? I was under the impression that dirty regions was enabled by default per the changelog http://wiki.xbmc.org/index.php?title=XBM..._changelog (crtl + f dirty)
find quote
deanmv Offline
Posting Freak
Posts: 876
Joined: Jun 2011
Reputation: 10
Location: UK
Post: #4
I think you would still need the old SHSH from 4.4.4 but I could be wrong on that. Support for Dirty Regions was added in Eden but it is no on by default.

"value, result description
0 Off The entire viewport is always rendered. This is the default mode." From the link I put in the first post.

Set Up
Raspberry Pi running Raspbmc - XBMC 12.2
40" Samsung ES6800 LED Smart 3D 1080P TV
Onkyo HTS3405 5.1 DD True HD and DTS-HD Surround Sound
ReadyNAS Duo with 4TB (2 x 2TB X-RAID) Western Digital Caviar Green using NFS
find quote
infinitybiff Offline
Junior Member
Posts: 3
Joined: Apr 2012
Reputation: 0
Post: #5
Ok thanks. I'll try downgrading first and if that doesn't work i'll go back to what I'm rolling with now. Either way I'll turn on dirty regions and see if that helps.

(2012-04-03 15:09)deanmv Wrote:  I think you would still need the old SHSH from 4.4.4 but I could be wrong on that. Support for Dirty Regions was added in Eden but it is no on by default.

"value, result description
0 Off The entire viewport is always rendered. This is the default mode." From the link I put in the first post.
find quote
alexkoo1812 Offline
Junior Member
Posts: 1
Joined: Apr 2012
Reputation: 0
Post: #6
I got the same problem as you, infinitybiff..
I'm using the AeonNox skin and the UI has noticeable lag while browsing through my over 700+ movie collection could be painful.
I'm trying to change to default skin and see any improve and if not, then I'll try dirty region you guys mentioned.

Let me know if it work fine on you.
Thanks
find quote