[SOLVED]Sound only playing thru laptop, not TV and 'window' not completely accessible

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
wellyfish Offline
Junior Member
Posts: 18
Joined: Apr 2012
Reputation: 0
Photo  [SOLVED]Sound only playing thru laptop, not TV and 'window' not completely accessible
Post: #1
Got a Dell studio 17 laptop running win 7 with 1GB ATI Mobility Radeon HD 5650 Graphics Card.

Plugged the HDMI cable into the laptop and into the TV.

Start playing a program thru iPlayer addon (tried playing videos too but get same problem).

Problem is, the sound only plays through laptop speakers and not thru TV.

Also, and this seems really weird, once I'm trying to play the program the 'window' on the laptop, although it's completely visible, I can't move the mouse all the way to the left or all the way to the bottom ... I can only move it so far!

Any help greatly appreciated ...

Here's a screenshot of my audio settings under System->System->Audio Settings

[Image: xbmc-audio.gif]
(This post was last modified: 2012-05-11 20:15 by kricker.)
find quote
kricker Offline
Team-XBMC QA Specialist
Posts: 3,537
Joined: Apr 2004
Reputation: 20
Location: Knoxville, TN
Post: #2
Does that laptop support audio over the HDMI port? You may need to setup the audio out in the Windows sound control panel first to go over HDMI. Then in XBMC change the Audio output device to WASPI (name of display device). And why is your speaker Configuration set at 3?

Read this before using these builds.
XBMC win32 SVN builds
Changelog
(This post was last modified: 2012-05-10 19:16 by kricker.)
find quote
wellyfish Offline
Junior Member
Posts: 18
Joined: Apr 2012
Reputation: 0
Post: #3
Don't mean to be thick ... but how do I set the audio out to be HDMI ...

I'm running Win 7. When I go into Control Panel -> Sound I see two things listed

1) Speakers/Headphones
IDT High definition Audio Codec
Default Device

2) Independent RTC Headphones

Can't see anything to do with HDMI.

Oh, I don't know why my speaker config is set to 3 ... maybe I clicked it trying to get the sound working ... what should it be set to?

Thanks,
(This post was last modified: 2012-05-10 20:45 by wellyfish.)
find quote
kricker Offline
Team-XBMC QA Specialist
Posts: 3,537
Joined: Apr 2004
Reputation: 20
Location: Knoxville, TN
Post: #4
The system settings are going to be slightly driver specific. But for example, on my Core i3 System I go to Control Panels\Hardware and Sound. Then I click on Manage audio devices. There I see listed:
  • Speakers 2-High Definition Audio Device
  • Headphones 2-High Definition Audio Device
  • Digital Audio (S/PDIF) 2-High Definition Audio Device
  • SONY TV Intel® Display audio
The Sony TV is set as the default device. I can choose it and configure it or check the properties. You may need to look in the Catalyst Control Panel for HDMI audio out settings and make sure to install any ATI driver needed to provide HDMI audio through that port. At least those are the things I would look at. Make sure you get audio out the HDMI port in the OS. Once that is working then set it up in XBMC.

Read this before using these builds.
XBMC win32 SVN builds
Changelog
(This post was last modified: 2012-05-10 23:38 by kricker.)
find quote
wellyfish Offline
Junior Member
Posts: 18
Joined: Apr 2012
Reputation: 0
Post: #5
After looking around a little and realising that I didn't have a HDMI device listed under Sound -> Manage audio devices I managed to find a way to get it listed.

Now it shows like this:

AMD HDMI Output Device
Not plugged in

Looking in XBMC under System->System->audio settings, the Audio Output Device shows only the following:

WASAPI: Speakers/Headphones (IDT High Definition Audio CODEC)
Direct Sound: Primary Sound Driver
Direct Sound: Speakers/Headphones (IDT High Definition Audio CODEC)
find quote
kricker Offline
Team-XBMC QA Specialist
Posts: 3,537
Joined: Apr 2004
Reputation: 20
Location: Knoxville, TN
Post: #6
I would Imagine that:

AMD HDMI Output Device
Not plugged in

...means it does not see an audio device plugged in via HDMI. I think you are still missing something in the OS.

Read this before using these builds.
XBMC win32 SVN builds
Changelog
find quote
wellyfish Offline
Junior Member
Posts: 18
Joined: Apr 2012
Reputation: 0
Post: #7
Any ideas as to what I might have to do to resolve that on Win7?
find quote
kricker Offline
Team-XBMC QA Specialist
Posts: 3,537
Joined: Apr 2004
Reputation: 20
Location: Knoxville, TN
Post: #8
Without having that laptop in front of me it is hard to know. You should check the users manual and Dell support site. You should be able to find the info you need there.

What did you do to finally get the HDMI listed in audio devices? Did you have the TV connected and on when you got it listed, but it said "Not plugged in"?

Read this before using these builds.
XBMC win32 SVN builds
Changelog
find quote
wellyfish Offline
Junior Member
Posts: 18
Joined: Apr 2012
Reputation: 0
Post: #9
I right clicked in the Playback tab on the Sound dialog and clicked 'Show Disabled Devices" and saw the HDMI output in that list.

I never got a user manula with the laptop that was of any use ... I'll see if Dell can help.

Thanks for you help though.
(This post was last modified: 2012-05-11 17:52 by wellyfish.)
find quote
kricker Offline
Team-XBMC QA Specialist
Posts: 3,537
Joined: Apr 2004
Reputation: 20
Location: Knoxville, TN
Post: #10
I guess the next step is to see why it is disabled.

Read this before using these builds.
XBMC win32 SVN builds
Changelog
find quote
wellyfish Offline
Junior Member
Posts: 18
Joined: Apr 2012
Reputation: 0
Post: #11
UPDATE:

I turned my laptop off and, as it was powering down I got the windows updating x of xx updates stuff.

After that I turned my tv off then plugged the hdmi cable into the tv and turned the tv on.
Then I plugged the hdmi cable into the laptop and turned the laptop on.
I fired up XBMC and tried to play a video ... the HDMI output showed up in the list in System->system->Audio Output so I selected that device and BINGO ... sound thrugh my tv.

Thanks!!!
find quote