ATV2 - First time XBMC *No videos showing up

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
toddbass10 Offline
Junior Member
Posts: 2
Joined: May 2012
Reputation: 0
Post: #1
I successfully got my ATV2 jailbroken and installed XBMC. However, no matter if I try UPNP (with XBMC installed on my Windows 7 machine) or a Windows share, XBMC fails to see any videos in the directory. I'm working with a video in MKV format currently. What am I doing wrong? It happens either when I go to add a source or browse for files under Add Videos...
find quote
Ned Scott Offline
Wiki Guy
Posts: 30,736
Joined: Jan 2011
Reputation: 521
Location: Arizona, USA
Post: #2
Try to get us a debug log: iOS XBMC.log (wiki)

Full disclosure: I work for WeTek. However, this is my personal account, and my words and opinion are my own.

You can make easy links to the Kodi Wiki Manual using double brackets around common Kodi words: [[debug log]] = debug log (wiki), [[Video library]] = Video library (wiki), [[SMB]] = SMB (wiki) , [[userdata]] = userdata (wiki), etc
find quote
toddbass10 Offline
Junior Member
Posts: 2
Joined: May 2012
Reputation: 0
Post: #3
http://pastesite.com/37304
find quote
Ozymandyaz Offline
Member
Posts: 85
Joined: May 2011
Reputation: 0
Location: Toronto, ON
Post: #4
I'm no expert... But I think its an authentication or permission issue with your Samba share...

From the log you can see it trying to access the share and then failing to list the directory.

Code:
17:42:21 T:121950208   ERROR: GetDirectory - Error getting smb://
17:42:21 T:121950208   ERROR: CGUIDialogFileBrowser::GetDirectory(smb://) failed
17:42:22 T:128552960   DEBUG: OpenDir - Using authentication url smb://tsnyder:[email protected]%2dPC

I would check the sharing permissions on the storage computer and make sure that the user has full read permissions. Next, I'd try and make it a share with no password, even if its only for troubleshooting purposes. And finally, I'd browse to the computer by IP just to rule out any windows URL parsing or master browser nonsense...

I use SMB shares with 5.1.1 and they work great!

Guide for MySQL database using Synology NAS
http://youtu.be/3PmmDtK65ks

Silent AppleTV with Crystalbuntu
http://quixventure.com/2011/12/crystalbu...roduction/
find quote
Memphiz Offline
Non-Serving Developer
Posts: 14,863
Joined: Feb 2011
Reputation: 188
Location: germany
Post: #5
Use the IP instead of the NetBios name of your server.

AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
find quote