[RELEASE] MyPicsDB: Pictures DB with EXIF, IPTC & XMP tags

  Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
twiseva Offline
Junior Member
Posts: 39
Joined: Jul 2013
Reputation: 0
Post: #631
(2016-06-10 03:13)twiseva Wrote:  
(2016-06-06 15:01)peppe_sr Wrote:  
(2016-06-06 12:03)Xycl Wrote:  Please try version 13.3.8

it worked at first attempt
thanks
Peppe

So it seems that this same error has appeared for ma after updating to 13.3.8. See http://pastebin.com/raw/SHXqw4ZL. Looks basically the same. Prior to 13.3.8 all was well, afterwards get an error popup and this in the logs.

Did a quick hack that worked for me in default.py as follows. Excuse my hack as I have never programmed in Python.

95 # Altered change to remove the '&reload' and EVERYTHING after it
96 self.parm= self.parm.split('&reload=')[0]
find quote
Xycl Offline
Fan
Posts: 423
Joined: Feb 2012
Reputation: 9
Location: Germany
Post: #632
To only remove &reload=xxx till next ampersand please use version 13.3.9

No log no help.
How to submit a log file: XBMC-Wiki

Main page: https://github.com/Xycl
Repository: Xycl Repository
find quote
twiseva Offline
Junior Member
Posts: 39
Joined: Jul 2013
Reputation: 0
Post: #633
(2016-06-10 15:29)Xycl Wrote:  To only remove &reload=xxx till next ampersand please use version 13.3.9

Works great -- thanks @Xycl.
find quote
stuka Offline
Junior Member
Posts: 2
Joined: Jun 2016
Reputation: 0
Post: #634
Hey,
Before explaining why I came here, let me say that I'm a beginner with Kodi, and Kodi Add-ons.
So I installed Kodi, then your (marvelous) add-on on my old PC, which was running Windows before, and now Mint 17.3.

When I try to scan the folder that contains all my pics (about 20.000), PyPicsDB scans it, but stops after a while. It finds precisely 5311 pictures.
I tried 2 times with different installs, and the problem remains the same. I don't know if I'm just dumb and didn't find an obvious way to fix it, or if a problem exists in my files.

Thanks for reading this, and thanks for you work !

EDIT : It appears that one of my .jpg has been corruted, excluded it and re-scanning, I'll update in the morning
(This post was last modified: 2016-07-01 22:56 by stuka.)
find quote
peppe_sr Offline
Posting Freak
Posts: 1,142
Joined: Mar 2006
Reputation: 15
Location: Italia, Sicilia, Siracusa
Post: #635
The easy way to understand your problem is through a debug log. Turn in on the settings, perform the scan and post the log on pastebin
Peppe
find quote
stuka Offline
Junior Member
Posts: 2
Joined: Jun 2016
Reputation: 0
Post: #636
Thanks,
I checked myself in the log a bit, and it appears that one folder I was trying to scan contained corrupted files.
I excluded it in the search path, and it worked properly
Thanks for reading me, problem is fixed !
find quote
varun432 Offline
Junior Member
Posts: 5
Joined: Jul 2016
Reputation: 0
Post: #637
Hi I am new here

Hey , how to add music playlist to my album
I can't seem to be able to do it... Can't find that option anywhere

Please help with this stupid question

Thanks in advance for reply
find quote
rubpa Offline
Junior Member
Posts: 40
Joined: Jun 2010
Reputation: 0
Location: India
Post: #638
Hi!

I've been using MyPicsDB for years now and a problem has been bothering me for months. I tag my photos using the face tagging feature of Picasa for Windows (which is configured to write face tags to the photos itself). I've 4000 pics of person X but MyPicsDB shows only about 400. The number shown by MyPicsDB varies whenever I go to Browse by Tags -> Person. Never figured out why. I've tried resetting the whole db and the problem is back after few weeks.

Today,
- I added only 1 folder to MyPicsDB with about 1000 photos. It found 411 photos of person X. Closed Kodi.
- Opened Picasa, tagged a new person (about 25 photos). Closed Picasa.
- Opened Kodi, MyPicsDB, scan for new/changed photos.
- After the scanning, new person has 25 photos, person X is down to 6 photos (all of which have new person as well).

If it helps, Picasa writes XMP-mwg-rs tags for faces.

Kindly fix the problem.
find quote
rubpa Offline
Junior Member
Posts: 40
Joined: Jun 2010
Reputation: 0
Location: India
Bug  RE: [RELEASE] MyPicsDB: Pictures DB with EXIF, IPTC & XMP tags
Post: #639
Hi Xycl!

It appears that more tags have a similar problem, not just the Person tag. I did an even more minimal test today. I added a single folder to MyPicsDB with 2 pictures. Both pics had the IPTC Caption/Description set to "Wow". I scanned them and I see 2 pics in the Browse by Tags -> Description -> Wow.

Then I edited one of the pictures and changed the caption to "Wowa". I scanned for new & changed pictures and MyPicsDB correctly shows 1 modified. Now Browse by Tags -> Description -> has only Wowa listed and Wow is missing.

However this does not happen always, sometimes both tags stayed - keep changing the caption from Wow to Wowa and back and the problem does happen soon enough. When it happens, I checked with a sqlite browser that the TagsInFiles.idTagContent has values which do not exist in TagContents table. It appears that instead of reusing the existing idTagType<->TagContent unique pair, a new record is added with a new idTagContent and the old pairs are deleted.

Is it a bug in the sqlite engine? I did my tests with v16.1 on Win7. I strongly believe it is the same problem on my main kodibuntu installation.
find quote
Post Reply