[MOD] ReAlaska : ReFocus meets Alaska (0.9.6 git)

  Thread Rating:
  • 7 Votes - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Sabish Offline
Senior Member
Posts: 160
Joined: Jul 2011
Reputation: 7
Post: #31
Update !

Ok, it took me some time, but i finally figured out how to properly code the pause and info OSD's. As you can see on the screenshots below, theyre now completed, with HD logo, rating stars, scrolling plot, progress bar and dialogs (Pause, seeking + 0:30, etc.). As asked, paused OSD and Info OSD are now exactly the same. I also shrinked the poster and clearart a little bit, and reworked the shadow of the poster.

I also integrated the custom fullscreen gallery view (with poster + HD flag), to please Amercian psycho..i mean Patrick Bateman Wink

Yoiu have to redownload/reinstall the skin to get the new features (link on page 1 updated)

Screenshots :

[Image: screenshot021.jpg]

[Image: screenshot022.jpg]

[Image: screenshot023.jpg]

[Image: screenshot024.jpg]


I'm gonna take a break now .. Wink

My reFocus mods : reAlaska & reAlaska (Dark)
find quote
sting2010 Offline
Junior Member
Posts: 30
Joined: Sep 2010
Reputation: 0
Post: #32
fantastic skin....love it! Problem I'm having on my macmini with OSX lion and Eden release is that there is a persistent line of code displayed related to the Home.xml file at the top of my screen

Line of code displayed is:

Window Home (Home.xml) Mouse (0,0) Focused: (9000) (listSmile


when I do the exact same install on my macbook pro - the line of code is not seen - can't figure out why it only appears on the macmini setup
(This post was last modified: 2012-06-18 04:37 by sting2010.)
find quote
PatrickBateman Offline
Posting Freak
Posts: 1,675
Joined: Mar 2011
Reputation: 17
Location: Another Earth
Post: #33
I think I love you Sabish Smile
Your officially off my list of people to kill Wink

Thanks for the awesome updates, this officially my new default skin.

Enjoy the summer break, you totally deserve it!

Thanks again,
Pat~

Edit:
1 minor bug.
In the new gallery view, movie and tv show descriptions don't scroll so long descriptions are cut off.
Its no biggie, but i just thought I'd mention it Smile

Thanks again for this awesome skin.
It's a delight to use and view.
Pat~
(This post was last modified: 2012-06-17 21:24 by PatrickBateman.)
find quote
Sabish Offline
Senior Member
Posts: 160
Joined: Jul 2011
Reputation: 7
Post: #34
(2012-06-17 17:53)sting2010 Wrote:  fastastic skin....love it! Prblem I'm having on my macmini with OSX lion and Eden release is that there is a persistent line of code displayed related to the Home.xml file at the top of my screen

when I do the exact same install on my macbook pro - the line of code is not seen - can't figure out why it only appears on the macmini setup

That's weird..can you provide a screenshot ?

(2012-06-17 20:15)PatrickBateman Wrote:  Your officially off my list of people to kill Wink

Remind me to never show you my business card Wink

Quote:Edit:
1 minor bug.
In the new gallery view, movie and tv show descriptions don't scroll so long descriptions are cut off.
Its no biggie, but i just thought I'd mention it Smile

Yep, noticed it too, will fix it in next update.

Quote:Thanks again for this awesome skin.
It's a delight to use and view.
Pat~

Thanks everyone for the warm feeback... almost 1500 views in 48hrs...nice Smile

My reFocus mods : reAlaska & reAlaska (Dark)
find quote
Jimmeh Offline
Member
Posts: 75
Joined: Aug 2010
Reputation: 0
Location: Berkshire, UK
Post: #35
Brilliant, all working now. The only thing I can find that's slightly off, the poster/clearart graphic is bottom aligned on the info screen, but isn't on the pause screen. Looks better at the bottom I think, probably just a minor tweak.

(2012-06-18 00:12)Sabish Wrote:  Thanks everyone for the warm feeback... almost 1500 views in 48hrs...nice Smile

You deserve the attention, it's a lovely mod.

[Image: signature.png]
(This post was last modified: 2012-06-18 02:55 by Jimmeh.)
find quote
htpc guy Offline
Posting Freak
Posts: 1,182
Joined: Oct 2010
Reputation: 7
Location: Near St. Louis Mo
Post: #36
This is looking really good. What are your plans? Do you aim to add more viewtypes? Can I suggest a view using logo.png's for both TV and Movies?

How to use Git
| AMD Athlon II X3 Triple Core Processor 2.9 GHz |GIGABYTE GA-MA785GM-US2H Mobo 2GB DDR2 Ram | MSI N430GT |
| Logitec Harmony One Remote| 52" Sharp Aquos LED TV | Demon AVR-X1000 |
find quote
sting2010 Offline
Junior Member
Posts: 30
Joined: Sep 2010
Reputation: 0
Post: #37
(2012-06-18 00:12)Sabish Wrote:  
(2012-06-17 17:53)sting2010 Wrote:  fastastic skin....love it! Prblem I'm having on my macmini with OSX lion and Eden release is that there is a persistent line of code displayed related to the Home.xml file at the top of my screen

when I do the exact same install on my macbook pro - the line of code is not seen - can't figure out why it only appears on the macmini setup

That's weird..can you provide a screenshot ?

Line of code displayed is:

Window Home (Home.xml) Mouse (0,0) Focused: (9000) (list

(2012-06-17 20:15)PatrickBateman Wrote:  Your officially off my list of people to kill Wink

Remind me to never show you my business card Wink

Quote:Edit:
1 minor bug.
In the new gallery view, movie and tv show descriptions don't scroll so long descriptions are cut off.
Its no biggie, but i just thought I'd mention it Smile

Yep, noticed it too, will fix it in next update.

Quote:Thanks again for this awesome skin.
It's a delight to use and view.
Pat~

Thanks everyone for the warm feeback... almost 1500 views in 48hrs...nice Smile
find quote
lordvorta Offline
Junior Member
Posts: 5
Joined: Apr 2010
Reputation: 0
Post: #38
First off can I say what a fantastic skin! I have just upgrade to a openelec pvr build and was trying to find a replacement skin for Alaska as it doesn't have PVR support.

When I stumbled across your skin which is just awesome! A perfect replacement for Alaska with PVR support.

(2012-06-16 01:32)Jimmeh Wrote:  Wow, this looks sexy.

Just tried it, it is sexy. One minor issue, I can't see any clearart or posters in the info view, with or without the options enabled under skin options, and the files are definitely in the folders. banner.jpg, logo.png, etc.

I'm using the stable eden build, am I doing something wrong?

Only one small issue, I am experiencing the same as above, no clear art or posters in the info view. I have 2 installs of xbmc one on a openelec pc and the other install on a Atv2 I am getting the issue on both machine's no clear art or posters. These installs are using a shared SQL library and shared thumbnails folder on a Freenas smb shared and all media is also stored on a smb share.

I have tested in a other skin Alaksa and the clear art and logos are working. I will try and install refocus to see if I get the same missing clear art and logos.

I would love to get this issue resolved as this skin is just fantastic!

I will see if I can't do some more investigation and have a look at some debug logs to see if I can work out what's is going on.
(This post was last modified: 2012-06-18 11:04 by lordvorta.)
find quote
LastCoder Offline
Fan
Posts: 434
Joined: Dec 2011
Reputation: 0
Post: #39
hi,

it looks so awesome Big Grin .. it could be my new skin .. but - I'm afraid to ask since I know the answer - does it support livetv [.. in a better way than refocus itself does] Huh

Greetz

LastCoder

Ubuntu 12.04 LTS Server, Xfce, XBMC Gotham, Skin reFred, tvheadend tv backend
ASUS P8H61-M LE/USB3, Celeron G530, Geforce 210, 4 GB DDR3 RAM
16 GB CnMemory 300x CF, 1 TB Samsung 2,5" HDD
iHOS104 BluRay Drive, TT DVBS2-1600
Silverstone GD05B Case, Sony PS3 BD Remote control, Logitech Cordless Mediaboard Pro for PS3
find quote
Sabish Offline
Senior Member
Posts: 160
Joined: Jul 2011
Reputation: 7
Post: #40
(2012-06-18 00:35)Jimmeh Wrote:  Brilliant, all working now. The only thing I can find that's slightly off, the poster/clearart graphic is bottom aligned on the info screen, but isn't on the pause screen. Looks better at the bottom I think, probably just a minor tweak.
This should be just like the screenshots...what's yout platform ?

Anyone else experiencing this ?

Quote:You deserve the attention, it's a lovely mod.

Thanks Wink

(2012-06-18 01:20)htpc guy Wrote:  This is looking really good. What are your plans? Do you aim to add more viewtypes? Can I suggest a view using logo.png's for both TV and Movies?

I don't think i will add more views, i think the skin is perfect the way it is : the author (jeroen) made a hell of a job. As for movie logos, i think it beter suits skins like Aeon and such, but maybe in the future

The only thing i would like to improve is the home menu. I think that a mix between the light vertical menu and the search results view (see below) to show recently added media could be really cool, and still be coherent with the rest of the skin.

[Image: screenshot025.jpg]

[Image: screenshot026.jpg]

[Image: screenshot027.jpg]

Maybe i'll give it a shot, but since my skinning knowledge is still limited, i don't know if i can pull it off ...if any experienced skinners are interested, please let me know Wink

(2012-06-18 11:01)lordvorta Wrote:  First off can I say what a fantastic skin! I have just upgrade to a openelec pvr build and was trying to find a replacement skin for Alaska as it doesn't have PVR support.

When I stumbled across your skin which is just awesome! A perfect replacement for Alaska with PVR support.

(2012-06-16 01:32)Jimmeh Wrote:  Wow, this looks sexy.

Just tried it, it is sexy. One minor issue, I can't see any clearart or posters in the info view, with or without the options enabled under skin options, and the files are definitely in the folders. banner.jpg, logo.png, etc.

I'm using the stable eden build, am I doing something wrong?

Only one small issue, I am experiencing the same as above, no clear art or posters in the info view. I have 2 installs of xbmc one on a openelec pc and the other install on a Atv2 I am getting the issue on both machine's no clear art or posters. These installs are using a shared SQL library and shared thumbnails folder on a Freenas smb shared and all media is also stored on a smb share.

I have tested in a other skin Alaksa and the clear art and logos are working. I will try and install refocus to see if I get the same missing clear art and logos.

I would love to get this issue resolved as this skin is just fantastic!

I will see if I can't do some more investigation and have a look at some debug logs to see if I can work out what's is going on.

First off : thanks Wink Are you sure you're using the very last version ((link on page 1) ? I did reupload a new version yesterday, wich should fix this issue...

My reFocus mods : reAlaska & reAlaska (Dark)
find quote
lordvorta Offline
Junior Member
Posts: 5
Joined: Apr 2010
Reputation: 0
Post: #41
[quote='Sabish' pid='1129691' dateline='1340012523'
First off : thanks ;) Are you sure you're using the very last version ((link on page 1) ? I did reupload a new version yesterday, wich should fix this issue...
[/quote]

Hi Sabish,

Just redownloaded the updated version and still no go HuhI did uninstall the older version before installing the updated one.

Tried the new version on both my XBMC installs. So I am not sure why it wouldn't be working with your mod extremely strange.
find quote
Jimmeh Offline
Member
Posts: 75
Joined: Aug 2010
Reputation: 0
Location: Berkshire, UK
Post: #42
These are from my windows box, 1920x1200.

I can test it on my linux box later if you need, that's 1920x1080.

[Image: 2LEyYh.jpg]
[Image: 6mR9Eh.jpg]

I have the OSD bar enabled in info, maybe that's why it's off? Also start/finish is missing on the top right of the info screen, not sure if you intended that or not.

[Image: signature.png]
(This post was last modified: 2012-06-18 17:24 by Jimmeh.)
find quote
oswald09 Offline
Junior Member
Posts: 12
Joined: Nov 2009
Reputation: 0
Post: #43
Quote:Just redownloaded the updated version and still no go I did uninstall the older version before installing the updated one.

Tried the new version on both my XBMC installs. So I am not sure why it wouldn't be working with your mod extremely strange.

Same problem here, tested with a few of the recent nightlies.
find quote
LastCoder Offline
Fan
Posts: 434
Joined: Dec 2011
Reputation: 0
Big Grin  PVR / LiveTV
Post: #44
Hi,

tested the skin .. I like it, great work Nod .. PVR works too Big Grin !

But there are some issues:

A. PVR-Support

1. There is a general refocus error : when entering the livetv section there is no clear focus for one of the sub sections (would prefer focus at channel overview) .. the left menu has focus, which is not WAF compatible ..

2. After entering Livetv section
- the shown channel list is "too big" for an overview
- there is no minimized tv window
- progress indicators don't work
- timeline: whole program background in purple, black letters - unreadable !

3. channel OSD
- the channel logo is located upper left corner; would be better to be located in the lower left corner at OSD panel
- no progress indicator for running program
- would like to see detailed EPG information for current program, atm only headline (compare Rapier skin)
- no "icon-ified" information about current program
- letters to small - information (what's running now, what's next etc) can't be seized at a glance

4. watching live tv
- channel list - progess indicators don't work
- channel list - channel logos are unproportional resized

B. Other issues

Video section - doesn't give me a list of sources like files etc. only get "addons" and "search"

Greetz

LastCoder

Ubuntu 12.04 LTS Server, Xfce, XBMC Gotham, Skin reFred, tvheadend tv backend
ASUS P8H61-M LE/USB3, Celeron G530, Geforce 210, 4 GB DDR3 RAM
16 GB CnMemory 300x CF, 1 TB Samsung 2,5" HDD
iHOS104 BluRay Drive, TT DVBS2-1600
Silverstone GD05B Case, Sony PS3 BD Remote control, Logitech Cordless Mediaboard Pro for PS3
find quote
Sabish Offline
Senior Member
Posts: 160
Joined: Jul 2011
Reputation: 7
Post: #45
(2012-06-18 17:22)Jimmeh Wrote:  These are from my windows box, 1920x1200.

I can test it on my linux box later if you need, that's 1920x1080.

[Image: 2LEyYh.jpg]
[Image: 6mR9Eh.jpg]

I have the OSD bar enabled in info, maybe that's why it's off? Also start/finish is missing on the top right of the info screen, not sure if you intended that or not.

The skin is intended for 1280x720 (should work the same in 1920x1080)... the little gap in 1920x1200 is normal.

You're right, i forgot to add clock on OSD info screen. To enable it, copy
Code:
    <include>clock</include>
just after <controls> at the beginning of DialogFullscreenInfo.xml (/720p folder)

... maybe this will fix your problem also. Let me know...
(2012-06-19 09:39)LastCoder Wrote:  Hi,

tested the skin .. I like it, great work Nod .. PVR works too Big Grin !

But there are some issues:

A. PVR-Support

1. There is a general refocus error : when entering the livetv section there is no clear focus for one of the sub sections (would prefer focus at channel overview) .. the left menu has focus, which is not WAF compatible ..

2. After entering Livetv section
- the shown channel list is "too big" for an overview
- there is no minimized tv window
- progress indicators don't work
- timeline: whole program background in purple, black letters - unreadable !

3. channel OSD
- the channel logo is located upper left corner; would be better to be located in the lower left corner at OSD panel
- no progress indicator for running program
- would like to see detailed EPG information for current program, atm only headline (compare Rapier skin)
- no "icon-ified" information about current program
- letters to small - information (what's running now, what's next etc) can't be seized at a glance

4. watching live tv
- channel list - progess indicators don't work
- channel list - channel logos are unproportional resized

B. Other issues

Video section - doesn't give me a list of sources like files etc. only get "addons" and "search"

Greetz

LastCoder

A. Sorry, i don't use PVR, and i never will : the skin is based on 0.9.6 git, so you might want to head up to main thread to see if your questions have already been answered.

B. You're talking about the "video" menu in homescreen main menu, right ?

My reFocus mods : reAlaska & reAlaska (Dark)
(This post was last modified: 2012-06-19 11:16 by Sabish.)
find quote
Post Reply