Update library missing new movies - fasthash?

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
nugget21 Offline
Junior Member
Posts: 31
Joined: Mar 2012
Reputation: 0
Post: #1
I'm running Openelec 1.95.5 64bit (XBMC Eden)

All of the sudden my update library is skipping my 'Movies' folder and throws out the following line:

02:25:23 T:139997000754944 DEBUG: VideoInfoScanner: Skipping dir 'smb://192.168.x.xx/Movies/' due to no change (fasthash)

There are definitely new files in there and it should be scanning them in. My 'TV Shows' source still updates if I add new things in there. If I go into the Video section and go to 'scan for new content' on the movies source it does find them but why has it started doing this?

I've found a few results on here about this but none that seem to have a solution.

Any ideas?
(This post was last modified: 2012-07-11 04:16 by nugget21.)
find quote
jmarshall Offline
Team-XBMC Developer
Posts: 26,221
Joined: Oct 2003
Reputation: 178
Post: #2
The only reason it would do this is if when you add new files to that folder it doesn't update the modified time on the folder.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
nugget21 Offline
Junior Member
Posts: 31
Joined: Mar 2012
Reputation: 0
Post: #3
Ok, can you maybe point me in the right direction as to why copying files to that directory has all of the sudden stopped updating the modified time on the folder?
find quote
jmarshall Offline
Team-XBMC Developer
Posts: 26,221
Joined: Oct 2003
Reputation: 178
Post: #4
No idea, try it and see?

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
bleze Offline
Senior Member
Posts: 216
Joined: Nov 2009
Reputation: 0
Post: #5
A similar problem regarding fasthash? In the database, I had paths stored but no movies. No idea how it happened. I could see the folders being skipped but the movies very missing from the library.

I cooked up this query;

delete from path where strHash like 'fast%'
and strPath not in (select c22 from movie)

After running it, I was able to update library and get back the missing movies.
find quote