Linux - cant find option to rip audio cd

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Juanjo Offline
Member
Posts: 91
Joined: Sep 2010
Reputation: 0
Location: Argentina
Post: #1
Hi,

i remember ripping audio cds with xbmc dharma, it was needed to setup an access to the cd as a source and there you could rip cd from the context menu, i read in the wiki about ripping cds from the audio cd item in the menu, but i dont have that option, when i select music, i just see my music source and add addons.. nothing more..
is it possible i disabled it somehow ? or do i have to enable something to see that option ? i can play the cd from the main menu just fine.. but no context menu anywhere

thanks
Juanjo

Philips 32PFL6606D
Intel G1620 + Gigabyte B75N + 4Gb DDR3 + Kingspek SSD 64Gb + 3TB WD Green
Hama MCE remote.
Ubuntu 14.04 minimal install + KODI 14 vaapi-sse4
find quote
Juanjo Offline
Member
Posts: 91
Joined: Sep 2010
Reputation: 0
Location: Argentina
Post: #2
anybody knows ?

Philips 32PFL6606D
Intel G1620 + Gigabyte B75N + 4Gb DDR3 + Kingspek SSD 64Gb + 3TB WD Green
Hama MCE remote.
Ubuntu 14.04 minimal install + KODI 14 vaapi-sse4
find quote
artrafael Offline
Team-XBMC Forum Moderator
Posts: 6,344
Joined: Jul 2010
Reputation: 113
Location: USA
Post: #3
If you are able to play the audio CD from the main menu by clicking on the PLAY DISC option, you should be able to do the following:
  1. Select: System-Settings-Music-Audio CDs
  2. Verify there are selections/entries for Lookup audio CD track names, Saved music folder, Track naming template, Encoder, Quality, Bitrate, Compression level.
  3. Press ESC until you return to the main menu
  4. If you haven't already done so, insert your audio CD into the optical drive and wait for the "PLAY DISC" option to appear on the main menu
  5. Select: Music-Files
  6. Among your various music sources displayed, you should see an entry (probably at the top of the list) for Audio-CD
  7. Open the context menu for the Audio-CD item (right mouse click or "c" on the keyboard) and you should see an entry for "Rip audio CD"
  8. Select "Rip audio CD"
find quote
Juanjo Offline
Member
Posts: 91
Joined: Sep 2010
Reputation: 0
Location: Argentina
Post: #4
hi, thanks for answering.. all options are set, but when i go to music, i just see addons and <my music folder> i dont have an option "files" and i remember seeing that option in the past. is it possible i changed some configuration to directly see the folders and skip "files" option?

Juanjo

Philips 32PFL6606D
Intel G1620 + Gigabyte B75N + 4Gb DDR3 + Kingspek SSD 64Gb + 3TB WD Green
Hama MCE remote.
Ubuntu 14.04 minimal install + KODI 14 vaapi-sse4
find quote
artrafael Offline
Team-XBMC Forum Moderator
Posts: 6,344
Joined: Jul 2010
Reputation: 113
Location: USA
Post: #5
The "Files" option is listed under "MUSIC" on the main menu (assuming you are using the Confluence skin). Use your left/right arrow keys to navigate to and highlight the MUSIC option, then use the down arrow to get to the submenu items and, if necessary, use the left/right arrows to highlight the "Files" option, and hit Enter to select.

If you have an audio CD inserted, it *should* be listed with your other music sources. along with the "Music Add-ons" and "Add source" items.

Let me ask again: when you insert an audio CD, does the "PLAY DISC" option get added to the main menu items?
(This post was last modified: 2012-07-21 20:43 by artrafael.)
find quote
Juanjo Offline
Member
Posts: 91
Joined: Sep 2010
Reputation: 0
Location: Argentina
Post: #6
yes, the play disk option gets added to the main menu, but inside the "music" menu there is just music addons and add source plus my music folder source.

yes, im using confluence skin.

im gonna try running xbmc as another user to see if there is some configuration i cannot remember touching that disabled that option.. i cannot think of anything else.

thanks

Philips 32PFL6606D
Intel G1620 + Gigabyte B75N + 4Gb DDR3 + Kingspek SSD 64Gb + 3TB WD Green
Hama MCE remote.
Ubuntu 14.04 minimal install + KODI 14 vaapi-sse4
find quote
Juanjo Offline
Member
Posts: 91
Joined: Sep 2010
Reputation: 0
Location: Argentina
Post: #7
i just installed my backed up eden which was running on ubuntu 11.10, audio cd unit shows up perfectly there. but with ubuntu 12.04 which i was using audio cd does not show up at all.

i tried running xbmc as another user, same result, so i think its not a personal configuration problem
i tried running xbmc as root, same result, so i think its not a user rights problem.

is it possible something changed in ubuntu 12.04 that disables this option ? what i mean is, maybe something changed and xbmc cannot add that option the way it used to, or the detection method is not triggered ? (although since play music cd option shows up in the main menu, i dont know if this can be)

any other ideas i can try ?
Juanjo

Philips 32PFL6606D
Intel G1620 + Gigabyte B75N + 4Gb DDR3 + Kingspek SSD 64Gb + 3TB WD Green
Hama MCE remote.
Ubuntu 14.04 minimal install + KODI 14 vaapi-sse4
find quote
artrafael Offline
Team-XBMC Forum Moderator
Posts: 6,344
Joined: Jul 2010
Reputation: 113
Location: USA
Post: #8
Try checking the Ubuntu options on how it should handle removeable media. Maybe compare the settings between your Ubuntu 11.10 and 12.04 installations and see what is different?

If you can't come up with a solution soon and if the option to rip/encode a CD from within XBMC is important to you, you may want to consider staying with Ubuntu 11.10 for now since it works.
find quote
capfuturo Offline
Fan
Posts: 560
Joined: Feb 2013
Reputation: 11
Location: London, UK
Post: #9
(2013-07-30 23:32)artrafael Wrote:  Select MUSIC > Files and you should see an entry for Audio-CD. Open its context menu and you can then select Play or Rip.

Good afternoon artrafael,

Your suggestion doesn't work on OS X systems/Ubuntu Linux. The context menu doesn't bring up Play or Rip options. There is just no Audio CD source showing up on XMBC that one can select, that is the issue, which has been playing around in XBMC not for months, but for years... I found a thread from at least 4 years ago, then again one from 2010, with same complaints and nobody really has fixed this for good. Perhaps somebody thought they fixed it but somehow it broke on the way again. Would it be too hard to set it up properly in the next Gotham iteration of XBMC? I mean seriously.

I saw also you were trying to help someone on this thread 1 year ago to no avail. Since XBMC fails to recognise the optical source and display it to the user for manual (not auto) playback/ripping purposes, the CDDA source MUST be added manually. So for all of you out there already gone mad with this issue, calm down, this is the way to go:

select 'add source', then enter the 'path' for the media location which should be cdda://local/cdda and name your new optical media source. After this the new CD/DVD source will be available as a source to manually rip and playback optical medias.

Best,

CF


BTW: after you set up your new optical source and you are finally ripping your "huge" old collection of Audio CDs with XBMC and think all is good, you are wrong let me tell you. You will face the inevitable problem of how to eject/close the tray!!!! It just doesn't happen. Why? Ask XBMC dev team. In the meantime, here you can find some help. Enjoy the rest of the summer (in the northern hemisphere at least). CF.
find quote
artrafael Offline
Team-XBMC Forum Moderator
Posts: 6,344
Joined: Jul 2010
Reputation: 113
Location: USA
Post: #10
(2013-08-02 15:54)capfuturo Wrote:  Good afternoon artrafael,

Your suggestion doesn't work on OS X systems/Ubuntu Linux. The context menu doesn't bring up Play or Rip options.

Thank you for your additional tips/suggestions; however, I wouldn't make a blanket statement that these options are not available under Linux. I use Linux exclusively for XBMC on multiple systems and I have context menu options for Play and Rip.
(This post was last modified: 2013-08-05 06:54 by artrafael.)
find quote
capfuturo Offline
Fan
Posts: 560
Joined: Feb 2013
Reputation: 11
Location: London, UK
Post: #11
Hi artrafael,

Thanks for for your feedback and for dealing with this so diligently. So to stay away from including Linux on the matter, unless other linux users have something to say about it, I have opened a new thread here to expose the repetitive issues I have observed exclusively in OS X working on different machines and OS X versions.

Best,

CF
find quote