HOW-TO Compile Tvheadend & HDHomerun on Synology NAS

  Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Senior Member
Posts: 166
Joined: Jun 2010
Reputation: 3
Location: France
Post: #511

Any news on hdhomerum driver for DSM 5.1 ?
find quote
Senior Member
Posts: 166
Joined: Jun 2010
Reputation: 3
Location: France
Post: #512
Hi everybody, and Happy New Year

hdhomerum driver for DSM 5.1 are apparently tricky to make,
But I've discovered in this post
that new Tvheadend version (3.9.2xxx) support hdhomerum diver natively.

thx jdierkse for your spk ! Smile
find quote
Junior Member
Posts: 27
Joined: Mar 2010
Reputation: 0
Post: #513
Could use some help....

- I have the latest tvheadend-testing compile from (Version 3.9.2525-1). It starts up successfully and I enter the web console.
- I have an HDHomerun Prime unit and all three tuners are recognized as dvb-c types.
- When I create a network I must select dvb-c as the type otherwise it won't let me pair it with one of the tuners which are of type dvb-c.
- The issue is that all the predefined muxes for dvb-c are non-U.S. .... the only predefined muxes for the U.S. are under ATSC tuner types.

I would prefer not to have to manually type all the frequencies in if I don't have to. What am I doing wrong? I have also tried to copy a U.S. predefined Muxes list to the dvb-c directory with all the non-U.S listings but it still doesn't pick it up.

Any help is appreciated!

find quote
Junior Member
Posts: 30
Joined: Mar 2012
Reputation: 0
Post: #514
Is there a version that works with the DS215j..?

It's the Arm 375 chipset..

(I see it's been added now... Thank you..)

Big Grin
(This post was last modified: 2015-06-14 11:41 by MortUK74.)
find quote
Posts: 90
Joined: Dec 2013
Reputation: 0
Post: #515
I have installed on my DS713+ Debian Chroot 8.1-6 and on this i have build and install my Tvheadend. I want install version 4.1.1193 with transcoding by use:


rm -fr /home/hts/tvheadend

git clone

cd tvheadend

./configure --prefix=/usr --enable-bundle --disable-avahi --disable-dvben50221 --enable-libffmpeg_static


sudo /etc/init.d/tvheadend stop

sleep 15

sudo make install

sleep 5

sudo /etc/init.d/tvheadend start

But when i try on finish i have:

make[5]: Opuszczenie katalogu `/home/hts/tvheadend/libav_static/libvorbis-1.3.5/doc'
make[4]: Opuszczenie katalogu `/home/hts/tvheadend/libav_static/libvorbis-1.3.5/doc'
make[3]: Opuszczenie katalogu `/home/hts/tvheadend/libav_static/libvorbis-1.3.5/doc'
make[3]: Wejście do katalogu `/home/hts/tvheadend/libav_static/libvorbis-1.3.5'
make[4]: Wejście do katalogu `/home/hts/tvheadend/libav_static/libvorbis-1.3.5'
make[4]: Nie ma nic do zrobienia w `install-exec-am'.
/bin/mkdir -p '/home/hts/tvheadend/libav_static/build/ffmpeg/share/aclocal'
/usr/bin/install -c -m 644 vorbis.m4 '/home/hts/tvheadend/libav_static/build/ffmpeg/share/aclocal'
/bin/mkdir -p '/home/hts/tvheadend/libav_static/build/ffmpeg/lib/pkgconfig'
/usr/bin/install -c -m 644 vorbis.pc vorbisenc.pc vorbisfile.pc '/home/hts/tvheadend/libav_static/build/ffmpeg/lib/pkgconfig'
make[4]: Opuszczenie katalogu `/home/hts/tvheadend/libav_static/libvorbis-1.3.5'
make[3]: Opuszczenie katalogu `/home/hts/tvheadend/libav_static/libvorbis-1.3.5'
make[2]: Opuszczenie katalogu `/home/hts/tvheadend/libav_static/libvorbis-1.3.5'
2015-12-09 13:21:38 URL: [725028/725028] -> "/home/hts/tvheadend/libav_static/x264-snapshot-20151120-2245.tar.bz2" [1]
SHA1SUM test '6ca54b8e257ef52f55c752e94e77dbc93fe32fe4' == '6ca54b8e257ef52f55c752e94e77dbc93fe32fe4': OK
#rm -rf /home/hts/tvheadend/libav_static/x264-snapshot-*
UNTAR           x264-snapshot-20151120-2245.tar.bz2
#{ ln -sf $(basename /home/hts/tvheadend/libav_static/x264-snapshot-*) /home/hts/tvheadend/libav_static/x264-snapshot-20151120-2245; }
cd /home/hts/tvheadend/libav_static/x264-snapshot-20151120-2245 && TVHEADEND_LIBAV_BUILD=/home/hts/tvheadend/libav_static/build/ffmpeg PKG_CONFIG=/home/hts/tvheadend/support/pkg-config.ffmpeg ./configure \
                --prefix=/ffmpeg \
                --enable-static \
                --disable-shared \
                --disable-avs \
                --disable-swscale \
                --disable-lavf \
                --disable-ffms \
                --disable-gpac \
Unknown option --disable-shared, ignored
No working C compiler found.
make[1]: *** [/home/hts/tvheadend/libav_static/x264-snapshot-20151120-2245/.tvh_build] Błąd 1
make[1]: Opuszczenie katalogu `/home/hts/tvheadend'
make: *** [/home/hts/tvheadend/libav_static/build/ffmpeg/lib/libavcodec.a] Błąd 2
[ ok ] Starting Tvheadend: tvheadend.
[email protected]_DS713:~$ which gcc
[email protected]_DS713:~$ gcc --version
gcc (Debian 4.9.2-10) 4.9.2
Copyright (C) 2014 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO

Please help me....!!! Aisman please help me because you first help me build on my NAS.
find quote
Post Reply