No audio and video stutter DTS-MA

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
butterkitty Offline
Junior Member
Posts: 14
Joined: Apr 2010
Reputation: 0
Post: #1
So, I have a problem wherein I try to play a H.264/DTS-HD Master Audio file on the new Frodo Beta 1 version of XBMC. The video shows but is extremely choppy, and there is no audio at all. My receiver seems to recognize 2.0 channel stereo at this point. If I turn off the option to send DTS-MA to my receiver, it plays perfectly fine as DTS.

My audio receiver is the Pioneer VSX-1021, which does support DTS-HD. I am hooked up to it via HDMI from a built-in Radeon HD 6310. My media center uses the AMD Fusion 350 APU.

Edit. This is what the log says:

log snippet removed
(This post was last modified: 2012-11-16 10:26 by thrak76.)
find quote
ynksbsbll2 Offline
Member
Posts: 85
Joined: Oct 2012
Reputation: 0
Post: #2
Same issues here, choppy video and no audio playback
find quote
steelman1991 Offline
Donor
Posts: 2,439
Joined: Jan 2009
Reputation: 10
Post: #3
Make sure your Audio output settings are set correctly (System\Settings\Audio Output) ensuring all capable formats are checked (DTS MA, TrueHD, DTS, DD etc). Make sure Audio Output and Passthrough device are set to WASAPI (Should also be something there to recognise the output device).

Also disable 'Use a fullscreen window rather than true fullscreen' (System\Settings\Video output)- unless you intend to use XBMC with an external player.

Also check your sound devices to see what windows is reporting as supported formats.

Control Panel\Sound, highlight the playback device, properties\supported formats. If the relevant HD Audio codecs are not listed, it may be that your devices have an EDID issue and are not recognising each device in the chain - see this thread for possible solution http://www.avsforum.com/t/1227161/edid-o...-ati-5xxxs
(This post was last modified: 2012-11-16 10:52 by steelman1991.)
find quote
thrak76 Offline
Moderator
Posts: 1,392
Joined: Mar 2011
Reputation: 26
Location: Lake Michigan Shoreline
Post: #4
Please link a complete debug log using xbmclogs.com, or pastebin.com.

Also, many folks have problems if they're using the Realtek HD audio drivers. If you're using them, you might try using the AMD HDMI audio drivers. No one seems to have problems with playback when using that driver (in conjunction with a proper setup).
find quote
butterkitty Offline
Junior Member
Posts: 14
Joined: Apr 2010
Reputation: 0
Post: #5
As requested my xbmc log is at <removed>

I will try using the ATI drivers since I am in fact using the Realtek HD drivers.
(This post was last modified: 2012-11-16 19:46 by butterkitty.)
find quote
butterkitty Offline
Junior Member
Posts: 14
Joined: Apr 2010
Reputation: 0
Post: #6
Did a full uninstall of the Realtek HDMI drivers and installed the AMD ones. Didn't seem to make a difference. I also disabled all other audio devices in the control panel.

DTS-HD is listed under supported formats for my current sound device.
find quote
steelman1991 Offline
Donor
Posts: 2,439
Joined: Jan 2009
Reputation: 10
Post: #7
Did you check your audio settings. The solution may be to visit the EDID thread I linked to.

@butterkitty - that's not a debug log - you will have to turn on 'debugging' from System\Settings\System\Debugging
(This post was last modified: 2012-11-16 18:58 by steelman1991.)
find quote
butterkitty Offline
Junior Member
Posts: 14
Joined: Apr 2010
Reputation: 0
Post: #8
Ahh yes, sorry. I thought I had it on already for some reason heh. I've updated the pastebin with the new log. To make things easier, I am trying to play the movie "Sunshine"
http://pastebin.com/VN2MRhFc

I'll take a look at that post, but I'm not sure it will help me since I checked the supported formats for my card in Windows and it did say that it supports DTS-HD.
find quote
jjd-uk Offline
Team-Kodi Member
Posts: 3,371
Joined: Oct 2011
Reputation: 65
Post: #9
It looks to me that you're using the Directsound AMD device in the XBMC audio settings however for HD audio bitstreaming you need to use the WASAPI AMD setting.

Also in windows Sound - Properties - Advanced check the 2 check boxes in the Exclusive Mode section are ticked.

For more detail check my Post #3 at http://forum.xbmc.org/showthread.php?tid=141569
(This post was last modified: 2012-11-16 21:28 by jjd-uk.)
find quote
steelman1991 Offline
Donor
Posts: 2,439
Joined: Jan 2009
Reputation: 10
Post: #10
Good post jjd, but I had already advised the OP to amend his audio settings (see post #3), which I assumed, having asked for advice, he had - obviously not.
find quote
jjd-uk Offline
Team-Kodi Member
Posts: 3,371
Joined: Oct 2011
Reputation: 65
Post: #11
Yeah I saw that, I'm no expert in log reading but it looks to me that Directshow is being initialised when playback starts, the WASAPI device in log seems to me to be reporting the correct capabilities so I don't think it's an EDID issue, but I'll freely admit I'm a amateur in log reading.
find quote
steelman1991 Offline
Donor
Posts: 2,439
Joined: Jan 2009
Reputation: 10
Post: #12
+1
find quote
ynksbsbll2 Offline
Member
Posts: 85
Joined: Oct 2012
Reputation: 0
Post: #13
Changing up my audio settings did the trick, playback is smooth as butter now. Thanks for the help!
(This post was last modified: 2012-11-17 01:15 by ynksbsbll2.)
find quote
butterkitty Offline
Junior Member
Posts: 14
Joined: Apr 2010
Reputation: 0
Post: #14
Got it working...sorry I missed that part of your post steelman1991. It's been a long week. Eg. Today I spent the day taking my car's rear end completely apart heh
find quote
steelman1991 Offline
Donor
Posts: 2,439
Joined: Jan 2009
Reputation: 10
Post: #15
Yeah those 'car rear ends' really get in the way lol. Glad you got your xbmc problem solved.
(This post was last modified: 2012-11-17 10:33 by steelman1991.)
find quote
Post Reply