[RELEASE] Movie Set Artwork Automator

  Thread Rating:
  • 5 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
wgstarks Offline
Posting Freak
Posts: 1,546
Joined: Jun 2013
Reputation: 11
Location: North Carolina, USA
Post: #391
(2015-01-03 01:16)maxdido Wrote:  Raspberry Pi B+
raspbmc with kodi 14
Movie Set Artwork Automator version 0.2.2

I used your plugin and I had some trouble in the beginning. I couldn't get the thumbnails as icons on the moviewall to show. I named all thumbnails to MovieSetName-folder.jpg (all artwork in 1 single folder). Then I noticed in the settings you can change the filenames of:

- thumbnail --> folder.jpg
- poster --> poster.jpg
- fanart --> fanart.jpg
- etc... etc

I changed poster.jpg to folder.jpg and after a restart of my raspberry pi the thumbnails of the movieset where changed. So great app you wrote. Still I have a question, what is the difference between thumbnail and poster? Where is what used?
Size is probably the only difference. I think it's usually the same image. As far as where they're used, that would depend on the skin you're using. Commonly, list views will have thumbnails and poster views, info windows, etc. will use posters.

[Image: all-thin-banner.jpg]
MacMini5,2 HTPC (Helix 14.0/Aeon Nox 5.5/MacOSX 10.8.5)/Onkyo TXNR609/Panny65VT30
(This post was last modified: 2015-01-03 01:52 by wgstarks.)
find quote
maxdido Offline
Junior Member
Posts: 10
Joined: Jan 2015
Reputation: 0
Post: #392
I also noticed when the program scans all sets I see a double backslash in front of SetName-poster.jpg and SetName-fanart.jpg. When I look into the database I also see //Batman-poster.jpg. I'm not saying this is wrong because the program works great but I just found it strange since all other artwork just have 1 slash as you can see in the picture below.

[Image: backslash-double.png]
find quote
Levi59 Offline
Senior Member
Posts: 128
Joined: Jun 2012
Reputation: 0
Post: #393
Does this version of MSAA will add extrafanart1.jpg to database or will it be implemented?
[Image: 8du2EWt.jpg]

On Helix, it don't add extrafanart1.jpg, i need to do that manually...
(This post was last modified: 2015-01-27 12:12 by Levi59.)
find quote
Levi59 Offline
Senior Member
Posts: 128
Joined: Jun 2012
Reputation: 0
Post: #394
up?
find quote
XELOR Offline
Member
Posts: 53
Joined: Jul 2009
Reputation: 0
Post: #395
Im running this on Frodo and getting this error?

[Image: Image1_zpsc720dfe8.jpg]
find quote
cwebster Offline
Junior Member
Posts: 1
Joined: Feb 2015
Reputation: 0
Post: #396
This is the easiest add-on I've ever used... I love it. I don't want a program to tell me what art I can have; I want one to use the art I give it. This is perfect!

Would you consider making a "Movie Artwork Automator" for the "normal" movie (poster, fanart, disc, etc.) artwork? Artwork Downloader drives me nuts because it won't scape my own folders.

I can't thank you enough for this little jewel.

I'm running Kodi 14.1, Aeon MQ5 6.1.6, on Windows 7 & 8.
find quote
CaptainKen Offline
Fan
Posts: 748
Joined: Mar 2011
Reputation: 6
Location: Arizona
Post: #397
(2015-03-01 10:26)cwebster Wrote:  This is the easiest add-on I've ever used... I love it. I don't want a program to tell me what art I can have; I want one to use the art I give it. This is perfect!

Would you consider making a "Movie Artwork Automator" for the "normal" movie (poster, fanart, disc, etc.) artwork? Artwork Downloader drives me nuts because it won't scape my own folders.

I can't thank you enough for this little jewel.

I'm running Kodi 14.1, Aeon MQ5 6.1.6, on Windows 7 & 8.

If I'm understanding you correctly, perhaps you're looking for this?

Current stable version: http://forum.kodi.tv/showthread.php?tid=165012

New version in the works: http://forum.kodi.tv/showthread.php?tid=191781

www.CaptainKen.us
www.YouTube.com/KenInGilbert
My Media Center Pics & Specs
Synology DS1813+ RAID 6 NAS, 22TB useable space

find quote
hanlon Offline
Junior Member
Posts: 9
Joined: Feb 2015
Reputation: 0
Post: #398
I have kodi 15/alpha installed on linux/64 on two machines -- 'master' and 'playback' kodi instances.

The two instances share a single mysql database, as specified in each advancedsettings.xml. Both instances share an NFS-mounted library store. Database info is exported as XML (.nfo), as separate files for each movie.

Database updates, content updates, etc. made in the master all propagate correctly.

I've installed MSA in the 'master' instance.

I've set up a single collection artwork folder for MSA. The folder exists on the NFS store. I've updated my collection artwork PNGs.

After exec of MSA all my collections on the 'master' instance correctly show the collection artwork I've specified.

On the 'playback' instance, I update the Library. All changes are picked up, as usual ...

EXCEPT, all of the collections -- as viewed in Thumbnail view -- display NO ART whatsoever. Title's there, single movies' art is there, but the collections' artwork is just missing.

What do I need to do to get the collection artwork in the 'playback' instance to disaply as it does in the 'master' instance?
find quote
Milhouse Online
Team-Kodi Member
Posts: 5,241
Joined: Jan 2011
Reputation: 119
Post: #399
Why are you updating the library on the Playback device when you're sharing a MySQL database? You shouldn't need to apply any library updates on the Playback device once the library updates have been processed by Master. This makes it sound like you're not really sharing a single library at all...

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(This post was last modified: 2015-03-02 19:03 by Milhouse.)
find quote
hanlon Offline
Junior Member
Posts: 9
Joined: Feb 2015
Reputation: 0
Post: #400
I updated it because NOT updating it didn't have any effect on the collections art.

For reference, on the 'playback' instance (it's an RPi)

Code:
cd /home/pi/.kodi/userdata/Database
ls -al
    total 2204
    drwxr-xr-x 3 pi pi    4096 Mar  2 06:54 .
    drwxr-xr-x 9 pi pi    4096 Feb 27 11:40 ..
    -rw-r--r-- 1 pi pi  602112 Mar  2 06:11 Addons16.db
    drwxr-xr-x 2 pi pi    4096 Feb 23 05:29 CDDB
    -rw-r--r-- 1 pi pi   28672 Feb 23 05:29 Epg9.db
    -rw-r--r-- 1 pi pi 1552384 Mar  2 06:15 Textures13.db
    -rw-r--r-- 1 pi pi   36864 Feb 23 05:29 TV27.db
    -rw-r--r-- 1 pi pi   20480 Feb 27 06:57 ViewModes6.db

cat advancedsettings.xml
-----------------------------
<advancedsettings>
<loglevel hide="false">2</loglevel>

<videodatabase>
  <type>mysql</type>
  <host>192.168.1.14</host>
  <port>3306</port>
  <user>kodi</user>
  <pass>PASSWORD</pass>
  <name>kodi_video</name>
</videodatabase>

<musicdatabase>
  <type>mysql</type>
  <host>192.168.1.14</host>
  <port>3306</port>
  <user>kodi</user>
  <pass>PASSWORD</pass>
  <name>kodi_music</name>
</musicdatabase>

<videolibrary>
  <importwatchedstate>true</importwatchedstate>
  <importresumepoint>true</importresumepoint>
  <updateonstartup>false</updateonstartup>
  <backgroundupdate>false</backgroundupdate>
  <cleanonupdate>false</cleanonupdate>
</videolibrary>

<videoscanner>
  <ignoreerrors>true</ignoreerrors>
</videoscanner>

<musiclibrary>
  <updateonstartup>false</updateonstartup>
</musiclibrary>
</advancedsettings>
-----------------------------


cat sources.xml
-----------------------------
<sources>
    <programs>
        <default pathversion="1"></default>
    </programs>
    <video>
        <default pathversion="1"></default>
        <source>
            <name>Movies</name>
            <path pathversion="1">/mnt/NFS/Video/Movies/</path>
            <allowsharing>true</allowsharing>
        </source>
        <source>
            <name>TV</name>
            <path pathversion="1">/mnt/NFS/Video/TV/</path>
            <allowsharing>true</allowsharing>
        </source>
    </video>
    <music>
        <default pathversion="1"></default>
    </music>
    <pictures>
        <default pathversion="1"></default>
    </pictures>
    <files>
        <default pathversion="1"></default>
    </files>
</sources>
-----------------------------
(This post was last modified: 2015-03-02 19:37 by hanlon.)
find quote
Post Reply