VNSI versions and compatibility

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
fritsch Offline
Team-XBMC Developer
Posts: 6,617
Joined: Aug 2011
Reputation: 150
Location: Karlsruhe
Post: #16
@uuzi: We had that already I think. Your radeon does mpeg-2 on shaders, that are not thread safe. Upgrade to tomorrows version of the fernetmenta-ppa. Go to expert settings under Video Playback and disable MPEG-2 codec in the VDPAU section.
find quote
Piticli Offline
Junior Member
Posts: 2
Joined: Jun 2014
Reputation: 0
Post: #17
Since Gotham update of Raspbmc, I have problems with my VDR connection. I have installed a server with yaVDR, and it uses vnsiserver3. Since Gotham, my raspbmc is trying to connect using protocol 5, so it can't connect. I have tried to install vnsiserver5 in yaVDR, but I couldn't do it without have all the packages and dependences broken (I almost had to reinstall all yaVDR to correct it all) because vnsiserver is in testing apt source. So... is it posible to use protocol 3 from client side? (vnsi client from raspbmc with Gotham).
Thanks
(This post was last modified: 2014-06-02 23:53 by Piticli.)
find quote
FernetMenta Online
Team-Kodi Developer
Posts: 3,476
Joined: Jul 2010
Reputation: 67
Location: Munich
Post: #18
Gotham requires vnsiserver 1.0 or later. Future versions will be less rigid regarding protocol version.
find quote
Piticli Offline
Junior Member
Posts: 2
Joined: Jun 2014
Reputation: 0
Post: #19
"vnsiserver 1.0" is equal to "vnsiserver5" ?
find quote
FernetMenta Online
Team-Kodi Developer
Posts: 3,476
Joined: Jul 2010
Reputation: 67
Location: Munich
Post: #20
No, they are not equal. vnsiserver5 is version 0.9.x. But both versions use protocol 5 and work with Gotham.
find quote
charlie0440 Offline
Fan
Posts: 389
Joined: Dec 2011
Reputation: 5
Post: #21
I'm confused. Recentenly my VNSI wouldn't connect to my server. Log states its looking for protocol 6:

Code:
Jun  5 21:37:35 Server vdr: [5446] VNSI: Welcome client 'XBMC Media Center' with protocol version '6'
Jun  5 21:37:35 Server vdr: [5446] VNSI-Error: Client 'XBMC Media Center' have a not allowed protocol version '6', terminating client
Jun  5 21:37:35 Server vdr: [5446] VNSI-Error: Clients must be logged in before sending commands! Aborting.

Don't think I changed anything.

So I recompiled from your master and its still the same. XBMC 13.1 Beta 2

Guide to building an all in one Ubuntu Server - TV(vdr),File,Music,Web

Server Fractal Designs Define XL, Asus P5QL/EPU, Dual Core E5200, 4gb, L4M-Twin S2 v6.2, Supermicro AOC-USAS-L8I, 1*SSD & 13*HDD drives (24TB total) - Ubuntu Server
XBMC 1 ASRock Z77E-ITX, G850, 8GB RAM, SSD, BD - Ubuntu / OpenElec frodo
XBMC 2 Revo 3700 - OpenElec frodo
XBMC 3 Raspb Pi
find quote
FernetMenta Online
Team-Kodi Developer
Posts: 3,476
Joined: Jul 2010
Reputation: 67
Location: Munich
Post: #22
Don't mix up things. You compiled vnsi addon from my master, used with Gotham, against on older version of vnsiserver.

- we are working on 14.x and there is no guarantee that m master is compatible with G releases (currently it is but this may change)
- upgrading the client (addon) may require an upgrade of server. -> my master branch of vnsi addon requires vnsiserver 1.1.0. It was supposed to be compatible with 1.0 but due to some bug it compares against a wrong version.
(This post was last modified: 2014-06-05 23:17 by FernetMenta.)
find quote
big_blue Offline
Junior Member
Posts: 10
Joined: Jan 2010
Reputation: 0
Post: #23
Hi. I am completly new into this Business. I try To get an pi Running with openelec 4.0.4 connecting To my yavdr 0.5 with stabile sources. I have read in some threads about version of vnsi and protocol but not sure what to do.

With the stable source of yavdr the version of vnsi is to old. In my mind the only version of get vnsi running is to get an alternative source or compile the correct version.

Is here someone who currently running this setup? What would you prefer? What is the correct version / git branch for openelec 4.0.4 Protocol Version 5?

Thanks
find quote
FernetMenta Online
Team-Kodi Developer
Posts: 3,476
Joined: Jul 2010
Reputation: 67
Location: Munich
Post: #24
The correct version is here: https://github.com/FernetMenta/vdr-plugin-vnsiserver
find quote
martin.haager Offline
Junior Member
Posts: 22
Joined: Jan 2013
Reputation: 0
Location: Vienna
Post: #25
Hello!

I upgraded to xbmc 13.2 final on mac --> everythings working there using protocol version 5

I upgraded my Openlec Installation on raspberry to 4.1.5 (xbmc 13.2)
Using LiveTV my vdr server log complains about wrong protocol version 6
Openelec 4.0.7 (xbmc 13.1) uses vdr-vnsi protocol 5 --> switched back to 4.0.7 everythings OK

Is there already a protocol version 6 ??
If yes, is your vnsi server via https://github.com/FernetMenta/vdr-plugin-vnsiserver supporting protocol 5 and 6 ??

right now I'm using vnsi server from yavdr testing ppa
vdr-plugin-vnsiserver5 1:0.9.4+git20140304-0yavdr0~trusty amd64 VDR-Network-Streaming-Interface

thx for any info
martin

yavdr 2.0.6 testing / TBS 6991 dvbs-2 - Twin Tuner plus CI / vdr-plugin-vnsiserver 1.0.9 - yavdr-testing / Ubuntu 14.04 LTS
RasPi / openelec 4.0.7 XBMC 13.1 09.07.2014 with shipped vdr addon 1.9.8, Skin Amber 1.6.0
MacBook Pro OSX 10.9 / XBMC 13.2 18.08.2014 with shipped vdr addon 1.9.8, Skin Amber 1.6.0
MySQL MediaDB
find quote
FernetMenta Online
Team-Kodi Developer
Posts: 3,476
Joined: Jul 2010
Reputation: 67
Location: Munich
Post: #26
With version 1.1.0 of vnsiserver backwards compatibility is back. This allows that clients with a minimum protocol version of 5 can connect to the server. AFAIK version 1.1.0 is in yaVDR unstable.
find quote
martin.haager Offline
Junior Member
Posts: 22
Joined: Jan 2013
Reputation: 0
Location: Vienna
Post: #27
Yep,

PPA yaVDR unstable holds 1.1.0
vdr-plugin-vnsiserver 1.1.0~git20140723-3f11c8e-0yavdr0~trusty seahawk1986 (2014-08-08)

Does it make sense to use this one
or shall I compile from your sources since you are on Version 1.1.0 since May 17th

Thanks for info
Will give it a try tonight

Martin

yavdr 2.0.6 testing / TBS 6991 dvbs-2 - Twin Tuner plus CI / vdr-plugin-vnsiserver 1.0.9 - yavdr-testing / Ubuntu 14.04 LTS
RasPi / openelec 4.0.7 XBMC 13.1 09.07.2014 with shipped vdr addon 1.9.8, Skin Amber 1.6.0
MacBook Pro OSX 10.9 / XBMC 13.2 18.08.2014 with shipped vdr addon 1.9.8, Skin Amber 1.6.0
MySQL MediaDB
find quote
FernetMenta Online
Team-Kodi Developer
Posts: 3,476
Joined: Jul 2010
Reputation: 67
Location: Munich
Post: #28
according to git sha vdr-plugin-vnsiserver 1.1.0~git20140723-3f11c8e-0yavdr0~trusty is identical to current master branch.
find quote
Post Reply