Linux - afrer upgrade from git - can't install pvr.hts

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
0nicram0 Offline
Junior Member
Posts: 20
Joined: Mar 2013
Reputation: 0
Post: #1
Hi,
I've upgraded my xbmc from git to version: XBMC 13.0-ALPHA2 Git:20130310-8f219c5
Istallation went smoothly, but my addon pvr.hts wont start. I've compiled it and i try to install it again but doesn't start. in xbmc.log writes:
Code:
15:17:51 T:140090093918080   DEBUG: LIRC: Update - NEW at 541120:000000037fcb7ba3 00 KEY_OK zboxremote (KEY_OK)
15:17:51 T:140090093918080   DEBUG: OnKey: 11 (0x0b) pressed, action is Select
15:17:51 T:140090093918080   DEBUG: ------ Window Deinit (FileBrowser.xml) ------
15:17:51 T:140090093918080   DEBUG: GetZipList - Processing zip://%2fusr%2fsrc%2fxbmc-pvr-addons%2faddons%2fpvr.hts-linux-x86_64.zip/
15:17:51 T:140089586771712   DEBUG: GetZipList - Processing zip://special%3a%2f%2fhome%2faddons%2fpackages%2fpvr.hts-linux-x86_64.zip/
15:17:51 T:140089595164416   DEBUG: EPG - Process - pvr manager failed to load - exiting
15:17:51 T:140089595164416   DEBUG: Thread EPG updater 140089595164416 terminating
15:17:51 T:140089586771712  NOTICE: PVRManager - stopping
15:17:51 T:140089436239616   DEBUG: Thread PVR manager 140089436239616 terminating
15:17:51 T:140089427846912   DEBUG: Thread PVR add-on updater 140089427846912 terminating
15:17:51 T:140089586771712   DEBUG: FileManager, processing folder: zip://special%3a%2f%2fhome%2faddons%2fpackages%2fpvr.hts-linux-x86_64.zip/pvr.hts/
15:17:51 T:140089586771712   DEBUG: GetZipList - Processing zip://special%3a%2f%2fhome%2faddons%2fpackages%2fpvr.hts-linux-x86_64.zip/pvr.hts/
15:17:51 T:140089586771712   DEBUG: statdata: 1360619468 new: 1360619468
15:17:51 T:140089586771712   DEBUG:   -- zip://special%3a%2f%2fhome%2faddons%2fpackages%2fpvr.hts-linux-x86_64.zip/pvr.hts/XBMC_Tvheadend.pvr
15:17:51 T:140089586771712   DEBUG:   -- zip://special%3a%2f%2fhome%2faddons%2fpackages%2fpvr.hts-linux-x86_64.zip/pvr.hts/icon.png
15:17:51 T:140089586771712   DEBUG:   -- zip://special%3a%2f%2fhome%2faddons%2fpackages%2fpvr.hts-linux-x86_64.zip/pvr.hts/changelog.txt
15:17:51 T:140089586771712   DEBUG:   -- zip://special%3a%2f%2fhome%2faddons%2fpackages%2fpvr.hts-linux-x86_64.zip/pvr.hts/addon.xml
15:17:51 T:140089586771712   DEBUG:   -- zip://special%3a%2f%2fhome%2faddons%2fpackages%2fpvr.hts-linux-x86_64.zip/pvr.hts/resources/
15:17:51 T:140089586771712   DEBUG: FileManager, processing folder: zip://special%3a%2f%2fhome%2faddons%2fpackages%2fpvr.hts-linux-x86_64.zip/pvr.hts/resources/
15:17:51 T:140089586771712   DEBUG: GetZipList - Processing zip://special%3a%2f%2fhome%2faddons%2fpackages%2fpvr.hts-linux-x86_64.zip/pvr.hts/resources/
...
15:17:52 T:140089586771712 WARNING: CreateFile, error 20 opening file </home/xbmc/.xbmc/addons/addons.xml.md5/addon.xml>, flags:800, mode:124.
15:17:52 T:140089586771712 WARNING: CreateFile, error 20 opening file </home/xbmc/.xbmc/addons/addons.xml/addon.xml>, flags:800, mode:124.
15:17:52 T:140089586771712    INFO: ADDON: cpluff: 'Could not read plug-in directory /usr/lib/xbmc/addons: No such file or directory'
15:17:52 T:140089586771712   DEBUG: FileManager, processing folder: special://home/addons/pvr.hts/
15:17:52 T:140089586771712   DEBUG:   -- special://home/addons/pvr.hts/resources/
15:17:52 T:140089586771712   DEBUG:   -- special://home/addons/pvr.hts/icon.png
15:17:52 T:140089586771712   DEBUG:   -- special://home/addons/pvr.hts/changelog.txt
15:17:52 T:140089586771712   DEBUG:   -- special://home/addons/pvr.hts/addon.xml
15:17:52 T:140089586771712   DEBUG:   -- special://home/addons/pvr.hts/XBMC_Tvheadend.pvr
15:17:52 T:140089586771712   DEBUG: FileManager, processing folder: special://home/addons/pvr.hts/resources/
15:17:52 T:140089586771712   DEBUG:   -- special://home/addons/pvr.hts/resources/skins/
15:17:52 T:140089586771712   DEBUG:   -- special://home/addons/pvr.hts/resources/settings.xml
15:17:52 T:140089586771712   DEBUG:   -- special://home/addons/pvr.hts/resources/language/
15:17:52 T:140089586771712   DEBUG: FileManager, processing folder: special://home/addons/pvr.hts/resources/skins/
15:17:52 T:140089586771712   DEBUG:   -- special://home/addons/pvr.hts/resources/skins/Confluence/
15:17:52 T:140089586771712   DEBUG: FileManager, processing folder: special://home/addons/pvr.hts/resources/skins/Confluence/
15:17:52 T:140089586771712   DEBUG:   -- special://home/addons/pvr.hts/resources/skins/Confluence/720p/
15:17:52 T:140089586771712   DEBUG: FileManager, processing folder: special://home/addons/pvr.hts/resources/skins/Confluence/720p/
15:17:52 T:140089586771712   DEBUG:   -- special://home/addons/pvr.hts/resources/skins/Confluence/720p/DialogTranscode.xml
...
15:17:52 T:140089427846912  NOTICE: Thread Background Loader start, auto delete: false
15:17:52 T:140089427846912   DEBUG: Thread Background Loader 140089427846912 terminating
15:17:54 T:140090093918080   DEBUG: SECTION:UnloadDelayed(DLL: special://xbmcbin/system/ImageLib-x86_64-linux.so)
15:17:54 T:140090093918080   DEBUG: Unloading: ImageLib-x86_64-linux.so
and when i try to start it:
Code:
15:21:52 T:140090093918080   DEBUG: LIRC: Update - NEW at 782321:000000037fcb7ba3 00 KEY_OK zboxremote (KEY_OK)
15:21:52 T:140090093918080   DEBUG: OnKey: 11 (0x0b) pressed, action is Select
15:21:52 T:140089595164416  NOTICE: Thread EPG updater start, auto delete: false
15:21:52 T:140089603557120  NOTICE: Start - EPG thread started
15:21:52 T:140089603557120  NOTICE: PVRManager - starting up
15:21:52 T:140089436239616  NOTICE: Thread PVR manager start, auto delete: false
15:21:52 T:140089427846912  NOTICE: Thread PVR add-on updater start, auto delete: false
15:21:52 T:140090093918080   DEBUG: ------ Window Init (DialogOK.xml) ------
15:21:52 T:140090093918080   DEBUG: Window DialogOK.xml was already loaded
15:21:52 T:140090093918080   DEBUG: Alloc resources: 0.95m
15:22:03 T:140089840764672   DEBUG: Suspended the Sink
15:22:04 T:140090093918080   DEBUG: LIRC: Update - NEW at 794109:000000037fcb7ba3 00 KEY_OK zboxremote (KEY_OK)
15:22:04 T:140090093918080   DEBUG: OnKey: 11 (0x0b) pressed, action is Select
15:22:04 T:140089840764672    INFO: CAESinkALSA::Initialize - Attempting to open device "hdmi:CARD=Generic,DEV=0,AES0=0x04,AES1=0x82,AES2=0x00,AES3=0x00,AES0=0x04,AES1=0​x82,AES2=0x00,AES3=0x00,AES0=0x04,AES1=0x82,AES2=0x00,AES3=0x00,AES0=0x04,AES1=0​x82,AES2=0x00,AES3=0x00,AES0=0x04,AES1=0x82,AES2=0x00,AES3=0x00,AES0=0x04,AES1=0​x82,AES2=0x00,AES3=0x00,AES0=0x04,AES1=0x82,AES2=0x00,AES3=0x00,AES0=0x04,AES1=0​x82,AES2=0x00,AES3=0x00,AES0=0x04,AES1=0x82,AES2=0x00,AES3=0x00"
15:22:04 T:140089840764672    INFO: CAESinkALSA::Initialize - Opened device "hdmi:CARD=Generic,DEV=0,AES0=0x04,AES1=0x82,AES2=0x00,AES3=0x00,AES0=0x04,AES1=0​x82,AES2=0x00,AES3=0x00,AES0=0x04,AES1=0x82,AES2=0x00,AES3=0x00,AES0=0x04,AES1=0​x82,AES2=0x00,AES3=0x00,AES0=0x04,AES1=0x82,AES2=0x00,AES3=0x00,AES0=0x04,AES1=0​x82,AES2=0x00,AES3=0x00,AES0=0x04,AES1=0x82,AES2=0x00,AES3=0x00,AES0=0x04,AES1=0​x82,AES2=0x00,AES3=0x00,AES0=0x04,AES1=0x82,AES2=0x00,AES3=0x00,AES0=0x04,AES1=0​x82,AES2=0x00,AES3=0x00"
15:22:04 T:140089840764672   DEBUG: CAESinkALSA::InitializeHW - Request: periodSize 4410, bufferSize 16384
15:22:04 T:140089840764672   DEBUG: CAESinkALSA::InitializeHW - Got: periodSize 8192, bufferSize 16384
15:22:04 T:140089840764672   DEBUG: CAESinkALSA::InitializeHW - Setting timeout to 372 ms
15:22:04 T:140089840764672   DEBUG: Resumed the Sink
15:22:04 T:140090093918080   DEBUG: ------ Window Deinit (DialogOK.xml) ------
15:22:04 T:140090093918080   DEBUG: Activating window ID: 10040
15:22:04 T:140090093918080   DEBUG: ------ Window Deinit (SettingsCategory.xml) ------
15:22:04 T:140090093918080   DEBUG: ------ Window Init (AddonBrowser.xml) ------
15:22:04 T:140090093918080   DEBUG: SECTION:LoadDLL(special://xbmcbin/system/ImageLib-x86_64-linux.so)
15:22:04 T:140090093918080   DEBUG: Loading: /usr/lib/xbmc/system/ImageLib-x86_64-linux.so
15:22:04 T:140090093918080   DEBUG: Window AddonBrowser.xml was already loaded
15:22:04 T:140090093918080   DEBUG: Alloc resources: 41.93m
15:22:04 T:140090093918080   DEBUG: CGUIMediaWindow::GetDirectory (addons://disabled/xbmc.pvrclient)
15:22:04 T:140090093918080   DEBUG:   ParentPath = [addons://disabled/xbmc.pvrclient/]
15:22:05 T:140089448941312  NOTICE: Thread Background Loader start, auto delete: false
15:22:05 T:140089448941312   DEBUG: Thread Background Loader 140089448941312 terminating
15:22:07 T:140090093918080   DEBUG: LIRC: Update - NEW at 797425:000000037fcb7ba6 00 KEY_DOWN zboxremote (KEY_DOWN)
15:22:07 T:140090093918080   DEBUG: OnKey: 167 (0xa7) pressed, action is Down
15:22:09 T:140090093918080   DEBUG: LIRC: Update - NEW at 799392:000000037fcb7ba3 00 KEY_OK zboxremote (KEY_OK)
15:22:09 T:140090093918080   DEBUG: OnKey: 11 (0x0b) pressed, action is Select
15:22:09 T:140090093918080   DEBUG: ------ Window Init (DialogAddonInfo.xml) ------
15:22:09 T:140090093918080   DEBUG: Window DialogAddonInfo.xml was already loaded
15:22:09 T:140090093918080   DEBUG: Alloc resources: 0.47m
15:22:11 T:140090093918080   DEBUG: LIRC: Update - NEW at 800968:000000037fcb7ba3 00 KEY_OK zboxremote (KEY_OK)
15:22:11 T:140090093918080   DEBUG: OnKey: 11 (0x0b) pressed, action is Select
15:22:11 T:140089595164416   DEBUG: EPG - Process - pvr manager failed to load - exiting
15:22:11 T:140089595164416   DEBUG: Thread EPG updater 140089595164416 terminating
15:22:11 T:140089468376832  NOTICE: PVRManager - stopping
15:22:11 T:140089436239616   DEBUG: Thread PVR manager 140089436239616 terminating
15:22:11 T:140089427846912   DEBUG: Thread PVR add-on updater 140089427846912 terminating
15:22:11 T:140089427846912  NOTICE: Thread EPG updater start, auto delete: false
15:22:11 T:140089468376832  NOTICE: Start - EPG thread started
15:22:11 T:140089468376832  NOTICE: PVRManager - starting up
15:22:11 T:140089436239616  NOTICE: Thread PVR manager start, auto delete: false
15:22:11 T:140089595164416  NOTICE: Thread PVR add-on updater start, auto delete: false
15:22:11 T:140089595164416   DEBUG: RegisterClient - registering add-on 'Tvheadend HTSP Client'
15:22:11 T:140089595164416   DEBUG: PVR - Create - creating PVR add-on instance 'Tvheadend HTSP Client'
15:22:11 T:140089595164416   DEBUG: ADDON: Dll Initializing - Tvheadend HTSP Client
15:22:11 T:140089595164416   ERROR: ADDON: Could not locate XBMC_Tvheadend.pvr
15:22:11 T:140089595164416 WARNING: UpdateAndInitialiseClients - failed to create add-on Tvheadend HTSP Client, status = 6
15:22:11 T:140089595164416 WARNING: UpdateAndInitialiseClients - failed to load the dll for add-on Tvheadend HTSP Client, disabling it
15:22:11 T:140090093918080   DEBUG: CGUIMediaWindow::GetDirectory (addons://disabled/xbmc.pvrclient)
15:22:11 T:140090093918080   DEBUG:   ParentPath = [addons://disabled/xbmc.pvrclient]
15:22:11 T:140089448941312  NOTICE: Thread Background Loader start, auto delete: false
15:22:11 T:140089448941312   DEBUG: Thread Background Loader 140089448941312 terminating
15:22:11 T:140090093918080   DEBUG: ------ Window Init (DialogOK.xml) ------
15:22:11 T:140090093918080   DEBUG: Window DialogOK.xml was already loaded
15:22:11 T:140090093918080   DEBUG: Alloc resources: 0.21m
15:22:13 T:140090093918080   DEBUG: LIRC: Update - NEW at 802828:000000037fcb7ba3 00 KEY_OK zboxremote (KEY_OK)
15:22:13 T:140090093918080   DEBUG: OnKey: 11 (0x0b) pressed, action is Select
15:22:13 T:140090093918080   DEBUG: ------ Window Deinit (DialogOK.xml) ------
15:22:23 T:140089840764672   DEBUG: Suspended the Sink

I can't make any settings to this addon, because i can't chose "settings" :/ when i restart xbmc, there i no my pvr.hts.
could anybodody help me?
thanks for your help in advance.
find quote
opdenkamp Offline
Team-XBMC PVR Developer
Posts: 2,228
Joined: Feb 2009
Reputation: 29
Location: Heerlen, The Netherlands
Post: #2
if you're using xbmc master, then you also need to use the pvr.hts from the master branch in my repos. the PVR API changed and is not compatible with the one from Frodo.

opdenkamp / dushmaniac

xbmc-pvr [Eden-PVR builds] [now included in mainline XBMC, so no more source link here :)]
personal website: [link]

Found a problem with PVR? Report it on Trac, under "PVR - core components". Please attach the full debug log.

If you like my work, please consider donating to me and/or Team XBMC.
find quote
0nicram0 Offline
Junior Member
Posts: 20
Joined: Mar 2013
Reputation: 0
Post: #3
That's right. I recompiled it from your master github and all works fine, even rew/ff Smile
Thanks a lot.
find quote
LastCoder Offline
Fan
Posts: 434
Joined: Dec 2011
Reputation: 0
Post: #4
(2013-03-10 21:23)0nicram0 Wrote:  That's right. I recompiled it from your master github and all works fine, even rew/ff Smile
Thanks a lot.

Sry for hijacking your thread .. but you write "even rew/ff" .. I'm using Frodo now and discovered, that fast forwarding and rewinding videos with more than 2x doesn't really work, picture "preview" stops, the counter doesn't go forward like it should and even if you press play video doesn't go on .. is that what you meant ?

Greetz

LastCoder

Ubuntu 12.04 LTS Server, Xfce, XBMC Gotham, Skin reFred, tvheadend tv backend
ASUS P8H61-M LE/USB3, Celeron G530, Geforce 210, 4 GB DDR3 RAM
16 GB CnMemory 300x CF, 1 TB Samsung 2,5" HDD
iHOS104 BluRay Drive, TT DVBS2-1600
Silverstone GD05B Case, Sony PS3 BD Remote control, Logitech Cordless Mediaboard Pro for PS3
find quote
opdenkamp Offline
Team-XBMC PVR Developer
Posts: 2,228
Joined: Feb 2009
Reputation: 29
Location: Heerlen, The Netherlands
Post: #5
known issue

opdenkamp / dushmaniac

xbmc-pvr [Eden-PVR builds] [now included in mainline XBMC, so no more source link here :)]
personal website: [link]

Found a problem with PVR? Report it on Trac, under "PVR - core components". Please attach the full debug log.

If you like my work, please consider donating to me and/or Team XBMC.
find quote
LastCoder Offline
Fan
Posts: 434
Joined: Dec 2011
Reputation: 0
Post: #6
good to know .. but I hope it's being solved in Frodo and not only in the next versions ;-) ..

Ubuntu 12.04 LTS Server, Xfce, XBMC Gotham, Skin reFred, tvheadend tv backend
ASUS P8H61-M LE/USB3, Celeron G530, Geforce 210, 4 GB DDR3 RAM
16 GB CnMemory 300x CF, 1 TB Samsung 2,5" HDD
iHOS104 BluRay Drive, TT DVBS2-1600
Silverstone GD05B Case, Sony PS3 BD Remote control, Logitech Cordless Mediaboard Pro for PS3
find quote
B4MB4M Offline
Junior Member
Posts: 38
Joined: Feb 2012
Reputation: 0
Post: #7
Having the same issue here after upgrading to XBMC 13.0 ALPHA2.
Trying to get a working pvr.hts, but when I try I get the following :
Code:
xbmc@xbmc:~/Downloads/xbmc-pvr-addons-master$ sudo ./bootstrap
Can't exec "libtoolize": No such file or directory at /usr/bin/autoreconf line 195.
Use of uninitialized value in pattern match (m//) at /usr/bin/autoreconf line 195.
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal --force
autoreconf: configure.ac: tracing
autoreconf: configure.ac: not using Libtool
autoreconf: running: /usr/bin/autoconf --force
configure.ac:15: error: possibly undefined macro: AC_PROG_LIBTOOL
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
autoreconf: /usr/bin/autoconf failed with exit status: 1

Am I missing something ?

regards
Jerry

edit : I got it ... I had to install libtool.
But when I got in configred, and made, I copied the pvr.hts dir to the final location , but stull the same error
(This post was last modified: 2013-04-09 11:57 by B4MB4M.)
find quote
B4MB4M Offline
Junior Member
Posts: 38
Joined: Feb 2012
Reputation: 0
Smile  RE: afrer upgrade from git - can't install pvr.hts
Post: #8
OK , I got it working again Big Grin

The addon path shown in my xbmc addon page was : /usr/share/xbmc/addons/ , but the error in xbmc.log
pointed to /usr/lib/xbmc/addons/
First I placed the new created pvr.hts in the /usr/share/xbmc/addons/ directory : no help
After that I placed it in /usr/lib/xbmc/addons/ and also copied two more files :
Code:
xbmc@xbmc:~$ sudo cp /home/xbmc/Downloads/xbmc-pvr-addons-master/xbmc/libXBMC_pvr.h /usr/share/xbmc/addons/library.xbmc.pvr/
and
Code:
xbmc@xbmc:~$ sudo cp /home/xbmc/Downloads/xbmc-pvr-addons-master/addons/pvr.hts/XBMC_Tvheadend.pvr /usr/lib/xbmc/addons/pvr.hts/

Don't realy know if these last two files are needed, but did it anyway Wink

Now all is ok , and working again.
(This post was last modified: 2013-04-09 12:57 by B4MB4M.)
find quote