librtmp - Help Thread

  Thread Rating:
  • 8 Vote(s) - 4.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Closed
superceleron Offline
Member
Posts: 98
Joined: Dec 2014
Reputation: 7
Location: Portugal
Post: #1501
(2015-10-01 20:48)cristi_28 Wrote:  you upload librtmp.so.0 for Kodi15.1 > Linux-X86 not librtmp.so.1 ,in my understanding that from Kodi 14 and upwards you now replace the librtmp.so.1

rename it...
find
algee Offline
Junior Member
Posts: 3
Joined: Oct 2015
Reputation: 0
Post: #1502
Hello,

I am running openelec 5.95.5.6.0, kodi 15.1 on a RPi2.
I am trying to get sportsdevil to work.

Video was fine from the start, just audio was skipping very badly. Like one second audio every 2-3 seconds.

So i downloaded librtmp provided by superceleron, hacklib and all that, and rebooted.

And now i get no sound at all in any stream Sad

Is there anything else i am missing?
find
superceleron Offline
Member
Posts: 98
Joined: Dec 2014
Reputation: 7
Location: Portugal
Post: #1503
In here is working just fine with my lib, but try milhouse builds Smile
find
algee Offline
Junior Member
Posts: 3
Joined: Oct 2015
Reputation: 0
Post: #1504
Hey there,

looks like its working.

Apparently the stream i tried just had no audio track...
Thanks!
find
shiggedyshoo Offline
Junior Member
Posts: 4
Joined: Oct 2015
Reputation: 0
Post: #1505
Just wondering if anyone has got superceleron's latest builds working on ios9? I have an ipad air 2 (I've previously used the armv7s librtmp), but I get instant kodi crashes with the following error:

Code:
13:46:40 T:1081290752   ERROR: Unable to load /Applications/Kodi.app/Frameworks/libcurl.4.dylib, reason: dlopen(/Applications/Kodi.app/Frameworks/libcurl.4.dylib, 1): Library not loaded: @executable_path/Frameworks/librtmp.1.dylib
                                              Referenced from: /Applications/Kodi.app/Frameworks/libcurl.4.dylib
                                              Reason: no suitable image found.  Did find:
                                                /Applications/Kodi.app/Frameworks/librtmp.1.dylib: can't map segments into 16KB pages
                                                /private/var/db/stash/_.YEZVC7/Applications/Kodi.app/Frameworks/librtmp.1.dylib: can't map segments into 16KB pages

No luck with armv7 or the test armv8 versions either Sad
find
superceleron Offline
Member
Posts: 98
Joined: Dec 2014
Reputation: 7
Location: Portugal
Post: #1506
was compiled with ios8 sdk.... so need to compile it again bah...
find
Thread Closed