Notifications all mixed up, have no idea what's happening.

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
loggio Offline
Fan
Posts: 593
Joined: May 2010
Reputation: 6
Post: #1
Hi guys,

There's massive issues with the way XBMC displays notifications regarding recordings with ArgusTV.

If i'm watching live TV and hit the record button while in fullscreen playback, xbmc reports "Recording scheduled" but the backend has actually started recording. Maybe this is suppose to happen? but xbmc does not report back to say that the recording has actually started after it was quickly scheduled.

Now, if i press record again, it pop's up quickly and says "Recording Started" then "recording scheduled" again (confusing right?)... When i look in the argus tv notifier in the task bar, it's now recording the stream twice, making duplicates. (more confused?... i sure am)

now, if i press record again for a third time... XBMC reports quickly "Recording Started" then followed by "Recording Deleted"... When i look in argusTV notifier, it's stopped one of the recordings, but the other is still going.

now, if i push record again for a fourth time... xbmc reports nothing back at all.. but when i look in argustv notifier, all recordings have stopped and the notifier is empty.


It may be acting like this because i have a dual tunner card?? recoding twice because it's unaware of what it's recording and simply schedules on top of itself, then uses the second tuner to start the recording... Not sure. However, recording this way is pretty much useless because of the mix up with the notifications, i actually have no idea what the hell is happening.

Other backends seem to just work as they should. Push record once, get notification saying 'recording started', push record second time, get notfication saying 'recording ended' or 'stopped' ... something along those lines.

I really hope this can be fixed.


Cheers,
Loggio
find quote
jeffski10 Offline
Junior Member
Posts: 19
Joined: Nov 2012
Reputation: 0
Location: London
Post: #2
This is a known issue with Argus TV & xbmc. You just have to disable the notifications within XBMC.
(This post was last modified: 2013-04-15 22:38 by jeffski10.)
find quote
loggio Offline
Fan
Posts: 593
Joined: May 2010
Reputation: 6
Post: #3
It's not a notification problem entirely.

If i look at the Argus Messenger tray icon app, i have to push the record button 4 times in XBMC in order to start and stop recordings.

push it once, it schedules a recording.
push it twice, it starts the recorind and adds another schedule.
push it three times, the first recording stops and the second schedule starts.
push it a fourth time, and all recordings are removed from argus.

This is the activity that is recorded by ArgusTV itself.

if i turn off notifications in XBMC, Argus will still respond this way...

pushing the button should start a recording. Pushing it a second time should stop the recording. Simple... at the moment, it does not do this... It doubles up.

Cheers,
Loggio.
(This post was last modified: 2013-04-15 23:52 by loggio.)
find quote
tzortst Offline
Junior Member
Posts: 29
Joined: Jul 2011
Reputation: 0
Location: Melbourne Australia
Post: #4
(2013-04-15 22:38)jeffski10 Wrote:  This is a known issue with Argus TV & xbmc. You just have to disable the notifications within XBMC.

How do you disable the notifications?
find quote