AppleTV 2 (black) - Crash when screensaver running

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
locus123 Offline
Junior Member
Posts: 37
Joined: Jan 2013
Reputation: 0
Post: #1
I submitted this in the pre-12.2 thread, but I imagine it was ignored since it's (probably) not a new issue. I can't confirm without downgrading, and I won't have time in the next week or so. Let me know if a crashlog is needed as well. I didn't grab that the first time, just the logs (I was blindly following the log instructions).

ATV2 is running 5.2 ATV software/6.1 iOS.

All files/pictures accessed through SMB shares.

I am using the screensaver slideshow that displays files that reside on an SMB share. Once it starts displaying the files, I rarely have an issue. However, when it first starts to load and shows the big spinning circle, if I try to cancel by pressing a button, it usually crashes. XBMC crashes out to the ATV2 screen, I reran XBMC and uploaded the logs (I believe you only need the .old logs, but I included both).

Your debug xbmc.log: http://xbmclogs.com/show.php?id=12904
Your debug xbmc.old.log: http://xbmclogs.com/show.php?id=12905
(This post was last modified: 2013-04-24 23:24 by locus123.)
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,619
Joined: Feb 2011
Reputation: 116
Location: germany
Post: #2
Please disable metadata extraction as mentioned in the ios faq and see if this fixes it.

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
locus123 Offline
Junior Member
Posts: 37
Joined: Jan 2013
Reputation: 0
Post: #3
I just looked through the iOS FAQ and I don't see anything on metadata extraction (I also looked through some previous threads and didn't find anything). Does it have another name maybe, or am I missing it?

I also looked in the screensaver settings and I didn't see anything by that name either. Can you be a bit more specific?
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,619
Joined: Feb 2011
Reputation: 116
Location: germany
Post: #4
@Ned someone removed that from the iOS FAQ "reasons for crashing" list?

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
Ned Scott Offline
Team-Kodi Wiki Guy
Posts: 21,941
Joined: Jan 2011
Reputation: 291
Location: Arizona, USA
Post: #5
It's under "Performance". Will mention it under crashing too.

You can make easy links to the XBMC wiki using double brackets around common XBMC words: [[debug log]] = debug log, [[Video library]] = Video library, [[SMB]] = SMB , [[userdata]] = userdata, etc
find quote
locus123 Offline
Junior Member
Posts: 37
Joined: Jan 2013
Reputation: 0
Post: #6
Sorry guys, is "metadata extraction" code for something else? The below is the Performance section from the iOS FAQ. I don't see anything that either sounds like it's related to Pictures, or for extraction.

General

Switch to a different network protocol (especially if you are using SMB), i.e. NFS, FTP, WebDAV, etc.
Try sharing the media on another device to rule out a device-specific (or network) issue.
Turn off thumbnail generation (does not affect thumbnails from a library scan), XBMC > Settings > Video > File and deselect 'generate thumbnails'.
Disable playback sync completely, XBMC > Settings > Video > Playback > turn off "Sync playback to display"
If you are having buffering issues using a Time Capsule on WiFi, try this.
Try switching on dirty regions to speed-up the GUI using advancedsettings.xml GUI only. Won't help for video playback.
See also #Thumbnails for speeding up the GUI when it's loading large/lots of thumbnails.
Make sure the video isn't interlaced.
If the video is in HD, make sure it is using the h.264 codec (up to High Profile. Hi10P will not work, mediainfo can help).

ATV2

Use a wired network connection (if possible, even if just for testing to rule out wireless network issues).
Delete cache files in the following dir: /private/var/mobile/Library/Caches/AppleTV/Video/LocalAndRental (leave .plist files)
Configure Audio Output in XBMC > System > Settings > System to use Optical/Coax, even if you are using HDMI.
Set to 16-bit audio, Apple TV > Settings > Audio & Video > Audio Output and set it to "16 bit".
Try using an ATV iOS version before 4.4.4 to minimize system resource consumption.
Reboot to clear out the ATV2's RAM. Sometimes other "apps" like Netflix don't always release RAM when they are done.

iDevice

Try copying the video to the iDevice locally to see if it is a network issue or not.
find quote
locus123 Offline
Junior Member
Posts: 37
Joined: Jan 2013
Reputation: 0
Post: #7
Maybe to clarify, I'm not viewing fanart or movie posters or anything, these pictures are just a bunch of directories of family pictures.
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,619
Joined: Feb 2011
Reputation: 116
Location: germany
Post: #8
Turn off thumbnail generation (does not affect thumbnails from a library scan), XBMC > Settings > Video > File and deselect 'generate thumbnails'.
Disable playback sync completely, XBMC > Settings > Video > Playback > turn off "Sync playback to display"

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
locus123 Offline
Junior Member
Posts: 37
Joined: Jan 2013
Reputation: 0
Post: #9
I thought I'd resurrect this. I've followed all the suggestions above with no luck and I've been living with the issue above for a while, and it's completely random. Sometimes it crashes, sometimes it doens't. I can't find any correlation. I happened to have a debug running when it crashed last time, and I captured the events during the crash. I can't tell if this has the info required, but I'll paste it anyway.

<snip>
18:34:16 T:803811328 DEBUG: CSmbFile::Open - opened Pictures/Wedding/Pre/23.JPG, fd=10000
18:34:17 T:803811328 DEBUG: CSmbFile::Close closing fd 10000
18:34:22 T:973314952 DEBUG: XBMCPureController: Button press remoteAction = 6 originator = 1
18:34:22 T:135254016 DEBUG: CWinEventsIOS: Button press keyID = 3
18:34:22 T:135254016 DEBUG: CGUIWindowManager::PreviousWindow: Deactivate
18:34:22 T:135254016 DEBUG: started alarm with name: sssssscreensaver
18:34:22 T:135254016 DEBUG: ------ Window Deinit () ------
18:34:22 T:135254016 DEBUG: CGUIWindowManager::PreviousWindow: Activate new
18:34:22 T:135254016 DEBUG: ------ Window Init (MyVideoNav.xml) ------
18:34:22 T:135254016 DEBUG: CGUIMediaWindow::GetDirectory (multipath://smb%3a%2f%2fHS2K11%2fVideos%2fMovies%2f/smb%3a%2f%2fHS2K11%2fVideos%2fMovies%20-%20720%2f/)
18:34:22 T:135254016 DEBUG: ParentPath = [multipath://smb%3a%2f%2fHS2K11%2fVideos%2fMovies%2f/smb%3a%2f%2fHS2K11%2fVideos%2fMovies%20-%20720%2f/]
18:34:22 T:973314952 DEBUG: XBMCPureController: Button press remoteAction = 6 originator = 1
18:34:22 T:135254016 DEBUG: Loading items: 1065, directory: multipath://smb%3a%2f%2fHS2K11%2fVideos%2fMovies%2f/smb%3a%2f%2fHS2K11%2fVideos%2fMovies%20-%20720%2f/ sort method: 1, ascending: true
18:34:22 T:135254016 DEBUG: RunQuery took 167 ms for 400 items query: select * from movieview WHERE c23=1
18:34:24 T:135254016 DEBUG: RunQuery took 688 ms for 659 items query: select * from movieview WHERE c23=2
18:34:28 T:135254016 DEBUG: CAnnouncementManager - Announcement: OnScreensaverDeactivated from xbmc
18:34:28 T:135254016 DEBUG: GOT ANNOUNCEMENT, type: 4, from xbmc, message OnScreensaverDeactivated
18:34:30 T:156299264 DEBUG: DoWork - took 562 ms to load special://masterprofile/Thumbnails/6/6511b518.jpg
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,619
Joined: Feb 2011
Reputation: 116
Location: germany
Post: #10
useless ...

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
locus123 Offline
Junior Member
Posts: 37
Joined: Jan 2013
Reputation: 0
Post: #11
So is there any way to provide any kind of data that even show the crash? It's not even a crash, it's more like a hang. Nothing restarts or crashes - the picture is still on the screen, the XBMC background starts to show up around the picture, and it just stops responding at that point. Obviously it's not captured in the xbmc.log file (above), and the ATV doesn't crash so it won't be in those logs. Any thoughts on what else can be done?
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,619
Joined: Feb 2011
Reputation: 116
Location: germany
Post: #12
Code:
DEBUG: started alarm with name: sssssscreensaver

whats that?

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
locus123 Offline
Junior Member
Posts: 37
Joined: Jan 2013
Reputation: 0
Post: #13
It looks like a snake is trying to say screensaver.

That's a straight copy from the xbmc.old.log file. I can put the whole thing up on pastebin if you think that'll help?
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,619
Joined: Feb 2011
Reputation: 116
Location: germany
Post: #14
you sure this is not a service addon?

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
locus123 Offline
Junior Member
Posts: 37
Joined: Jan 2013
Reputation: 0
Post: #15
Uh oh. Yes, it is. It's the Team XBMC Slideshow addon. I always thought it was built in to XBMC, but I guess I enabled it years ago and it's just always been there. I guess this is posted in the wrong subforum then?
find quote
Post Reply