VAAPI Issue with Hybrid skin

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Jerrican Offline
Junior Member
Posts: 2
Joined: May 2013
Reputation: 0
Post: #1
I am newbe with both XBMC and the Hydrid Skin, used Boxee before, having download and installed everything within the last 2 days, so my apologies if my questions are already solved in another thread or are even downright stupidConfused

First the system I am running:
Intel NUC Celeron 847, 4GB Ram and 64GB SSD, connected with HDMI thru receiver and from receiver by HDMI to LED-TV, using latest version of OpenEelec 3.0.2 with Frodo12.2.
I have installed the Confluence, the Ace and the Hybrid Skin.

The Hybrid Skin is really awesome and since I basically like the setup and functionality of confluence but find the lay-out a bit boring, Hybrid is perfect for me and more easy for me to work with, thumbs up for the developerLove

When I run with the Hybrid-skin I have following issues:
The XBMC Media centre start up-logo crashes the system, rendering an all "green screen" and no reaction to any keyboard commands, and my only option is a "hard-reset", pushing main power button on the NUC.
Disabling this XBMC Media Centre in the setting solves that issue.
Next, playing videos from Navi-X, latest version 3.7.7, the HD 1080p and 720p, give the same green screen, only allowing me to do a hard reset again.

I couldn't find the option of VAAPI-disabling in Hybrid (is there one?) so I changed the skin to confluence.
I disabled the VAAPI in the confluence setting and changed the skin to Hybrid again and the issue seems solved.
All videos within Navi-X, using the Hybrid skin, now play without issues, also the 1080p run flawlessly.

The interesting thing though is that using the Confluence skin with VAAPI enabled, there are no issues with playing the same videos, it only occurs with the Hybrid skin.

The Question is why can Confluence play with VAAPI enabled and Hybrid not, at least in my setup?
Both use the same Openelec+Frodoversion after all.

I have googled and looked in forums but not found anyone with similar issue with the Hybrid skin.

Are there more people having the same issue and, if so, does someone have a explanation for this?
find quote
Jerrican Offline
Junior Member
Posts: 2
Joined: May 2013
Reputation: 0
Post: #2
May 18

The issue is solved.
First of all I found the place within the Hybrid skin where I could activate/de-activate the VAAPI for video.
Uptil now however all videos did not run (gave green screen) when VAAPI was activated within the Hybrid skin.
With the Cobfluence skin all videos run fine with the VAAPI activated.

Today my system automatically upgraded from OpenElec 3.0.2 to OpenElec 3.0.3.

When I now activate VAAPI within the Hybrid skin, all videos run fine, hecne I keep it activated.

I do not know which change in Openelec cause this, but my issue is solved.
find quote