[MOD] Xperience1080++

  Thread Rating:
  • 9 Votes - 4.33 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
el_cabong Offline
Senior Member
Posts: 192
Joined: May 2010
Reputation: 0
Post: #46
awesome.. thanks for the quick update. problem 2 seems to be completely fixed.

problem 1 persists. and it seems as tho the video frame is the only thing over the information. i tried it again with a wide screen video and could see the top and bottom parts of the info panel where the video crops the screen, but the video was on top covering the mid section.
find quote
el_cabong Offline
Senior Member
Posts: 192
Joined: May 2010
Reputation: 0
Post: #47
a few issues i see with the home screen menu. after you added the pictures section, on fresh boot, the header menu and tiles will be off. i have to play around with the menu for a second for them to line up again. notice in the second picture below the movies section is small and the mostly hidden home section is large, but offscreen.



i think there is a conflict with the new pictures header button. when selecting the menu item directly, the screen transitions then comes back to the main screen with the top right error message, because i dont have PVR setup.. but its from the pictures button.

[Image: 3KGk8Ak.jpg]

also, the tvshows header button does nothing while the movies goes to the movies library.. is there a setting i missed or is the function not there?
find quote
Slipx Offline
Member
Posts: 92
Joined: Jun 2008
Reputation: 0
Post: #48
Quote:a few issues i see with the home screen menu. after you added the pictures section, on fresh boot, the header menu and tiles will be off. i have to play around with the menu for a second for them to line up again. notice in the second picture below the movies section is small and the mostly hidden home section is large, but offscreen.

Like the updates but also experiencing the problem above
find quote
im85288 Offline
Fan
Posts: 530
Joined: Aug 2011
Reputation: 12
Location: United Kingdom
Post: #49
Hi Guys, I have just pushed a fix to Github that should solve the problems mentioned with the pictures and tv header buttons. Also hopefully the alignment problems on a fresh boot are solved as I now included a default picture to be shown when nothing is set in the settings along with using the correctly coloured picture tiles at startup.

el_cabong, with regards problem 1 with the actors...it seems to work fine for me when a video is playing..after pressing right on cast it takes me to the biography. Is this not happening for you?

As a final tip (and this comes from blacks thread)..if the menu options get out of synch going down to the power button and pressing down twice should fix it...hopefully this has not increased though with the adding of pictures

[Image: q4FdSAu.png]
(This post was last modified: 2013-06-07 11:53 by im85288.)
find quote
el_cabong Offline
Senior Member
Posts: 192
Joined: May 2010
Reputation: 0
Post: #50
Thanks again, the menu items are working as they should.

I am still noticing the start-up issue where the menu defaults to the search, but the tiles default to the home area, making it out of alignment. the temp fix you stated works to bring them back into alignment.

re problem 1, yes, it gets to the biography, but try to keep going in the menu and open a new movie, it will show up behind the currently playing movie.. use a wide screen movie so there are the black bars on the top and bottom of the picture.
find quote
im85288 Offline
Fan
Posts: 530
Joined: Aug 2011
Reputation: 12
Location: United Kingdom
Post: #51
Completed all EPG screens with alternate view and fixed problem with focus on startup - available on Github



@el_cabong - with regards problem 1 it seems to work fine for me, once I select a new movie it stops the currently playing movie and then starts the new one. Perhaps I did not do it the way you did though. And thanks for the test and bug reports, helps out a lot as I would never have seen the focus problem mentioned due to having the global search addon disabled so it does not show on the menu.

[Image: q4FdSAu.png]
find quote
Slipx Offline
Member
Posts: 92
Joined: Jun 2008
Reputation: 0
Post: #52
If you chose not to display the pictures menu option then it stills goes out of sync.
find quote
LeeG Offline
Member
Posts: 73
Joined: Aug 2011
Reputation: 2
Post: #53
Fuuu..slow down with the updates! Wink

PS: -10 man points for watching The Voice (and don't tell me it's because "the other half" likes to watch it.
find quote
im85288 Offline
Fan
Posts: 530
Joined: Aug 2011
Reputation: 12
Location: United Kingdom
Post: #54
(2013-06-07 23:25)Slipx Wrote:  If you chose not to display the pictures menu option then it stills goes out of sync.

This has now been corrected and is on Github, thanks for the report.

(2013-06-08 00:26)LeeG Wrote:  Fuuu..slow down with the updates! Wink

PS: -10 man points for watching The Voice (and don't tell me it's because "the other half" likes to watch it.

I think I have reached saturation point and yes time for a break ( The voice was for the "other half" honest :-))..plus with the Arctic mod (views are beautiful) there is so much I like in there minus the whole PVR section and OSD so I may mashup that version with the new PVR screens and OSD from here and add the Pictures and Music Video changes..what do you guys think..continue this one or mashup?

[Image: q4FdSAu.png]
(This post was last modified: 2013-06-08 11:26 by im85288.)
find quote
jurialmunkey Offline
Skilled Skinner
Posts: 763
Joined: Feb 2013
Reputation: 52
Post: #55
(2013-06-08 11:21)im85288 Wrote:  I think I have reached saturation point and yes time for a break ( The voice was for the "other half" honest :-))..plus with the Arctic mod (views are beautiful) there is so much I like in there minus the whole PVR section and OSD so I may mashup that version with the new PVR screens and OSD from here and add the Pictures and Music Video changes..what do you guys think..continue this one or mashup?

I'm currently in the process of changing the pvr section in Arctic so its more in line with the theme, so I would wait a little bit if I were you Wink I've been meaning to change it for quite a while as it hasn't had nearly as much attention as I've put into the views - I've just been putting it off as it is a fairly big job. But I'm making a move on it now that I'm happy (for the most part) with the viewtypes.
(This post was last modified: 2013-06-08 12:37 by jurialmunkey.)
find quote
im85288 Offline
Fan
Posts: 530
Joined: Aug 2011
Reputation: 12
Location: United Kingdom
Post: #56
Great news, the views in your mod are nothing short of awesome. I will still go ahead and integrate my PVR and OSD changes just because they are areas I think I have nailed (personal view only!) and those areas with the inclusion of the pictures and music videos support along with support for movie sets and concerts are additions I would make to your mod..but great work, the views are what I was aiming for without knowing it!!

[Image: q4FdSAu.png]
find quote
BigPoppa17211 Offline
Junior Member
Posts: 13
Joined: May 2013
Reputation: 0
Post: #57
Yeah, if you two could combine the best of both, you would have a super-mod on your hands! Still going back and forth between the 2...kinda like deciding which of your kids you love more Smile

On another note, maybe one of you could help me out here. I have XBMC running on my desktop and Openelec running on a dedicated box in the bedroom. On Openelec Im not seeing any of the "new" indicators for both themes, but see them fine on the Windows version. Any idea where I would look to see if something is wrong? The watched indicators work fine though. Thanks!
find quote
jurialmunkey Offline
Skilled Skinner
Posts: 763
Joined: Feb 2013
Reputation: 52
Post: #58
(2013-06-09 01:28)BigPoppa17211 Wrote:  Yeah, if you two could combine the best of both, you would have a super-mod on your hands! Still going back and forth between the 2...kinda like deciding which of your kids you love more Smile

On another note, maybe one of you could help me out here. I have XBMC running on my desktop and Openelec running on a dedicated box in the bedroom. On Openelec Im not seeing any of the "new" indicators for both themes, but see them fine on the Windows version. Any idea where I would look to see if something is wrong? The watched indicators work fine though. Thanks!

It's because OpenElec is Linux and the Linux file system is CaSe SeNsiTiVe. In the skin directory under /media/overlays there should be two folders OverlayWatched.png and OverlayUnWatched.png - in Black's original skin and most of the mods of it, OverlayUnWatched.png is named incorrectly. It Should be OverlayUnwatched.png with a lower case w.

In my mod, I've removed the unwatched indicators for the moment because I'm using blue for watched (because of the poster watched overlays I'm using from aeon which are also blue), and using either green or red for unwatched becomes confusing. Plus an indicator for watched is all that is really needed.
(This post was last modified: 2013-06-09 04:20 by jurialmunkey.)
find quote
BigPoppa17211 Offline
Junior Member
Posts: 13
Joined: May 2013
Reputation: 0
Post: #59
(2013-06-09 04:16)jurialmunkey Wrote:  
(2013-06-09 01:28)BigPoppa17211 Wrote:  Yeah, if you two could combine the best of both, you would have a super-mod on your hands! Still going back and forth between the 2...kinda like deciding which of your kids you love more Smile

On another note, maybe one of you could help me out here. I have XBMC running on my desktop and Openelec running on a dedicated box in the bedroom. On Openelec Im not seeing any of the "new" indicators for both themes, but see them fine on the Windows version. Any idea where I would look to see if something is wrong? The watched indicators work fine though. Thanks!

It's because OpenElec is Linux and the Linux file system is CaSe SeNsiTiVe. In the skin directory under /media/overlays there should be two folders OverlayWatched.png and OverlayUnWatched.png - in Black's original skin and most of the mods of it, OverlayUnWatched.png is named incorrectly. It Should be OverlayUnwatched.png with a lower case w.

In my mod, I've removed the unwatched indicators for the moment because I'm using blue for watched (because of the poster watched overlays I'm using from aeon which are also blue), and using either green or red for unwatched becomes confusing. Plus an indicator for watched is all that is really needed.

That fixed it! Thanks for the help, now can see the "NEW" label on the openelec box.
find quote
im85288 Offline
Fan
Posts: 530
Joined: Aug 2011
Reputation: 12
Location: United Kingdom
Post: #60
New version of Xperience1080++ merged with the amazing Arctic version by jurialmonkey

- additions include

-- Pictures
-- Rearranged Home menu with Live TV positioned next to TV Shows
-- Music Videos support
-- Ability to show more background fanart in views/homescreen etc
-- Uses phil65 extended info script for additional movie sets information
-- view fanart in movie information view
-- uses OSD and PVR views from the original Xperience1080plusplus mod



Available at the new Github location of: XperienceArctic1080plusplus

[Image: q4FdSAu.png]
find quote
Post Reply