Mac OS X - AUDIO STUTTER ON 1ST SECOND OF MUSIC PLAYBACK (short video posted)

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
capfuturo Offline
Fan
Posts: 568
Joined: Feb 2013
Reputation: 11
Location: London, UK
Post: #1
Good morning,

FULL DEBUG LOG HERE

VIDEO REPRODUCING THE ISSUE:





Music playback stutters on 1st second of playback for every file I choose, rewind or skip to, regardless of its audio codec. The files play absolutely fine in Plex, in any other music player, or in XBMC if it is left alone playing the tracks without skipping or selecting them manually (no stutter occurs).

I reproduced the issue (debug log attached) selecting a track, playing it for 10 seconds, then skipping to the next one. I allowed XBMC to go from the penultimate track to the last one by itself without manually skipping (log time: 19:56:49), so the log could show a difference, if there is any.

Set-up: Macbook Pro Retina display 2013; music library located in a usb local volume connected directly to the macbook. XBMC: v12.2 ; SKIN: AEON NOX 4.0.9 .

System - Audio Settings as follows:
[Image: XBMC%20-%20System%20Audio%20Settings.jpg]

I hope someone can help. Thank you!

Best,

capfuturo


"The world must learn to work together, or finally it will not work at all" - General Eisenhower
(This post was last modified: 2013-09-06 19:13 by capfuturo.)
find quote
capfuturo Offline
Fan
Posts: 568
Joined: Feb 2013
Reputation: 11
Location: London, UK
Post: #2
(This post was last modified: 2013-09-06 18:28 by capfuturo.)
find quote
capfuturo Offline
Fan
Posts: 568
Joined: Feb 2013
Reputation: 11
Location: London, UK
Post: #3
(This post was last modified: 2013-09-06 18:24 by capfuturo.)
find quote
xarqi Offline
Junior Member
Posts: 14
Joined: Nov 2012
Reputation: 0
Post: #4
If this is the issue I think it is, it's been broken since 12.0. I'm not sure if there will be a fix in 12.3, if indeed there will be a 12.3.
Download 12.0 and see if that works for you.
find quote
capfuturo Offline
Fan
Posts: 568
Joined: Feb 2013
Reputation: 11
Location: London, UK
Post: #5
Thank you xarqi,

Indeed seems to be a version-related issue which seems to be fixed in Gotham Alpha 9. I just tested it and works without stutter.

Best,

capfuturo


"The world must learn to work together, or finally it will not work at all" - General Eisenhower
find quote
capfuturo Offline
Fan
Posts: 568
Joined: Feb 2013
Reputation: 11
Location: London, UK
Post: #6
It is also resolved on XBMC 12.3 test build running on OS X Mavericks. See here for build.

Best,

capfuturo


"The world must learn to work together, or finally it will not work at all" - General Eisenhower
find quote