Mac OS X - Problem with SMB protocol after updating to Mac OS Maverick

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Memphiz Offline
Team-Kodi Developer
Posts: 11,584
Joined: Feb 2011
Reputation: 116
Location: germany
Post: #91
Ok

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
Welbach Offline
Junior Member
Posts: 5
Joined: Nov 2014
Reputation: 0
Post: #92
Anyway, it’s OK. The Fire TV is back the Warehouse and I don‘t need a solution for this problem. I feel much better now Wink
find quote
wrxtasy Offline
Senior Member
Posts: 228
Joined: Feb 2012
Reputation: 3
Location: Perth, Oz
Post: #93
(2014-11-01 19:04)Welbach Wrote:  No. Tht’s not the problem. I can see the directories and files from all other machines in the network. It is read only bot open for everyone.
Sorry I did not get on here sooner...

If you still want to have a look in NFS Manager -

1. Select your shared folder in the top window.
2. Click "Show advanced options" on the bottom right.
3. Ensure "Allow mounting the folder or any subfolders inside" is selected.
4. Close and repeat for any other shared folders.
5. Remember to hit "Apply"

The other hint that has already been alluded to is to make sure "Sharing & Permissions" is correctly set for the selected folder or external drive.

1. Select the problem folder or drive in question, right click and select "Get Info"
2. At the bottom right of the window click the padlock and type in your password
3. In the Name and Priviledge window set everything to Priviledge "Read & Write"
4. In the drop down star symbol (next to + -) - select "Apply to enclosed items...."
5. Click the padlock again and you done.

or the Brute Force quick way just.....

Select "Ignore ownership on this volume"

Undecided
(This post was last modified: 2014-11-02 05:18 by wrxtasy.)
find quote
Welbach Offline
Junior Member
Posts: 5
Joined: Nov 2014
Reputation: 0
Post: #94
Thanks for the help. I did so and it had no effect. It simply didn't work. But it’s over now. I returned the Fire TV and returned myself to LEX. Although I’d like XBMC much more (and tried for this reason the Fire TV because my Smart TV has no app which would wok with XBMC), it’s better to have a solution which is ugly but works as one beautiful which costs a lot of time and nerves and doesn’t work... Wink

(The strange thing: There was no problem with SMB on a Mac runnig Mountain Lion. It seems to be a problem with Mavericks. But now it’s no longer important for me.)
find quote
macha-one Offline
Junior Member
Posts: 7
Joined: Aug 2012
Reputation: 0
Post: #95
hi there , i would like to join this thread. I m having issues with smb afp nfs as well.
Gave up on smb and afp after testing and trying for many hours.

so NFS is my last option.
I ve set up my shared folders on my mac with the nfs manager.
But on my crystalbuntu apple tv1 with latest gotham I somehow can n to get grips on the server name and shared folder path

1. in XBMC I added a new network location. chose NFS protocol
2. used the http adress of my mac as the server name. ( also tried the name of the server )
3., as shared folder the path structure as mentioned in the nfs manger app on my mac.

should i use my username and password?
am I overlooking something?

the zero config option does not work for me.
after trying for 5 hours I decided to join this thread........can anyone help a sad xbmc girl....i would love to have this working.
find quote
wrxtasy Offline
Senior Member
Posts: 228
Joined: Feb 2012
Reputation: 3
Location: Perth, Oz
Post: #96
Hi macha-one, I run my iMac via NFS to - 2 Crystalbuntu ATV1's and a Raspberry Pi as well.
Please check you have this selected in XBMC: > System > Settings > Services > Zeroconf > Announce these services to other systems via Zeroconf

I have never managed to get NFS sharing to work in XBMC by selecting NFS Protocol, it has always worked when i select Zeroconfig - no usernames or passwords necessary.
In NFS Manager in the window with the Shared folder names I have this under the Options heading:

-alldirs -maproot=0:0

If you do not see that I suggest you start configuration again with NFS Manager using the link below.

http://forum.kodi.tv/showthread.php?tid=...pid1814794

Also make sure your ATV1 actually has an IP address on your local network:

Settings > System Info
(This post was last modified: 2014-11-08 17:07 by wrxtasy.)
find quote
macha-one Offline
Junior Member
Posts: 7
Joined: Aug 2012
Reputation: 0
Post: #97
thnx for you input wrxtasy
Got it working. It had to do with double slashes in the path which xbmc added on its own.

now the next thing i need to solve is hw to open ports 111 and 2049......i
xbmc can not access my mac when firewall on mac is on.......
or is there another trick to do this.

how can this be done in mavericks?
find quote
wrxtasy Offline
Senior Member
Posts: 228
Joined: Feb 2012
Reputation: 3
Location: Perth, Oz
Post: #98
Did you leave the OSX Firewall off when using Zeroconfig from XBMC to add your shared folders initially ?
If it was enabled that may have been the source of the problem. I would turn the Firewall off then try Zeroconfig again.

Even with Firewall turned on and XBMC getting media from the Mac NFS share, configured via Zeroconfig in XBMC. I am not getting port 2049 blocked.
I suggest you start configuring and sharing from scratch with the Firewall off.

I also just had a play around with the OSX Firewall myself, you could try this if all else fails....

System Preferences > Security & Privacy > Firewall > Firewall Options > Hit + and then add the NFS Manager.app from your Applications folder to the Firewall list to allow incoming connections.

More info here:
http://support.apple.com/en-us/ht1810

Tongue
(This post was last modified: 2014-11-09 05:47 by wrxtasy.)
find quote
macha-one Offline
Junior Member
Posts: 7
Joined: Aug 2012
Reputation: 0
Post: #99
thnx again wrxtsy .
Indeed the firewall was on when setting up the links.
will try your suggestion. Makes a lot of sense. Will try zero config again instead of the create network option.
Maybe the firewall prevented the zero config from connecting.

I already had the NFS app checked in the firewall options.
in old OS X versions you could easily choose which ports you wanted to open but apple took that out in mavericks .....:-(

I am determined to get this working. :-) thnx for the heads up.
find quote
macha-one Offline
Junior Member
Posts: 7
Joined: Aug 2012
Reputation: 0
Post: #100
the zero configuration worked after I turned off the firewall. Scanning the content on my mac went fine.
Sadly when turning the firewall back on after finishing the library scan the links to the movies on my mac don t work.
When I turn off the firewall links work fine......

I suppose I have to find a way to open those two ports to make it work.
Since this is not in the system preferences anymore I was wondering if this can be done with an app or with terminal....


anyone have a suggestion how to open ports 111 and 2049?

i enabled " allow" for the nfs manger in the security / firewall option. did not help. :-(
nevertheless I will not give up on this. any suggestion is welcome.

thnx in advance
find quote
wrxtasy Offline
Senior Member
Posts: 228
Joined: Feb 2012
Reputation: 3
Location: Perth, Oz
Post: #101
Make sure you have rebooted your Mac and then allowed the connections that popup after reboot through the Firewall.
If that fails to allow anything through try the procedure below.

Turn Firewall OFF

Then fire up the OSX App - Terminal and the copy paste this: (hit <return> once pasted and enter password)

Code:
sudo nano /etc/pf.conf

Then scroll down and add this text at the end of the file:

Code:
# Open port 2049 for TCP on all interfaces
pass in proto tcp from any to any port 2049

Hit <return> after "port 2049" twice to insert a blank at the end of the file. (or errors will result when you test below)
Then to save it CTRL_O <return> CTRL_X to exit.

Now to test and load with the new open ports:

Code:
sudo pfctl -vnf /etc/pf.conf

Then Reboot your Mac and turn the Firewall back on again.

Fingers crossed. xx

**I'm now sure why you need port 111 open as well as NFS manager only configures port 2049. If so add this text to the end of file as well:

Code:
pass in proto tcp from any to any port 111
(This post was last modified: 2014-11-13 04:31 by wrxtasy.)
find quote
lberlincioni Offline
Junior Member
Posts: 1
Joined: Nov 2014
Reputation: 0
Post: #102
Hi, I don't have that much of computer knowledge, but I'm trying to set up my Mac (updated to Mavericks) to work with boxee.
I've set up my network, file sharing and SMB settings on my Mac, I go on the boxee browse the file sources to add my shared folders from the computer and it asks for a user name and password, which I didn't even set up in the first place. I've tried both AFP and SMB protocols and have the same kind of problem. I've double checked the Network settings and I made sure that the "Enable Windows File Sharing" box was checked and on.
I've tried putting in my computer login username and pw just to try, but it doesn't work and no folder gets added to boxee.
What should I do? What settings to I need to change?
Any advice is welcome,
Thanks!
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,584
Joined: Feb 2011
Reputation: 116
Location: germany
Post: #103
Please understand that we want you to gather support for Boxee from wherever Boxee is supported. We don't support it here (and if you knew the history you maybe wouldn't ask exactly in our forum ...).

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
macha-one Offline
Junior Member
Posts: 7
Joined: Aug 2012
Reputation: 0
Post: #104
WRXTSY thnx for your suggestions. I tried the terminal commands.
sadly it did not solve the issue..:-( still no connection possible with firewall on.

only doubt I have is if I used the CTRL_O and CTR_X commands in the right way.....
is it just two keys..CTRL and O ? or should I use the " _ " key as well?


also i was wondering if a network cable might help...I am now trying the connection over wifi.....
find quote
wrxtasy Offline
Senior Member
Posts: 228
Joined: Feb 2012
Reputation: 3
Location: Perth, Oz
Post: #105
A bit clearer...In sudo nano....

^O WriteOut...... means save text file. To do that hold down CONTROL and press O.
"File Name to Write: /etc/pf.conf" will then be highlighted - then hit <return> to save.

The bottom middle of the text will now say [Wrote xx lines]
(This post was last modified: 2014-11-14 20:00 by wrxtasy.)
find quote
Post Reply