Solved Issue - Umlauts in EPG and channel names sometimes not showing correctly

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
eroxm Offline
Junior Member
Posts: 34
Joined: Aug 2008
Reputation: 0
Post: #1
In the channel names and the EPG the "umlauts" (german special characters) are sometimes not shown correctly. I've tried to delete the database, but this did not help in any cases. Some were fixed after that, some were not. I don't know if it's an issue of vdr, xbmc or vnsi. Hopefully someone can help me.
(This post was last modified: 2013-11-30 19:34 by eroxm.)
find quote
FernetMenta Offline
Team-Kodi Developer
Posts: 3,676
Joined: Jul 2010
Reputation: 72
Location: Munich
Post: #2
Your channels.conf needs to be encoded in utf-8. You can either do this with w_scan when creating the file or use iconv in case you missed this.
Some channels don't braodcast the used character set for EPG. You need to set charset override for vdr:
export VDR_CHARSET_OVERRIDE="ISO-8859-15"
find quote
eroxm Offline
Junior Member
Posts: 34
Joined: Aug 2008
Reputation: 0
Post: #3
Thanks! Seems to have worked. Still saw some characters that were wrong, but only on non-german channels (spanish, ...). But I don't care about that.
find quote
eroxm Offline
Junior Member
Posts: 34
Joined: Aug 2008
Reputation: 0
Post: #4
The issue is not finally solved. After some time the wrong characters in the EPG are back. Do I have to put export VDR_CHARSET_OVERRIDE="ISO-8859-15" into some config file?
find quote
FernetMenta Offline
Team-Kodi Developer
Posts: 3,676
Joined: Jul 2010
Reputation: 72
Location: Munich
Post: #5
I have it in the script runvdr
find quote
sveni_lee Offline
Fan
Posts: 405
Joined: Jan 2013
Reputation: 9
Post: #6
(2013-12-22 20:35)FernetMenta Wrote:  I have it in the script runvdr

I've tried ti change the /usr/sbin/runvdr as follow

Code:
echo 'C.UTF-8'
    fi
}

setEnv() {
    if [ -z "$VDR_LANG" ]
    then
        local VDR_LANG=$(getLang)
    fi

    export LANG=$VDR_LANG LC_ALL=$VDR_LANG $VDR_ENV
}

start() {
    local plugins=''
    local args="-u $USER -v $VIDEO_DIR -c $CFG_DIR -L $PLUGIN_DIR -s $VDRSHUTDOWN \
                -E $EPG_FILE -g /tmp --port $SVDRP_PORT $OPTIONS $@"
    local epg_dir=$(dirname "$EPG_FILE")

    for i in $PLUGINS
    do
        if [ -f "$PLUGIN_CFG_DIR/plugin.$i.conf" ]
        then
            a="$(echo $(cat "$PLUGIN_CFG_DIR/plugin.$i.conf" | sed "s/ *#.*$//"))"
            plugins="$plugins -P '$i $a'"
        else
            plugins="$plugins -P $i"
        fi
    done

    [ ! -d "$epg_dir" ] && mkdir "$epg_dir" || true
    [ ! -d "$VIDEO_DIR" ] && mkdir "$VIDEO_DIR" || true
    chown $USER:$GROUP "$epg_dir"
    chown $USER:$GROUP "$VIDEO_DIR"
    setEnv

    ([ -z "$PLUGINS" ] && echo 'Starting VDR') || \
    echo "Starting VDR with plugins: $PLUGINS"

    unloadDriver
    loadDriver

    eval exec "$EXECUTABLE" $args $plugins
}

start $@

export VDR_CHARSET_OVERRIDE="ISO-8859-15"

is it right in this way, because I had no succsess

Board: B85M-ITX
CPU: i3 4330
find quote
FernetMenta Offline
Team-Kodi Developer
Posts: 3,676
Joined: Jul 2010
Reputation: 72
Location: Munich
Post: #7
I would put it before the call to start vdr.
find quote
sveni_lee Offline
Fan
Posts: 405
Joined: Jan 2013
Reputation: 9
Post: #8
Thank you,

I will try..

Board: B85M-ITX
CPU: i3 4330
find quote
sveni_lee Offline
Fan
Posts: 405
Joined: Jan 2013
Reputation: 9
Post: #9
Thanks again....

It workd...

Board: B85M-ITX
CPU: i3 4330
find quote
eroxm Offline
Junior Member
Posts: 34
Joined: Aug 2008
Reputation: 0
Post: #10
It's working for me too, but after every update of vdr, the code line is gone and I have to add it again manually. Is there another way I can do this or another file I can add this to so that it stays permanently?
find quote