Help us solving the AirPlay issue when using iOS7 devices

  Thread Rating:
  • 6 Votes - 4.33 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Memphiz Offline
Team-Kodi Developer
Posts: 11,278
Joined: Feb 2011
Reputation: 114
Location: germany
Post: #436
You can just skip posting those statements without a log file - as you need to post anyway again and it only increases the number of useless posts in this already very big thread ...

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
testooo Offline
Junior Member
Posts: 27
Joined: Mar 2014
Reputation: 0
Post: #437
(2014-04-03 10:23)Memphiz Wrote:  @testooo

your airplay log looks fine - xbmcs player struggles with the googlevideo.com videos/urls it seems. Try it without dxva hw decoding maybe - but from an airplay point of view it is fine.

Thanks mate ... I dont know how to do that is it a setting on Xbmc or Youtube app ? also I forgot to mention that on Testbuild 10 didn't have this problem as its the same system setup .... except now Beta3 installed ....!!!

Do you think Beta3 has more changes than Testbuild 10 and may be corrupted your fix? just a thought

cheers
(This post was last modified: 2014-04-04 00:52 by testooo.)
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,278
Joined: Feb 2011
Reputation: 114
Location: germany
Post: #438
No b3 is fine and works flawless for me on all platforms.

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
testooo Offline
Junior Member
Posts: 27
Joined: Mar 2014
Reputation: 0
Post: #439
(2014-04-04 11:56)Memphiz Wrote:  No b3 is fine and works flawless for me on all platforms.

l tried to disable HW decoding and its the same, My guess there is something has changed on last week update from youtube app on iPad I found out that old videos play ok via airplay but the newer once have problem as I stated above....

could I be correct? as I am sure testbuild 10 was ok but before youtube app updated ?
find quote
Boilerplate4U Offline
Junior Member
Posts: 4
Joined: Mar 2014
Reputation: 0
Post: #440
(2014-04-04 11:56)Memphiz Wrote:  No b3 is fine and works flawless for me on all platforms.

By any chance, did any of you test playback with subtitles as well? I'm asking since I can't get subtitles to work with either hbo or viaplay with airplay from ios 7 to xbmc rpi (b3). Besides that, audio and video seems to work with occasional hiccups during forward or reverse seek.

Anyhow, many thanks for the great work with the airplay support for xbmc!
(This post was last modified: 2014-04-06 17:32 by Boilerplate4U.)
find quote
Harri Offline
Junior Member
Posts: 43
Joined: Nov 2009
Reputation: 0
Post: #441
airplay works only 50% for me. I haven't found an option to attach a log file to this thread, so I created http://trac.xbmc.org/ticket/15097 . Hope this helps.
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,278
Joined: Feb 2011
Reputation: 114
Location: germany
Post: #442
(2014-04-06 17:27)Boilerplate4U Wrote:  
(2014-04-04 11:56)Memphiz Wrote:  No b3 is fine and works flawless for me on all platforms.

By any chance, did any of you test playback with subtitles as well? I'm asking since I can't get subtitles to work with either hbo or viaplay with airplay from ios 7 to xbmc rpi (b3). Besides that, audio and video seems to work with occasional hiccups during forward or reverse seek.

Anyhow, many thanks for the great work with the airplay support for xbmc!

There is no subtitle support via airplay as it is unknown on how this works.

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
dantaylorseo Offline
Junior Member
Posts: 4
Joined: Mar 2014
Reputation: 0
Post: #443
Hi there,

AirPlay working in B3 on Windows 7 in all but one app I have tested.

The app is PremierLeaguePass and the extract from the log file is at http://pastebin.com/y7gxSCfj it seems like it can't download a key file?

Dan
find quote
mirata Offline
Junior Member
Posts: 4
Joined: Mar 2014
Reputation: 0
Post: #444
Just wanted to say that I upgraded to gotham beta 4 and airplay video is working very well. Thanks for the hard work memphiz
find quote
yoggit Offline
Junior Member
Posts: 6
Joined: Oct 2011
Reputation: 0
Post: #445
I'm on beta 3 and have odd airplay audio behaviour... Windows 8.1 on Intel NUC, IOS7.1 iphone.

Airplay audio wasn't working... just no sound. Everything looked like it was OK, but no sound. It has been like this for days.

So today enabled debugging as I was going to submit the logs here, and airplay audio started working! I then disabled debugging and airplay remains OK.

So I reboot (with debugging disabled) and again airplay audio is broken until I enable debugging at which point the audio immediately starts (it was still 'playing' from my phone)

Another reboot to verify the behaviour and airplay audio appears OK.

So in a nutshell, I've had sporadic behaviour, and unable to get logs to show it!

Frustrated,
Jon
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,278
Joined: Feb 2011
Reputation: 114
Location: germany
Post: #446
volume turned up in the remote app or volume control disabled (its under the airpaly option)?

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
catkinso Offline
Junior Member
Posts: 41
Joined: Mar 2013
Reputation: 0
Post: #447
Hi, Can you please provide a link to the feature requirement details for the release? I would like to see if you have retained the XML file settings capability for this fix and it's documentation. Thx
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,278
Joined: Feb 2011
Reputation: 114
Location: germany
Post: #448
no the xml was not implemented in a way that it would have been accepted in mainline.

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
catkinso Offline
Junior Member
Posts: 41
Joined: Mar 2013
Reputation: 0
Post: #449
Thanks for response. Can I log a request for this to be implemented? (Required Due to shoddy 3rd party compatibility crap from people like Plex)
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,278
Joined: Feb 2011
Reputation: 114
Location: germany
Post: #450
Nobody limits the stuff which people can request. At least i will not implement this because as soon as people start to alter the zeroconf announcement to their likes the support hell on airplay issues will get even hotter.

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
Post Reply