From Subtitles add-on to subtitles service. The no-trouble How-to.

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
nickr Offline
Donor
Posts: 9,924
Joined: May 2009
Reputation: 179
Location: Christchurch NZ
Post: #196
Please identify where in that log you search for a subtitle?

If I have helped you or increased your knowledge, click the plus button and increase my reputation :)
find quote
korgis Offline
Junior Member
Posts: 4
Joined: Sep 2014
Reputation: 0
Post: #197
Installed the service OpenSubtitle and adjustment were inserted data for logging their website.After starts of the film click on the button (small screen) and then click on the "subtitles" After that appears Opensubtitle service and the message "Searching subtitle ..." and so is until tomorrow Smile

P. S. Yesterday happened to me a coincidence that the first "Search" found the subtitles (english) because I configured the settings.Now then tried with subtitles by Serbs, Croatia, Bosnia and Herzegovina, but the result was "Searchin subtitle ......" Repeat the back to adjust subtitles "English" and again the same result "Searchin subtitle ......" Sad
(This post was last modified: 2014-10-22 10:24 by korgis.)
find quote
tnuc Offline
Junior Member
Posts: 42
Joined: Sep 2014
Reputation: 1
Post: #198
And a Debug Log with all that is where?
find quote
korgis Offline
Junior Member
Posts: 4
Joined: Sep 2014
Reputation: 0
Post: #199
I hope that my problem here http://pastebin.com/CEGvNbyJ
refers to the number of post #191
Thank you all for your patience !!
(This post was last modified: 2014-10-27 10:41 by korgis.)
find quote
h4wkm00n Offline
Junior Member
Posts: 7
Joined: Dec 2013
Reputation: 0
Post: #200
Hi everyone,

Like others, I'm having trouble getting subtitles to work since the last big change.
The subtitle features in the previous versions of XBMC were really great, and will be in the future. As for now, it is a pain.

I've read the 1st post, and as many docs as I could find. Nothing works completely.

I'm using xmbc on a raspberry with raspmbc, and on a HTPC, on ubuntu (XBMC 13.2).

As for the subtitle services, I have 3 issues to talk about

1st : Temp dirs don't seem to be created. So all the subtitle services I've tried fail with
Code:
Error Contents: [Errno 2] No such file or directory: '/home/pi/.xbmc/userdata/addon_data/service.subtitles.XXXXX/temp/'
I've commented the recreations of temp dirs, and the scripts can go on.

2nd : Opensubtiles.org (updated today) fails with message :
Code:
16:13:04 T:2667574336   ERROR: GetDirectory - Error getting plugin://service.subtitles.opensubtitles/?action=download&link=http://dl.opensubtitles.org/en/download/subad/src-api/xxxxxxxxxx/5880611/xxxxxxxxx&ID=1954459004&filename=The.Walking.Dead.S05E04.HDTV.x264-KILLERS.srt&format=srt
I can say that I can download the zip file manually from the command-line, with the same user as xbmc. Maybe it expects the file to be a plain srt file. Or is it again a temp dir issue ?

3rd : Super subtitles fails with message :
Code:
15:59:46 T:2667574336   ERROR: OnDownloadComplete - Saving of subtitle /home/pi/.xbmc/userdata/addon_data/service.subtitles.supersubtitles/temp/Once_Upon_a_Time_-_04x06_-_Family_Business.DIMENSION.English.C.orig.Addic7ed.com.srt to special://temp/Once.Upon.a.Time.2011.S04E06.HD.TV-DIMENSION.en.srt failed
NOTICE: special://temp/ is mapped to: /home/pi/.xbmc/temp (wich is obvioulsy read-writable for pi user.)

I hope this will help you to help us.
find quote
Merdique Offline
Junior Member
Posts: 30
Joined: Feb 2009
Reputation: 0
Post: #201
Hello! I know it's taboo to ask questions and not hail the new subtitle mechanism, but I just wonder, "search by parent folder" will never be implemented again will it?
find quote
tnuc Offline
Junior Member
Posts: 42
Joined: Sep 2014
Reputation: 1
Post: #202
No, not really... Since the focus is on movies that are already loaded in the library and name/season/episode is already abailable to us.
find quote
Post Reply