Wrong Audio stream selected

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
mrpg Offline
Member
Posts: 84
Joined: Sep 2010
Reputation: 0
Post: #1
Dear All,

I Use TVheadend together with XBMC as my frontend for wtahcing TV / Recording.

Recently i have issues where tvheadend records the wrong audio stream.

My XBMC client is set to use English everywhere, as is tvheadend (as far as i can tell anyway, i cannot find any more settings regarding language)

I.e for example, i have three BBC channels, and lately it records Polish audio stream instead of the original English stream ( i live in sweden, and have never entered Polish as my language anywhere)

To try and remedy the problem, i am now using the Beta version of Tvheadend, together with the latest Alpha build of Gotham. (but this has not helped)

Anyone else with similar issues? , or ideas on what i can try to fix this?

Br
Patric
find quote
Prof Yaffle Offline
Donor
Posts: 1,204
Joined: Mar 2011
Reputation: 28
Location: UK - in the middlish (mostly).
Post: #2
Are you recording to .ts? If so, you should have everything as transmitted - including all audio tracks. Have a look at the files and see what audio streams they include (VLC does a good job of telling you, as does mediainfo). You may find that the tracks are badly tagged, or that a default flag is missing for some reason.

tvheadend doesn't really care about the languages, so there's no setting that I'm aware of (unless it appeared recently).
find quote
negge Offline
Team-Kodi Member
Posts: 2,557
Joined: Dec 2010
Reputation: 25
Location: Finland
Post: #3
It should indeed record all audio tracks available. Have you checked that it's not just a matter of having to switch to the correct stream when playing the recording?
find quote
mrpg Offline
Member
Posts: 84
Joined: Sep 2010
Reputation: 0
Post: #4
Sorry forgot about this thread, I record to mkv, I will double check but I am pretty sure it only records one audio stream (it does include all subtitle languages though)
find quote
negge Offline
Team-Kodi Member
Posts: 2,557
Joined: Dec 2010
Reputation: 25
Location: Finland
Post: #5
If so then that's a bug in tvheadend and you should check their bug tracker and report it if it's not there.
find quote