Release - [service.subtitles.opensubtitles]

  Thread Rating:
  • 2 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
calpay2000 Offline
Junior Member
Posts: 1
Joined: Dec 2014
Reputation: 0
Post: #136
Hi guys,

I have a problem about Opensubtitles add-on on my Qnap HS251 XBMC 13.2.0.
The Opensubtitles add on is enabled, searches for the subtitles and finds them.
When I clikc load, it says "Failed to load subtitles"
This is some partf of the Debug.log
23:45:51 T:3597663040 DEBUG: CPythonInvoker(2, /root/.xbmc/addons/service.subtitles.opensubtitles/service.py): setting the Python path to /root/.xbmc/addons/service.subtitles.opensubtitles:/root/.xbmc/addons/script.module.beautifulsoup/lib:/share/CACHEDEV1_DATA/.qpkg/XBMC/opt/xbmc/share/xbmc/addons/script.module.pil/lib:/root/.xbmc/addons/script.module.mechanize/lib:/share/CACHEDEV1_DATA/.qpkg/XBMC/opt/xbmc/share/xbmc/addons/xbmc.debug/:/usr/lib/python2.7:/usr/lib/python2.7/plat-i386-linux-gnu:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload:/usr/local/lib/python2.7/dist-packages:/usr/lib/python2.7/dist-packages:/usr/lib/python2.7/dist-packages/PILcompat:/usr/lib/pymodules/python2.7
23:45:51 T:3597663040 DEBUG: CPythonInvoker(2, /root/.xbmc/addons/service.subtitles.opensubtitles/service.py): entering source directory /root/.xbmc/addons/service.subtitles.opensubtitles
23:45:51 T:3597663040 DEBUG: CPythonInvoker(2, /root/.xbmc/addons/service.subtitles.opensubtitles/service.py): instantiating addon using automatically obtained id of "service.subtitles.opensubtitles" dependent on version 2.1.0 of the xbmc.python api
23:45:51 T:3597663040 DEBUG: ### [__main__] - failed to connect to service for subtitle download
23:45:51 T:3858758464 DEBUG: WaitOnScriptResult- plugin returned successfully
23:45:51 T:3597663040 INFO: CPythonInvoker(2, /root/.xbmc/addons/service.subtitles.opensubtitles/service.py): script successfully run
23:45:51 T:4110592320 DEBUG: ------ Window Init (DialogKaiToast.xml) ------

What may be the problem?
I have the whole debug.log file but didn't find a place to upload it to this post.

Cem
find quote
jumle Offline
Junior Member
Posts: 1
Joined: Dec 2014
Reputation: 0
Post: #137
Hi everybody!

I'm on openelec 4.2.1 (XBMC 13.2) on Raspberry Pi, and I've suddenly lost functionality on the opensubtitles add-on, that I use all the time.
Its very frustrating, as the add-on show up fine (and I tried both the old way and adding as a subtitle service; the new way), but it won't download and enable. Anybody have a clue whats wrong?? Its a completely fresh install and it has no troubles with other services like subscene.com f.e…

Heeeeeeeelp!

Sad
find quote
darthdiablo Offline
Senior Member
Posts: 129
Joined: Apr 2012
Reputation: 0
Post: #138
Debug log: http://pastebin.com/TWhs6saT

Any ideas what I'm doing wrong here? The subtitle file for some reason only gets saved to /tmp folder of the opensubtitle addon, it seems to be unable to add file next to the mkv file on NAS server.

Edit: NVM, found the problem. Have no idea how the folder was set as 755 instead of 777, I set it to chmod 777 and now the addon is able to write to that folder, problem solved.
(This post was last modified: 2014-12-22 03:32 by darthdiablo.)
find quote
Post Reply