Windows - My music library stopped updating?

  Thread Rating:
  • 1 Vote(s) - 1 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Breakerfall Offline
Junior Member
Posts: 42
Joined: Nov 2013
Reputation: 0
Location: New England, USA
Post: #1
Not sure how it happened but I had all my flac files scraped but now only a handful show up. I have tried a few different skins with no success. I mostly use Confluence and Windows.

I have update the library checked. I also have it unchecked so that it wouldn’t hide the updates. I see that it scans my movies, etc. I also tried a reinstall of Frodo but still having the same problem.

Any suggestions for next steps?

Thanks.
find quote
thrak76 Offline
Moderator
Posts: 1,524
Joined: Mar 2011
Reputation: 26
Location: Lake Michigan Shoreline
Post: #2
Corrupted database? Try deleting (back it up first!) the database from your userdata/database folder, and then rescan your music library.

Quick Links: debug log (wiki) | userdata (wiki) | advancedsettings (wiki) | adding videos to the library (wiki)
find quote
Breakerfall Offline
Junior Member
Posts: 42
Joined: Nov 2013
Reputation: 0
Location: New England, USA
Post: #3
Hmmm.... I don't seem to have a database folder in the user data file under XBMC.
find quote
thrak76 Offline
Moderator
Posts: 1,524
Joined: Mar 2011
Reputation: 26
Location: Lake Michigan Shoreline
Post: #4
http://wiki.xbmc.org/index.php?title=Userdata

Quick Links: debug log (wiki) | userdata (wiki) | advancedsettings (wiki) | adding videos to the library (wiki)
find quote
Breakerfall Offline
Junior Member
Posts: 42
Joined: Nov 2013
Reputation: 0
Location: New England, USA
Post: #5
Reading the Wiki, it says that I should have a database with folders such as “MyMusic”, “MyVideos”, etc but I don’t have anything , including the database folder itself. But tv shows, movies, are all scanning and storing what I have watched. Doesn’t seem to be much in the user data file at all.

Should I backup and delete the file entire User Data file and just let XBMC try to rebuild everything??

I did do a reinstall of XBMC but would think there should be something under database.

Thanks!
(This post was last modified: 2014-02-26 23:33 by Breakerfall.)
find quote
thrak76 Offline
Moderator
Posts: 1,524
Joined: Mar 2011
Reputation: 26
Location: Lake Michigan Shoreline
Post: #6
(2014-02-26 23:10)Breakerfall Wrote:  Doesn’t seem to be much in the user data file at all.

That's because you're looking in the wrong place. The userdata folder is not in c:\program files (x86)\XBMC\. The wiki shows quite clearly near the top, before even scrolling, that the userdata folder is in %appdata%\XBMC\userdata\. You might not know that %appdata% means: c:\users\"you"\appdata\roaming\. You may have to change your folder options to show hidden files and folders.

There in that directory you will find XBMC\userdata\databases. I promise you that there will be .db files in that directory.

Quick Links: debug log (wiki) | userdata (wiki) | advancedsettings (wiki) | adding videos to the library (wiki)
(This post was last modified: 2014-02-27 07:21 by thrak76.)
find quote
Breakerfall Offline
Junior Member
Posts: 42
Joined: Nov 2013
Reputation: 0
Location: New England, USA
Post: #7
Your correct, I didn't know what %appdata% was. Thanks.

I found two MyMusic db files, backed them up and deleted. I tried scanning my library again by hitting C and updating, but it still doesn't do anything. I do see a new MyMusic32.db file was created but I still don't have anything in my library.

Other suggestions please??
(This post was last modified: 2014-02-28 20:35 by Breakerfall.)
find quote
thrak76 Offline
Moderator
Posts: 1,524
Joined: Mar 2011
Reputation: 26
Location: Lake Michigan Shoreline
Post: #8
If you deleted the db files, then you have to add the music source again from the files menu, set the content and scraper, and then let xbmc scrape.

Quick Links: debug log (wiki) | userdata (wiki) | advancedsettings (wiki) | adding videos to the library (wiki)
find quote
Breakerfall Offline
Junior Member
Posts: 42
Joined: Nov 2013
Reputation: 0
Location: New England, USA
Post: #9
Of course - I should have known that.

Thanks for your help thrak76!
find quote