How to compile vdr + vnsiserver from source

  Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
charlie0440 Offline
Fan
Posts: 423
Joined: Dec 2011
Reputation: 8
Post: #61
I have removed it. Still not working

syslog -> http://paste.ubuntu.com/13508369/

runvdr -> http://paste.ubuntu.com/13508378/

Its must have been my channels.conf or settings

1st log had this issue so I remove the use of picons - > http://xbmclogs.com/pedtzxejw

Code:
AddOnLog: VDR VNSI Client: Logged in at '1448494497+0' to 'VDR-Network-Streaming-Interface (VNSI) Server' Version: '1.3.1' with protocol version '8'
23:34:57 T:140081155270400   ERROR: SQL: Abort due to constraint violation
                                            Query: INSERT INTO channels (iUniqueId, bIsRadio, bIsHidden, bIsUserSetIcon, bIsUserSetName, bIsLocked, sIconPath, sChannelName, bIsVirtual, bEPGEnabled, sEPGScraper, iLastWatched, iClientId, idEpg) VALUES (53483305, 1, 0, 0, 0, 0, '/storage/downloads/hd.transparent-black_2014-09-02--00-00-01/tv/1_0_2_258D_7FB_2_11A0000_0_0_0.png', 'RTE R na G', 0, 1, 'client', 0, 16428, -1)
23:34:57 T:140081155270400   ERROR: CommitInsertQueries - failed to execute queries
23:34:57 T:140081155270400   ERROR: SQL: Abort due to constraint violation
                                            Query: INSERT INTO channels (iUniqueId, bIsRadio, bIsHidden, bIsUserSetIcon, bIsUserSetName, bIsLocked, sIconPath, sChannelName, bIsVirtual, bEPGEnabled, sEPGScraper, iLastWatched, iClientId, idEpg) VALUES (53483305, 1, 0, 0, 0, 0, '/storage/downloads/hd.transparent-black_2014-09-02--00-00-01/tv/1_0_2_258D_7FB_2_11A0000_0_0_0.png', 'RTE R na G', 0, 1, 'client', 0, 16428, -1)
23:34:57 T:140081155270400   ERROR: CommitInsertQueries - failed to execute queries
23:34:57 T:140081155270400   ERROR: SQL: Abort due to constraint violation
                                            Query: INSERT INTO channels (iUniqueId, bIsRadio, bIsHidden, bIsUserSetIcon, bIsUserSetName, bIsLocked, sIconPath, sChannelName, bIsVirtual, bEPGEnabled, sEPGScraper, iLastWatched, iClientId, idEpg) VALUES (53483305, 1, 0, 0, 0, 0, '/storage/downloads/hd.transparent-black_2014-09-02--00-00-01/tv/1_0_2_258D_7FB_2_11A0000_0_0_0.png', 'RTE R na G', 0, 1, 'client', 0, 16428, -1)
23:34:57 T:140081155270400   ERROR: CommitInsertQueries - failed to execute queries
23:34:57 T:140081155270400   ERROR: PVR - Load - failed to load channel groups

2nd log then had channel group erros, so I removed that setting -> http://xbmclogs.com/ppuc3oh7m

working fine now, well without picons, they used to work so I will continue to fiddle

Guide to building an all in one Ubuntu Server - TV(vdr),File,Music,Web

Server Fractal Designs Define XL, Asus P5QL/EPU, Dual Core E5200, 4gb, L4M-Twin S2 v6.2, Supermicro AOC-USAS-L8I, 1*SSD & 13*HDD drives (24TB total) - Ubuntu Server
XBMC 1 ASRock Z77E-ITX, G850, 8GB RAM, SSD, BD - Ubuntu / OpenElec frodo
XBMC 2 Revo 3700 - OpenElec frodo
XBMC 3 Raspb Pi
(This post was last modified: 2015-11-26 02:26 by charlie0440.)
find quote
magicamun Offline
Member
Posts: 50
Joined: Feb 2012
Reputation: 0
Post: #62
I am also stuck at this ...

i cloned Jarvis, built, installed
i cloned platform, make , make install
i cloned kodi-platform, cmake, make , make install:
i fail on pvr cmake....
Code:
[email protected]:/nas/kodi# git clone https://github.com/Pulse-Eight/platform.git platform-master
[email protected]:/nas/kodi# cd platform-master/
[email protected]:/nas/kodi/platform-master# cmake -DCMAKE_INSTALL_PREFIX=/usr/local
-- Configuring done
-- Generating done
-- Build files have been written to: /nas/kodi/platform-master
[email protected]:/nas/kodi/platform-master# make clean
[email protected]:/nas/kodi/platform-master# make && make install
[100%] Building CXX object CMakeFiles/p8-platform.dir/src/util/StringUtils.cpp.o
Linking CXX static library libp8-platform.a
[100%] Built target p8-platform
[100%] Built target p8-platform
Install the project...
-- Install configuration: ""
-- Installing: /usr/local/lib/libp8-platform.a
-- Up-to-date: /usr/local/include/p8-platform/os.h
-- Up-to-date: /usr/local/include/p8-platform/posix/os-socket.h
-- Up-to-date: /usr/local/include/p8-platform/posix/os-threads.h
-- Up-to-date: /usr/local/include/p8-platform/posix/os-types.h
-- Up-to-date: /usr/local/include/p8-platform/sockets/cdevsocket.h
-- Up-to-date: /usr/local/include/p8-platform/sockets/socket.h
-- Up-to-date: /usr/local/include/p8-platform/sockets/tcp.h
-- Up-to-date: /usr/local/include/p8-platform/threads/atomics.h
-- Up-to-date: /usr/local/include/p8-platform/threads/mutex.h
-- Up-to-date: /usr/local/include/p8-platform/threads/threads.h
-- Up-to-date: /usr/local/include/p8-platform/util/atomic.h
-- Up-to-date: /usr/local/include/p8-platform/util/buffer.h
-- Up-to-date: /usr/local/include/p8-platform/util/StringUtils.h
-- Up-to-date: /usr/local/include/p8-platform/util/StdString.h
-- Up-to-date: /usr/local/include/p8-platform/util/timeutils.h
-- Up-to-date: /usr/local/include/p8-platform/util/util.h
-- Up-to-date: /usr/local/lib/pkgconfig/p8-platform.pc
-- Up-to-date: /usr/local/lib/p8-platform/p8-platform-config.cmake

Cloned and installed kodi-platform
Code:
[email protected]:/nas/kodi# git clone https://github.com/xbmc/kodi-platform.git
[email protected]:/nas/kodi# cd kodi-platform/
[email protected]:/nas/kodi/kodi-platform# cmake -DCMAKE_INSTALL_PREFIX=/usr/local
[email protected]:/nas/kodi/kodi-platform# cmake -DCMAKE_INSTALL_PREFIX=/usr/local
-- Configuring done
-- Generating done
-- Build files have been written to: /nas/kodi/kodi-platform
[email protected]:/nas/kodi/kodi-platform# make clean && make && make install
[100%] Building CXX object CMakeFiles/kodiplatform.dir/src/util/XMLUtils.cpp.o
Linking CXX shared library libkodiplatform.so
[100%] Built target kodiplatform
[100%] Built target kodiplatform
Install the project...
-- Install configuration: ""
-- Installing: /usr/local/lib/libkodiplatform.so.16.0.0
-- Up-to-date: /usr/local/lib/libkodiplatform.so.16.0
-- Up-to-date: /usr/local/lib/libkodiplatform.so
-- Up-to-date: /usr/local/include/kodi/util/XMLUtils.h
-- Up-to-date: /usr/local/lib/pkgconfig/kodiplatform.pc
-- Up-to-date: /usr/local/lib/kodiplatform/kodiplatform-config.cmake
[email protected]:/nas/kodi/kodi-platform# cmake -DCMAKE_INSTALL_PREFIX=/usr/local
-- Configuring done
-- Generating done
-- Build files have been written to: /nas/kodi/kodi-platform
[email protected]:/nas/kodi/kodi-platform# make clean && make && make install
[100%] Building CXX object CMakeFiles/kodiplatform.dir/src/util/XMLUtils.cpp.o
Linking CXX shared library libkodiplatform.so
[100%] Built target kodiplatform
[100%] Built target kodiplatform
Install the project...
-- Install configuration: ""
-- Installing: /usr/local/lib/libkodiplatform.so.16.0.0
-- Up-to-date: /usr/local/lib/libkodiplatform.so.16.0
-- Up-to-date: /usr/local/lib/libkodiplatform.so
-- Up-to-date: /usr/local/include/kodi/util/XMLUtils.h
-- Up-to-date: /usr/local/lib/pkgconfig/kodiplatform.pc
-- Up-to-date: /usr/local/lib/kodiplatform/kodiplatform-config.cmake
[email protected]:/nas/kodi/kodi-platform# cmake -DCMAKE_INSTALL_PREFIX=/usr/local
-- Configuring done
-- Generating done
-- Build files have been written to: /nas/kodi/kodi-platform

and now pvr....:
Code:
[email protected]:/nas/kodi/kodi-platform# cd ..
[email protected]:/nas/kodi# cd Jarvis/pvr.vdr.vnsi/
[email protected]:/nas/kodi/Jarvis/pvr.vdr.vnsi# cmake -DCMAKE_INSTALL_PREFIX=/usr/local
CMake Error at CMakeLists.txt:11 (find_package):
  By not providing "Findplatform.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "platform",
  but CMake did not find one.

  Could not find a package configuration file provided by "platform" with any
  of the following names:

    platformConfig.cmake
    platform-config.cmake

  Add the installation prefix of "platform" to CMAKE_PREFIX_PATH or set
  "platform_DIR" to a directory containing one of the above files.  If
  "platform" provides a separate development package or SDK, be sure it has
  been installed.


-- Configuring incomplete, errors occurred!
See also "/nas/kodi/Jarvis/pvr.vdr.vnsi/CMakeFiles/CMakeOutput.log".
[email protected]:/nas/kodi/Jarvis/pvr.vdr.vnsi#

kodi0 Asus M4A77D, Borg HFX 4GB, 2 * TT S2-3200, GeForce 9500 GT 1GB Borg FX VGA), kodi 13.1, vdr 2.1.8, vnsi, streamdev, markad, xxxapi, mcubed HFX Classic, FB: Mediagate GP-IRO2BK, Logitech diNovoEdge
kodi1 Asrock D1300M (BORG Hfx), 2GB, Tevii S371, kodi 14.1, vdr 2.1.8, vnsi,streamdev, markad, xxxapi, HFX mini, Remote: Mediagate GP-IRO2BK
find quote
FernetMenta Online
Team-Kodi Developer
Posts: 5,662
Joined: Jul 2010
Reputation: 116
Location: Munich
Post: #63
I guess you are in the wrong thread. This thread is about compiling vdr and vdr-plugin-vnsiserver
find quote
billfreeman Offline
Junior Member
Posts: 3
Joined: Apr 2016
Reputation: 0
Post: #64
Thanks for this guide but I am having issues getting things to work.

Firstly, whenever I use any of the commands that contain the ~ character I am always greeted with a no such file or directory error.

So I have simply left this out and navigated manually.

Then next area that gave me an issue was in step 7.

cp PLUGINS/src/vnsiserver/vnsiserver/allowed_hosts.conf /var/vdr/plugins/vnsiserver

This always returns a no such file or directory error.

So I found a copy of allowed_hosts.conf from another folder and copied it to the appropriate folder.

The command in step 8 also gave me the same error, so again I copied it from another location.

Step 10 confuses me as it says Autostart VDR but not sure if there should be a procedure to do this.

So as far as I can see, I have all the right things in place.

The only problem is that after a reboot I can't seem to be able to do anything to get TV channels on Kodi.

Reading through the thread I noticed that a user was asked to check whether sudo start vdr works, so I tried this but I just get a command not found error.

I've double checked all the configurations files are in the right place and have the correct information but am baffled as to what may be wrong or what I am doing that is wrong.
(This post was last modified: 2016-05-22 00:38 by billfreeman.)
find quote
FernetMenta Online
Team-Kodi Developer
Posts: 5,662
Joined: Jul 2010
Reputation: 116
Location: Munich
Post: #65
Quote:Step 10 confuses me as it says Autostart VDR but not sure if there should be a procedure to do this.

This step is outdated for newer versions of Ubuntu and other Linux distros. Upstart is dead and was superseded by systemd
find quote
Post Reply