Mac OS X - 24p Audio playback broken? Desperately seeking help...!

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
WilliamG Offline
Junior Member
Posts: 31
Joined: Oct 2008
Reputation: 0
Post: #1
So I'm enjoying perfect VIDEO on my 2012 Mac mini at 24p, with playback sped up 0.1% using refresh rate matching for 24p material because of OS X's lack of true 24p support. I have the audio settings set to send the 5.1/DTS/PCM audio through to my Denon AVR-3313CI receiver.

However, with video files that have DTS 1.5Mbit audio, I'm getting some glitchy audio. It's really noticeable on music, with little chops/blips in the track the whole time.

If I turn off refresh-rate matching and just play all material at 60hz, the problem goes away. I can't figure out why this setting would affect HDMI passthrough to my receiver at 24p?!

System: 2012 Mac mini running Mountain Lion 10.8.5.

I've tried XBMC 12.3, and the latest 3/31/14 XBMC 13.0 BETA. I've also tried Plex Home Theater 1.0 with EXACTLY the same results (no surprise).

Anyone have any ideas why this would be happening. All help appreciated, because this is killing my movie enjoyment. Sad
find quote
FernetMenta Offline
Team-Kodi Developer
Posts: 3,686
Joined: Jul 2010
Reputation: 73
Location: Munich
Post: #2
For passthrough audio you need to set audio as master for clock if refresh rate does not match fps of video.
find quote
WilliamG Offline
Junior Member
Posts: 31
Joined: Oct 2008
Reputation: 0
Post: #3
(2014-04-05 10:41)FernetMenta Wrote:  For passthrough audio you need to set audio as master for clock if refresh rate does not match fps of video.

What do you mean "master for clock" ? I don't see that setting...

Thanks...

(Also, if I disable HDMI passthrough and let the Mac mini do the decoding internally, I get occasional frame-skips in the video... I don't get frame skips if I pass the audio the receiver to decode, but then I get the audio issues instead. I can't win!)
(This post was last modified: 2014-04-05 10:49 by WilliamG.)
find quote
FernetMenta Offline
Team-Kodi Developer
Posts: 3,686
Joined: Jul 2010
Reputation: 73
Location: Munich
Post: #4
The best setting for the case that refresh rate does not exactly match video fps is:
Sync playback to display" enabled
A/V Sync method = video clock (resample audio)
Passthrough audio disabled

With this setting video can run slightly faster/slower and audio speed is adjusted by resampling.

If you enable passthrough either video or audio frames have to be skipped or duplicated.
find quote
WilliamG Offline
Junior Member
Posts: 31
Joined: Oct 2008
Reputation: 0
Post: #5
(2014-04-05 10:57)FernetMenta Wrote:  The best setting for the case that refresh rate does not exactly match video fps is:
Sync playback to display" enabled
A/V Sync method = video clock (resample audio)
Passthrough audio disabled

With this setting video can run slightly faster/slower and audio speed is adjusted by resampling.

If you enable passthrough either video or audio frames have to be skipped or duplicated.

Thank you for the reply. If I disable passthrough audio, I get a video frame-skip every ~90 seconds, though it DOES vary. How do I fix that? Sad
find quote
FernetMenta Offline
Team-Kodi Developer
Posts: 3,686
Joined: Jul 2010
Reputation: 73
Location: Munich
Post: #6
What did you set a/v sync method to?
find quote
WilliamG Offline
Junior Member
Posts: 31
Joined: Oct 2008
Reputation: 0
Post: #7
(2014-04-05 11:04)FernetMenta Wrote:  What did you set a/v sync method to?

Video clock (resample audio).
find quote
FernetMenta Offline
Team-Kodi Developer
Posts: 3,686
Joined: Jul 2010
Reputation: 73
Location: Munich
Post: #8
please post a debug log.
find quote
WilliamG Offline
Junior Member
Posts: 31
Joined: Oct 2008
Reputation: 0
Post: #9
(2014-04-05 12:06)FernetMenta Wrote:  please post a debug log.


http://wiki.xbmc.org/index.php?title=Log_file/Easy

I'll do this later today. Can you explain why I have no issues except with some audio, using passthrough setting?
(This post was last modified: 2014-04-05 18:32 by WilliamG.)
find quote
WilliamG Offline
Junior Member
Posts: 31
Joined: Oct 2008
Reputation: 0
Post: #10
(2014-04-05 12:06)FernetMenta Wrote:  please post a debug log.

Hey, quick question: What do you want a debug log of? The frame-skip when my Mac mini is set to do the Dolby/DTS decoding internally? Or a log of the glitching audio? Do those things even get logged?

Thanks again..
find quote
FernetMenta Offline
Team-Kodi Developer
Posts: 3,686
Joined: Jul 2010
Reputation: 73
Location: Munich
Post: #11
Only debug logs are of interest. Play a sample with passthrough for a while, then with above mentioned settings.
find quote
beemarp Offline
Member
Posts: 71
Joined: Mar 2012
Reputation: 0
Location: Oklahoma
Post: #12
I dealt with this same problem until I decided to downgrade my 2011 Mac Mini to Snow Leopard. I also ditched HDMI for audio, and use optical only. Doesn't really matter since OSX can't output HD audio anyway.

I don't notice any dropped frames or audio glitches anymore with XBMC 12.3

XBMC and Mac Mini is an extremely finicky relationship, IMO.

Mac Mini 2011 5,1 2.3ghz i5 OSX 10.6.8, Snow Leopard
XBMC 12.3
find quote
beemarp Offline
Member
Posts: 71
Joined: Mar 2012
Reputation: 0
Location: Oklahoma
Post: #13
Also, you might try resetting the PRAM on your mini. http://support.apple.com/kb/ph11243

Just a shot in the dark...

Mac Mini 2011 5,1 2.3ghz i5 OSX 10.6.8, Snow Leopard
XBMC 12.3
find quote
WilliamG Offline
Junior Member
Posts: 31
Joined: Oct 2008
Reputation: 0
Post: #14
(2014-04-08 19:43)beemarp Wrote:  Also, you might try resetting the PRAM on your mini. http://support.apple.com/kb/ph11243

Just a shot in the dark...

I had a friend test on his 2012 Mac mini, and he has the same issue. So, alas, that won't work.

I'll be doing some more tests later. Thanks again for the replies.
find quote