Different versions of the same Addon?

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
dknlght Offline
Fan
Posts: 472
Joined: Nov 2007
Reputation: 9
Post: #1
Ok, so with the release of Gotham, a lot of the people who upgraded can't install my addon because of the incompatible message. I know how to change it to get it to be compatible but I still want to keep another version that is compatible with Eden because I still have a lot of users still using this version. So the question is how do I do that? I know this is possible because awhile back when Frodo came out the youtube addon had different version for different xbmc platforms. I want to be able to have a version compatible with Eden show up when they're browsing my repo in Eden and the same for when they are using Gotham.

though donation is not necessary but just in case you want to: Donate Here
find quote
pkscout Offline
Posting Freak
Posts: 1,103
Joined: Jan 2011
Reputation: 23
Location: Honolulu, HI
Post: #2
Are you using the official repo? I think what you need to do is submit a pull request and designate it for Gotham only. Bump the version number to something larger than what you have on Frodo (e.g. 1.7 for Frodo, 2.0 for Gotham). Then do a separate pull request for the Frodo branch with the correct version number.

If you're doing your own repo, I'm not sure how you designate a chunk of the repo for Frodo versus Gotham.

If you're using any kind of versioning system, it might be easier to create a branch for Frodo and one for Gotham (or use master for Gotham, which is what I do).
(This post was last modified: 2014-05-07 22:33 by pkscout.)
find quote
dknlght Offline
Fan
Posts: 472
Joined: Nov 2007
Reputation: 9
Post: #3
(2014-05-07 22:32)pkscuot Wrote:  Are you using the official repo? I think what you need to do is submit a pull request and designate it for Gotham only. Bump the version number to something larger than what you have on Frodo (e.g. 1.7 for Frodo, 2.0 for Gotham). Then do a separate pull request for the Frodo branch with the correct version number.

If you're doing your own repo, I'm not sure how you designate a chunk of the repo for Frodo versus Gotham.

If you're using any kind of versioning system, it might be easier to create a branch for Frodo and one for Gotham (or use master for Gotham, which is what I do).

Yes, I do have my own repo but as for creating another branch that's fine but how to do I make so that both version can be installed from the same repository?

here's what I'm looking NOT to do
1. Create two separate repository where users now have to install a different one than the one they currently have.
2. Rename the addon slightly so that both can exist in the same addon, but this means users who have the addon already installed but upgrade to Gotham wouldn't get the gotham version updates unless they installed it.

Essentially I was just wondering if there was a format in the repo addon.xml that will allow me have two addons with the same addonid but specify different versions of xbmc to install for.

since you mention that this can be done with the official repo that probably explain how the youtube addon was able to have different versions available. If it can't be done I'll probably have to the do the second approach

though donation is not necessary but just in case you want to: Donate Here
find quote