Shuttering problems Mavericks

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Tiff_Needle Offline
Junior Member
Posts: 7
Joined: Nov 2011
Reputation: 0
Post: #1

I've been having a problem with my OSX setup ever since I've upgraded do Mavericks that is really staring to angry me.

I'll explain...

Setup is a Mac mini with Mavericks and all files are in a network drive.

With the previous operating system, lion, I had no problems at all!

This as been a more than discussed topic on various forums but I honestly haven't quite figured out how to solve this.

By now most of us know that mavericks brought, amongst other things, problems with samba. It no uses samba 2.

I've read so many workaround suggestions from forcing to smb1...well a lot of suggestions really.

The last one I've tried is forcing the connection to my network drive, that is mounting the drive, with CIFS.

And honestly it as proven to be the best option of all reducing quite a bit the shuttering problems.

Nevertheless I keep unable to see a movie, the higher the resolution the worse, without any playback interruption.

Any of you have suggestions? Should I look for how to augment the buffering size?

I'm really fed up with this as I had a setup that worked perfectly ok before and now it doesn't!

Forgot to mention, I'm using the latest versions of XBMC. No nightly builds. "Only" the version 13.0 Gotham
(This post was last modified: 2014-05-31 00:16 by Tiff_Needle.)
find quote
SushiMo Offline
Junior Member
Posts: 11
Joined: Mar 2012
Reputation: 0
Post: #2
have you tried to manage your samba shares with SMBUp ?
it disables the os x build in samba and installs samba3

i'm running it since i setup mountain lion (currently mavericks 10.9.3) and it works great.
find quote
Tiff_Needle Offline
Junior Member
Posts: 7
Joined: Nov 2011
Reputation: 0
Post: #3

I'll give it a try and let you know my findings.
find quote
Aonoa Offline
Posts: 66
Joined: Oct 2011
Reputation: 0
Post: #4
I am having buffering issues as well with samba shares, but I think it is XBMC's fault and not Mavericks. It started for me with one of the upgrades to XBMC 13. If you also look at this thread: someone else did a workaround by mounting the shares as volumes and using those volumes to bypass XBMC's samba code.

Trying different network buffering settings in advancedsettings.xml have so far been of no help.

I would very much like to see this fixed. I will provide a debug log when next I have the time.
(This post was last modified: 2014-06-02 12:22 by Aonoa.)
find quote
Tiff_Needle Offline
Junior Member
Posts: 7
Joined: Nov 2011
Reputation: 0
Post: #5
still having problems.... I'm now using CIFS instead of samba... although it got a lot better. the issue is still there.

Even with SD content!

I'm tired of this. I used to have a great experience with XBMC and OSx, now it's crap.

Can anyone help me?

I've used CIFS to connect to my network drive and I chosen XBMC to access via volumes.

Forgot to mention that I'm running gotham 13.1 on mavericks
(This post was last modified: 2014-06-22 18:02 by Tiff_Needle.)
find quote
Waltman Offline
Senior Member
Posts: 215
Joined: Dec 2012
Reputation: 4
Location: the Netherlands
Post: #6
Although there can me may reasons like hardware, network connections, routers etc i am going to assume thats okay.

My advise try NFS. I switched to NFS, mainly because of the "osx mavericks / synology samba situation" and because i have a raspberry pi in my network. I use cabled connections and i mount the NFS shares on my htpc a mac mini. XBMC connects to the sources with the build in NFS network option and all is working perfect under mavericks.
(This post was last modified: 2014-06-22 23:19 by Waltman.)
find quote
Memphiz Offline
Kodi MVP
Posts: 15,637
Joined: Feb 2011
Reputation: 213
Location: germany
Post: #7
read and try buffermode1 (this will buffer all filesystems - as you are using osx layer mounts xbmc doesn't know that the filesystem is on a network - so it won't buffer it - buffermode 1 will fix this). Also use readbufferfactor 4 and increase the cachemembuffersize to something like 60MB or so ... feedback with those changes would be welcome.

Also cifs is the same like samba imo ...

AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
find quote