Release - [SteamOS] Kodi repository

  Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
wsnipex Offline
Team-Kodi Member
Posts: 4,941
Joined: Jun 2011
Reputation: 115
Post: #106
(2015-05-13 05:32)calibos Wrote:  Are AMD GPU's still not supported? Typical! Have 6 Arctic MC001's with Atom D525 and AMD mobile GPU's inside and was hoping to add SteamOS once I build my new Media server and add IHS. The atoms will melt with software decode whereas these machines are fine for 1080 video with Vanilla Kodi.

the radeon OSS driver works fine, but it depends if steamOS has new enough kernel and mesa for your GPU. Fglrx is not supported for hardware acceleration.
find quote
wsnipex Offline
Team-Kodi Member
Posts: 4,941
Joined: Jun 2011
Reputation: 115
Post: #107
(2015-06-15 09:22)Vash63 Wrote:  I'm not the greatest at Debian based systems so I might be doing something wrong, but I've had this installed for months and it's still on 14.1 even after an 'aptitude full-upgrade'. Is this repository still maintained?

the motherboard in my SteamOS machine broke and its non trivial to replace. So sadly I can't update the repo,
find quote
DanCooper Online
Moderator
Posts: 2,151
Joined: Apr 2012
Reputation: 99
Location: Switzerland
Post: #108
Is it possible to install DVBViewer pvr addon? If yes, how?

Edit: ok, linux noob jas found the way :-)
Code:
sudo apt-get install kodi-pvr-dvbviewer
(This post was last modified: 2015-06-22 23:45 by DanCooper.)
find quote
Vash63 Offline
Junior Member
Posts: 8
Joined: Jan 2014
Reputation: 0
Post: #109
(2015-06-15 14:52)wsnipex Wrote:  
(2015-06-15 09:22)Vash63 Wrote:  I'm not the greatest at Debian based systems so I might be doing something wrong, but I've had this installed for months and it's still on 14.1 even after an 'aptitude full-upgrade'. Is this repository still maintained?

the motherboard in my SteamOS machine broke and its non trivial to replace. So sadly I can't update the repo,

That's too bad, especially with the update to SteamOS 2.0 / Debian 8.1. I've never built Debian packages before but might give it a try.
find quote
Vash63 Offline
Junior Member
Posts: 8
Joined: Jan 2014
Reputation: 0
Post: #110
Ugh. Tried to get the Jessie repo added into SteamOS, tons of dependency issues though trying to get to the point where I could even run the ./configure script. libass requires libharfbuzz which is already installed but at a newer version and apt refuses to install it without removing other packages... hope to see this come back at some point though.
find quote
ercete Offline
Junior Member
Posts: 3
Joined: Jul 2015
Reputation: 0
Post: #111
Bonjour SteamOS & Kodi users

I just reinstalled my SteamBox (GB-BXCE-2955 - Gigabyte) with the last fresh brewmaster beta of steamos.

The HowTo helped me install Xbmc/Kodi on my previous install.

But with this new one it is a bit harder, after following every step of the howto, the kodi install gave me these errors :

Code:
desktop@steamos:/etc/apt$ sudo apt-get install kodi
[sudo] password for desktop:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kodi : Depends: kodi-bin (>= 2:14.1~git20150131.1014-38e4046-0) but it is not going to be installed
        Depends: kodi-bin (< 2:14.1~git20150131.1014-38e4046-0.1~) but it is not going to be installed
        Depends: python-imaging but it is not going to be installed
        Depends: libaacs0 but it is not going to be installed
        Depends: libcec2 (>= 2.2.0) but it is not going to be installed
        Depends: libgnutls26 but it is not installable or
                 libgnutls28 but it is not installable
E: Unable to correct problems, you have held broken packages.

I admit that I do not understand how Debian/SteamOS handle its packets,
(I used to work with gentoo before) so I came here to find some help...
find quote
Vash63 Offline
Junior Member
Posts: 8
Joined: Jan 2014
Reputation: 0
Post: #112
Just to update this, I was finally able to get this working by manually configuring and compiling it. Had to add a custom repo to get ffmpeg and of course the Jessie repo which I've had installed for some time but it's working great now. I had to add a few deps that weren't in the Debian guide but other than that all I did was comment out the --enable-libcec in the configure, then bootstrap, configure, and make install and all went smoothly.

Unfortunately make checkinstall didn't work for me, I'm not great with Debian but I know that's generally better for building an easily manageable package. Oh well, if this breaks I can just wipe it at any time, Steam cloud syncs all of its files and my Kodi config is on an external mariadb database.

(2015-07-19 21:43)ercete Wrote:  Bonjour SteamOS & Kodi users

I just reinstalled my SteamBox (GB-BXCE-2955 - Gigabyte) with the last fresh brewmaster beta of steamos.

The HowTo helped me install Xbmc/Kodi on my previous install.

But with this new one it is a bit harder, after following every step of the howto, the kodi install gave me these errors :

Code:
desktop@steamos:/etc/apt$ sudo apt-get install kodi
[sudo] password for desktop:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kodi : Depends: kodi-bin (>= 2:14.1~git20150131.1014-38e4046-0) but it is not going to be installed
        Depends: kodi-bin (< 2:14.1~git20150131.1014-38e4046-0.1~) but it is not going to be installed
        Depends: python-imaging but it is not going to be installed
        Depends: libaacs0 but it is not going to be installed
        Depends: libcec2 (>= 2.2.0) but it is not going to be installed
        Depends: libgnutls26 but it is not installable or
                 libgnutls28 but it is not installable
E: Unable to correct problems, you have held broken packages.

I admit that I do not understand how Debian/SteamOS handle its packets,
(I used to work with gentoo before) so I came here to find some help...

Interesting, something must have changed. Last time I checked kodi wasn't even getting that far. aptitude install kodi was able to resolve the dependencies for me this time though, maybe I'll try that on the next update.
find quote
ercete Offline
Junior Member
Posts: 3
Joined: Jul 2015
Reputation: 0
Post: #113
Quote:Interesting, something must have changed. Last time I checked kodi wasn't even getting that far. aptitude install kodi was able to resolve the dependencies for me this time though, maybe I'll try that on the next update.

I only tested with apt-get, not aptitude, I tought that it was doing the same job but I'll give it a try this evening.
I think I'll have to dig a bit dependency & repo system on debian...
find quote
Vash63 Offline
Junior Member
Posts: 8
Joined: Jan 2014
Reputation: 0
Post: #114
(2015-07-21 08:50)ercete Wrote:  
Quote:Interesting, something must have changed. Last time I checked kodi wasn't even getting that far. aptitude install kodi was able to resolve the dependencies for me this time though, maybe I'll try that on the next update.

I only tested with apt-get, not aptitude, I tought that it was doing the same job but I'll give it a try this evening.
I think I'll have to dig a bit dependency & repo system on debian...

Found it, apt-get wasn't your problem. Checked with apt-cache and it turns out my packages were getting pulled from deb-multimedia.org, which I installed to get ffmpeg when I was manually compiling everything earlier. Turns out it also packages a working Kodi 14.2.
find quote
wsnipex Offline
Team-Kodi Member
Posts: 4,941
Joined: Jun 2011
Reputation: 115
Post: #115
you don't need ffmpeg, its included in kodi. Using any other version then our own is unsupported.
find quote
Vash63 Offline
Junior Member
Posts: 8
Joined: Jan 2014
Reputation: 0
Post: #116
(2015-07-22 10:21)wsnipex Wrote:  you don't need ffmpeg, its included in kodi. Using any other version then our own is unsupported.

Strange, it wouldn't configure until I had it installed and failed right after the checking for ffmpeg line.
find quote
wsnipex Offline
Team-Kodi Member
Posts: 4,941
Joined: Jun 2011
Reputation: 115
Post: #117
then you did something wrong. OUR ffmpeg is downloaded and built automatically during configure.
find quote
ercete Offline
Junior Member
Posts: 3
Joined: Jul 2015
Reputation: 0
Post: #118
Bonjour everyone,

Stilll in fight installing kodi on last steamos brewmaster.
As suggested, I installed deb-multimedia.org sources. Did apt-get update and :

Code:
desktop@steamos:~/Downloads$ sudo apt-get install kodi
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kodi : Depends: kodi-bin (>= 5:14.2+repack-dmo1b1) but it is not going to be installed
        Depends: kodi-data (>= 5:14.2+repack-dmo1b1)
E: Unable to correct problems, you have held broken packages.
Code:
desktop@steamos:~/Downloads$ sudo apt-get install kodi-bin
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kodi-bin : Depends: libavcodec56 (>= 10:2.6.2) but 6:11.4-1~deb8u1+bsos1 is to be installed
            Depends: libavfilter5 (>= 10:2.6.2) but 6:11.4-1~deb8u1+bsos1 is to be installed
            Depends: libavformat56 (>= 10:2.6.2) but 6:11.4-1~deb8u1+bsos1 is to be installed
            Depends: libavutil54 (>= 10:2.6.2) but 6:11.4-1~deb8u1+bsos1 is to be installed
            Depends: libpostproc53 (>= 10:2.6.2) but it is not going to be installed
            Depends: libsdl2-2.0-0 (>= 2.0.0) but it is not installable
            Depends: libswresample1 (>= 10:2.6.2) but it is not going to be installed
            Depends: libswscale3 (>= 10:2.6.2) but 6:11.4-1~deb8u1+bsos1 is to be installed
            Recommends: libbluray1 (>= 0.3.0~) but it is not going to be installed
            Recommends: libhdhomerun1 but it is not installable
            Recommends: libmad0 (>= 0.15.1b-3) but it is not going to be installed
            Recommends: libmp3lame0 (>= 1:3.99.0) but 3.99.5+repack1-7+bsos3 is to be installed
            Recommends: libmpeg2-4 (>= 0.5.1) but it is not installable
            Recommends: libnfs8 but it is not going to be installed
            Recommends: libshairplay0 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


A quick look at
Code:
desktop@steamos:~/Downloads$ apt-cache policy kodi
kodi:
  Installed: (none)
  Candidate: 5:14.2+repack-dmo1b1
  Version table:
     5:14.2+repack-dmo1b1 0
        500 http://www.deb-multimedia.org/ jessie/main amd64 Packages
     2:14.1~git20150131.1014-38e4046-0 0
        500 http://mirrors.xbmc.org/apt/steamos/ alchemist/main amd64 Packages

Let's try to force the topic's version :
Code:
desktop@steamos:~/Downloads$ sudo apt-get install kodi="2:14.1~git20150131.1014-38e4046-0"
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kodi : Depends: kodi-bin (>= 2:14.1~git20150131.1014-38e4046-0) but it is not going to be installed
        Depends: kodi-bin (< 2:14.1~git20150131.1014-38e4046-0.1~) but it is not going to be installed
        Depends: python-imaging but it is not going to be installed
        Depends: libgnutls26 but it is not installable or
                 libgnutls28 but it is not installable
E: Unable to correct problems, you have held broken packages.

Still no result...
All the dependencies met with kodi-bin are kind of chinese for me...
I'm taking any advice...

(This morning hasn't been a complete fail because I can now power on my brix with my xbox controller... just wanted to share it with you \o/ )
find quote
wsnipex Offline
Team-Kodi Member
Posts: 4,941
Joined: Jun 2011
Reputation: 115
Post: #119
Quote:As suggested, I installed deb-multimedia.org sources

not suggested at all. Install all build dependencies and compile kodi from source.
find quote
Post Reply