Mac OS X - N64 emulator params problem in Mavericks - game not launching

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
evillevi Offline
Junior Member
Posts: 32
Joined: Jan 2013
Reputation: 0
Post: #1
Hello everyone

I have XBMC (Gotham) + Rom Collection Browser + emulators all set up on my Macbook Pro running Mountain Lion, everything works fine.
I also have RCB in XBMC (OSX) on my late 2009 Mac Mini, running Mavericks. However, for N64 games, it will only launch the emulator (Sixtyforce). It will not load the game itself.

To make sure this was not caused by the folder path structure, I set up both RCBs to launch roms from the same remote folder on my NAS.
It still didn't work on the Mac Mini.

So, to rule out the possibility of the operating system causing this, I checked with Terminal.
On my Macbook Pro the command open -a /Applications/ /Volumes/Data/Games/Nintendo/N64/Roms/starfox64.v64 launches the game.
On the Mac Mini, it does not. It only launches the programme.

If I launch the emulator app Sixtyforce on the Mac Mini, and open a rom file from the menu, the game WILL load.

I tried Mednafen, this seems to work, but not with N64 games (only launches the emulator).

Do I have to use a different string of emulator parameters in RCB's config.xml file with Mavericks?
I am not familiar with other emulators, and I am a complete noob when it comes to emulator parameters. In the config.xml file I only use the emulator command: open, and emulator parameter: -a /Applications/ "%ROM%"
This seems to work on my laptop.

What am I doing wrong? Do I have to try switching back to Mountain Lion and check? Am I using the wrong version of XBMC for OSX (OSX vs X86)? Am I forgetting something?

Since Terminal is not launching the game, it probably does not have anything to do with XBMC, but I hope you guys can help me out.

(This post was last modified: 2014-07-14 13:30 by evillevi.)
find quote
Memphiz Offline
Kodi MVP
Posts: 15,639
Joined: Feb 2011
Reputation: 213
Location: germany
Post: #2
This needs to be fixed in the and might be related to changes in mavericks. XBMC has a similar fix for mavericks here

Maybe this might help the developers to fix it ...

AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
find quote
evillevi Offline
Junior Member
Posts: 32
Joined: Jan 2013
Reputation: 0
Post: #3
Thanks Memphiz. I solved the problem by installing mupen64plus, by the way.
find quote