epg not populated from tv_grab_file.xmltv

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
darcywronk Offline
Junior Member
Posts: 7
Joined: Jan 2014
Reputation: 0
Post: #1
I am using mc2xml to create a program listing. It is sitting on my raspberry pi where I am running tvheadend. When tvheadend parses the file I get this:
2014-07-20 09:01:34.673 [ INFO] /usr/bin/tv_grab_file: grab took 6 seconds
2014-07-20 09:01:36.110 [ INFO] /usr/bin/tv_grab_file: parse took 0 seconds
2014-07-20 09:01:36.112 [ INFO] /usr/bin/tv_grab_file: channels tot= 153 new= 0 mod= 0
2014-07-20 09:01:36.115 [ INFO] /usr/bin/tv_grab_file: brands tot= 0 new= 0 mod= 0
2014-07-20 09:01:36.118 [ INFO] /usr/bin/tv_grab_file: seasons tot= 0 new= 0 mod= 0
2014-07-20 09:01:36.121 [ INFO] /usr/bin/tv_grab_file: episodes tot= 0 new= 0 mod= 0
2014-07-20 09:01:36.123 [ INFO] /usr/bin/tv_grab_file: broadcasts tot= 0 new= 0 mod= 0

As you can see, it sees and parses all of the channels, but none of the program information. I have looked at the file and there does appear to be program information in the file. What am I doing wrong?
Thank you!
find quote
Cassiel Offline
Senior Member
Posts: 228
Joined: Jan 2013
Reputation: 4
Location: Germany
Post: #2
Parsing seems okay for channels, but it looks like no other information has been processed.

- Was MC2XML configured correctly?
- Have you tried to open Tvheadend's webif (web interface) in order to assign the XMLTV sources to channels?
find quote