Android - Buffering problem when +4Mb/sec

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
kalouka Offline
Junior Member
Posts: 3
Joined: Aug 2014
Reputation: 0
Post: #1
Hi there, the plugin is working great on my rooted Amazon fireTV, thanks for that, great work ! I'm using Gotham 13.2. I've try with Frodo, Gotham 13 and 13.1 and SPMC.

I'm using Hauppauge Colossus to record from a STB and my video bitrate is set to Variable from 1 to 14 Mb/sec.
On the FireTV i'm wired and I use Tsreader 'cause FFmpeg has video glitch but runs ok.

Here's my problem, XBMC will start to 'eat' buffer if the Mb/sec exceed 4Mb/sec. It's a problem ONLY on the TV side. Even if I watch from a recorded program, same thing. But if I watch recorded program from SMB sharing folder, everything is great, I got 100% in the buffer 'till the end.

I'm able to test any plugin build 'cause my FireTV is rooted,

Here's my advancedsettings.xml

Code:
<advancedsettings>
  <network>
    <buffermode>1</buffermode>
    <cachemembuffersize>20971520</cachemembuffersize>
    <readbufferfactor>2</readbufferfactor>
  </network>
  <video>  
    <stagefright>
      <!--  -1 is default, 0 is never used this codec, 1 is always use this codec, bypassing blacklist -->
      <useavccodec>1</useavccodec>
      <usevc1codec>1</usevc1codec>
      <usevpxcodec>1</usevpxcodec>
      <usemp4codec>0</usemp4codec>
      <usempeg2codec>0</usempeg2codec>
      <useswrenderer>false</useswrenderer>
    </stagefright>
  </video>
</advancedsettings>


Thanks a lot margro for this great plugin.
(This post was last modified: 2014-10-01 19:44 by kalouka.)
find quote
4irm Offline
Junior Member
Posts: 1
Joined: Sep 2014
Reputation: 0
Post: #2
(2014-08-15 14:54)kalouka Wrote:  Hi there, the plugin is working great on my rooted Amazon fireTV, thanks for that, great work ! I'm using Gotham 13.2. I've try with Frodo, Gotham 13 and 13.1 and SMPC.

I'm using Hauppauge Colossus to record from a STB and my video bitrate is set to Variable from 1 to 14 Mb/sec.
On the FireTV i'm wired and I use Tsreader 'cause FFmpeg has video glitch but runs ok.

Here's my problem, XBMC will start to 'eat' buffer if the Mb/sec exceed 4Mb/sec. It's a problem ONLY on the TV side. Even if I watch from a recorded program, same thing. But if I watch recorded program from SMB sharing folder, everything is great, I got 100% in the buffer 'till the end.

I'm able to test any plugin build 'cause my FireTV is rooted,

Here's my advancedsettings.xml

Code:
<advancedsettings>
  <network>
    <buffermode>1</buffermode>
    <cachemembuffersize>20971520</cachemembuffersize>
    <readbufferfactor>2</readbufferfactor>
  </network>
  <video>  
    <stagefright>
      <!--  -1 is default, 0 is never used this codec, 1 is always use this codec, bypassing blacklist -->
      <useavccodec>1</useavccodec>
      <usevc1codec>1</usevc1codec>
      <usevpxcodec>1</usevpxcodec>
      <usemp4codec>0</usemp4codec>
      <usempeg2codec>0</usempeg2codec>
      <useswrenderer>false</useswrenderer>
    </stagefright>
  </video>
</advancedsettings>


Thanks a lot margro for this great plugin.

Have you found a solution yet?

I have same issue, tried all available configs. I read, that adv.conf. does not work for live tv...same impression i got.

BR
find quote
kalouka Offline
Junior Member
Posts: 3
Joined: Aug 2014
Reputation: 0
Post: #3
(2014-10-01 18:32)4irm Wrote:  Have you found a solution yet?

I have same issue, tried all available configs. I read, that adv.conf. does not work for live tv...same impression i got.

BR

Nope, If a developper manifest himself, maybe we'll have a chance to nail the problem down.
find quote
kalouka Offline
Junior Member
Posts: 3
Joined: Aug 2014
Reputation: 0
Post: #4
I'm using the SPMC version 13.3.3 (2014/10/26) since yesterday, and I don't have this buffering problem anymore !!!!

I don't know if it's the Mediaportal PVR plugin version or SPMC that fix the bug but now its fine !
find quote