Solved Issue - XBMC and curl v7.38.0 do not work together - cannot scrape

  Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
mianosm Offline
Junior Member
Posts: 2
Joined: Mar 2014
Reputation: 0
Post: #61
(2014-12-13 10:32)wsnipex Wrote:  There is nothing we can do about it. Report it to fedora.

Clearly, seeing as the fix is an updated libcurl/curl package.

That said - the site is indexed well enough that it came up while searching for other folks that had the same issue that presented itself to me. The only reason for posting and editing is in the hope that someone will find it if they decide that they'll install XBMC/KODI on {Fedora 21}, or some other broken distribution (due to {lib,}curl) today and run into the same issue, and subsequently turn to Google for an answer.

I'd even go so far as suggesting adding a [Solved] to the thread title maybe?
find quote
crpt0 Offline
Junior Member
Posts: 1
Joined: Jun 2015
Reputation: 0
Post: #62
hello,
this is my first post in this forum and i'd like to give u all a step by step guide to downgrade curl on your rpi.

Download the curl version suggested in the first post

Code:
wget http://snapshot.debian.org/archive/debian/20140718T163109Z/pool/main/c/curl/curl_7.37.1-1_armhf.deb
wget http://snapshot.debian.org/archive/debian/20140718T163109Z/pool/main/c/curl/libcurl3_7.37.1-1_armhf.deb
wget http://snapshot.debian.org/archive/debian/20140718T163109Z/pool/main/c/curl/libcurl3-gnutls_7.37.1-1_armhf.deb

Remove new version (with bug) ** only single package witout any dependencies

Code:
sudo dpkg -r --force-depends curl
sudo dpkg -r --force-depends libcurl3-gnutls
sudo dpkg -r --force-depends libcurl3

Install the old version

Code:
sudo dpkg -i libcurl3_7.37.1-1_armhf.deb
sudo dpkg -i libcurl3-gnutls_7.37.1-1_armhf.deb
sudo dpkg -i curl_7.37.1-1_armhf.deb

Put packages on hold to preventig upgrade

Code:
dpkg --get-selections |grep curl
echo "curl hold" | sudo dpkg --set-selections
echo "libcurl3 hold" | sudo dpkg --set-selections
echo "libcurl3-gnutls hold" | sudo dpkg --set-selections
dpkg --get-selections |grep curl

Remove hold

Code:
echo "curl install" | sudo dpkg --set-selections
echo "libcurl3 install" | sudo dpkg --set-selections
echo "libcurl3-gnutls install" | sudo dpkg --set-selections

that's all
bye bye and good night
crpt0

ps
apologize for mistakes, my english needs improvements Tongue
find quote
Post Reply