help req 4 WD My Cloud with xbmc please..

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
sadsack007 Offline
Member
Posts: 88
Joined: Dec 2013
Reputation: 0
Location: UK
Post: #1
Hi chaps....

I've recently purchased a 3tb WD My Cloud Nas to replace my Router attached HD.... (this was being used for an IPad and an ATV2).. both were reading the attached drive through smb. (not very good over wifi with 720p content, kept running out of cache)... but SD content was fine.

I wanted to give NFS a go but (noob time)... this was not that simple, ... with smb i was able to easily show it the directory on the HD (for instance) Movies, and that was that.
but under NFS and if I chose browse, it always came up as blank, ... the same with upnp.

I have managed to get the user guides for the new Nas, but it's all about setting it up through windows,.... and worse of all using twonky, something I really want to stay away from.
I tried it once on my router with a WD Live and after reading just 10 albums it locked up. (Twonky has been disabled ever since).
I assumed probably wrongly, that I could simpy attach said Nas to my router via cat cable, and create folders as I did with my old HD, I.E. Movies, TVShows, Photos and then be able to use NFS to read them rather than smb.
(I'm assuming that NFS is also better for HD content from what I have already read elsewhere).

But I have a feeling that this Nas is not going to allow me to do what I want, ... On the packaging it states Upnp and Dlna....

I have searched and searched for a setup video or even someone who has gone through a similar process using the same equipment, but I've hit a brickwall.

link to full user guide here.. http://www.wdc.com/wdproducts/library/?id=439&type=25

Here is what the share page looks like, [Image: zwyqhg.jpg]

I'm kind of hoping that there must be someone out there that is using one of these units.... So if someone can throw some light on the subject it would be very much appreciated.

many thanks for reading..
sadsack
find quote
wrxtasy Offline
Posting Freak
Posts: 1,357
Joined: Feb 2012
Reputation: 25
Location: Perth, Oz
Post: #2
When adding Videos in Kodi have you selected Zeroconf Browser ?

NFS does not work for me, I have to use Zeroconf on all my Kodi machines to get into the NFS shared folders. Smile

NFS uses less CPU resources, so high bitrate movies that will not work on SMB can be made to play by using NFS.
(This post was last modified: 2015-01-20 16:33 by wrxtasy.)
find quote
shabuboy Offline
Senior Member
Posts: 127
Joined: Apr 2014
Reputation: 4
Location: USA
Post: #3
See if this helps...

http://community.wd.com/t5/WD-My-Cloud/C...d-p/677961

AFTV (non-rooted + FiredTV Launcher + Kodi)
WD My Book Live NAS
find quote
Tinwarble Offline
Fan
Posts: 445
Joined: Mar 2013
Reputation: 13
Post: #4
What firmware version are you running on your My Cloud NAS?

You can try adding the NFS manually. Just type in:

nfs://yourMyCloud_IP/share_name
(This post was last modified: 2015-01-21 04:22 by Tinwarble.)
find quote
sadsack007 Offline
Member
Posts: 88
Joined: Dec 2013
Reputation: 0
Location: UK
Post: #5
Hi chaps...

I am so sorry for the lateness of this reply.....

I would just like to say thank you to those that did reply....

After doing a lot more searching... (I have to admit, this is not the best example, - http://shortattentionspade.com/wd-myclou...ies-movie/ )

I am still not to sure how best to tackle this unit....

After reading that it uses twonky as a media server.... (my router had that enabled and it turned 20 mp3's and 10 700mb SD movies into a nothing more than hell, until I realized I could turn it off and just map the drive connected to my router).

I have also read that it wants to add icon's to everything you add to the unit, and also wants to index everything as well.... and god forbid one might want to move a file....

Has that been everybody's elses experience with these units....
I've looked at all of WD video's on youtube,... (mostly promotional hype).

p.s.
I have to admit I have not checked the FW version on this unit yet, as I really want to be sure of what I'm doing first.
As I've read also that updating the FW on these is not always the best thing to do.. although I'm not to sure why, I vagely remember reading that an update removes something that makes the unit worse...

Is there anyone out there that is using one of these on Helix 14.0 (and is still smiling).

All I wanted to do was to create the same as I had on my router connected HD, (Movies) (TV Shows) (Music) (Photos) folders.... But do all these folders have to be created within the "Public" folder using the WD downloaded software.

And If I can use SMB on this unit I'm going to stick with SMB, It works well from my router connected HD will stream anything even 4gb + mkv movies over wifi to a ATV2.

Appreciate any help from a user of these units of any Nas user come to that....
thanks chaps...

sadsack...

p.p.s if anyone is wondering why I don't just keep the router connected HD, ... well everytime i have a powercut, or the electric trips out, everything on the HD becomes corrupted, it seems many routers that use USB to connect hard drives all suffer from a similar problem.
find quote